User Tag List

Reply
 
Thread Tools Rating: Thread Rating: 5 votes, 4.20 average. Display Modes
Old 06-06-2004, 09:03 PM #1
crainmain crainmain is offline
Junior Member
 
Join Date: Jun 2004
Posts: 5
crainmain is an unknown quantity at this point
crainmain crainmain is offline
Junior Member
 
Join Date: Jun 2004
Posts: 5
crainmain is an unknown quantity at this point
Question Check engine light, VSC TRAC & TRAC OFF lights

Hello,
New to this site, looking for help. I have a 2001 SR5 2WD 4runner w/TRD supercharger, 40,000 miles. I just bought it, and a few days later the check engine light, VSC TRAC, and TRAC OFF lights all came on. I took it to a dealership and was told the codes were: P0440, P0441, and P0446. I looked them up and they were all for the EVAP system. I was told by them that the codes were for some sort of oil temp sensor, (this is before I looked them up). I am, needless to say taking it back to have a talk with them. What my question is, is there any way that all those lights would come on for those codes? It sounds to me that that system would only kick on the check engine light, and the VSC TRAC and TRAC OFF lights are another problem, maybe I'm wrong. The dealer did reset the computer and the codes went away for a few days, then all 3 came back on together. Does anyone have any experience with this? Thanks for any help you can give.
crainmain is offline   Reply With QuoteReply With Quote
Old 07-06-2004, 03:11 PM #2
theMarc theMarc is offline
Junior Member
 
Join Date: Jul 2004
Posts: 1
theMarc is an unknown quantity at this point
theMarc theMarc is offline
Junior Member
 
Join Date: Jul 2004
Posts: 1
theMarc is an unknown quantity at this point
i have a 2001 Ltd 4WD, 37000 miles and the same lights just came up for me - i haven't gone to the dealership but was checking here to see if that was some kind of maintenance reminder that could be reset - anyone else dealt with that?
theMarc is offline   Reply With QuoteReply With Quote
Old 07-16-2004, 04:06 AM #3
crainmain crainmain is offline
Junior Member
 
Join Date: Jun 2004
Posts: 5
crainmain is an unknown quantity at this point
crainmain crainmain is offline
Junior Member
 
Join Date: Jun 2004
Posts: 5
crainmain is an unknown quantity at this point
Dear themarc,
We took the truck into the dealership, and they changed out a valve on top of the fuel tank for the EVAP emmissions control system, (don't remember the name of the valve), and the truck has been running perfect ever since, no lights since. Try that, I believe the valve is cheap and easy to replace. I'm in Germany here, and we paid 44 euro for the change, which should be much more expensive than in the states. Good luck.
crainmain is offline   Reply With QuoteReply With Quote
Old 07-16-2004, 12:26 PM #4
Good Times's Avatar
Good Times Good Times is offline
Senior Member
 
Join Date: Jan 2003
Location: Sunny Socal
Posts: 1,657
Good Times is an unknown quantity at this point
Good Times Good Times is offline
Senior Member
Good Times's Avatar
 
Join Date: Jan 2003
Location: Sunny Socal
Posts: 1,657
Good Times is an unknown quantity at this point
evap codes are common. I had this happen on my 4th gen as well.

easy to fix as all they need to do is determine where the problem is and either clean it out of replace the item and you're set

They also have to clear the codes so the computer won't show the old errors though (dealers do forget so make sure).
Good Times is offline   Reply With QuoteReply With Quote
Old 07-20-2004, 01:25 PM #5
dredhaus's Avatar
dredhaus dredhaus is offline
Member
 
Join Date: Jul 2004
Location: Palmer Twp., PA
Posts: 55
dredhaus is an unknown quantity at this point
dredhaus dredhaus is offline
Member
dredhaus's Avatar
 
Join Date: Jul 2004
Location: Palmer Twp., PA
Posts: 55
dredhaus is an unknown quantity at this point
I am having the same problem with the VSC TRAC and VSC TRAC OFF along with the engine light. Is this part easy to change? After it is changed do I then have to take it to a dealer and have them clear the codes in the computer? Is there any other way to do this?
dredhaus is offline   Reply With QuoteReply With Quote
Old 07-20-2004, 01:40 PM #6
Good Times's Avatar
Good Times Good Times is offline
Senior Member
 
Join Date: Jan 2003
Location: Sunny Socal
Posts: 1,657
Good Times is an unknown quantity at this point
Good Times Good Times is offline
Senior Member
Good Times's Avatar
 
Join Date: Jan 2003
Location: Sunny Socal
Posts: 1,657
Good Times is an unknown quantity at this point
dredhaus:

I'd take your 4runner into the dealer and have them find what codes are causing the problem. It is most likely an evap issue but it can be other problems.

You can goto Autozone to get codes for the problem but you'd have to take it into the dealer to fix the problem. It should be a warranty repair so I wouldn't worry about it. It'll take em a day to check and order the part and then replace it (so 2 days total of downtime). The dealer will clear the codes after they are done btw.

If your dealer is cool, they might be able to give you a loaner for the time being.

Good luck!
Good Times is offline   Reply With QuoteReply With Quote
Old 08-04-2004, 12:47 PM #7
dredhaus's Avatar
dredhaus dredhaus is offline
Member
 
Join Date: Jul 2004
Location: Palmer Twp., PA
Posts: 55
dredhaus is an unknown quantity at this point
dredhaus dredhaus is offline
Member
dredhaus's Avatar
 
Join Date: Jul 2004
Location: Palmer Twp., PA
Posts: 55
dredhaus is an unknown quantity at this point
I just got a code of P01135. Toyota said it is an air fuel sensor that has gone bad. The price they quoted me is $431. Is that good? Can I get this part somehwere else for cheaper?
__________________
2001 SR5
Dueler A/T Revo 265/70/16
new addition: T4R.ORG sticker ! haha
dredhaus is offline   Reply With QuoteReply With Quote
Old 08-04-2004, 12:50 PM #8
Good Times's Avatar
Good Times Good Times is offline
Senior Member
 
Join Date: Jan 2003
Location: Sunny Socal
Posts: 1,657
Good Times is an unknown quantity at this point
Good Times Good Times is offline
Senior Member
Good Times's Avatar
 
Join Date: Jan 2003
Location: Sunny Socal
Posts: 1,657
Good Times is an unknown quantity at this point
has your warranty expired? i'd try to see if they can get it done under somekind of warranty or related TSB fix.

if all else fails, you're gonna have to just fork up the $$
Good Times is offline   Reply With QuoteReply With Quote
Old 08-04-2004, 06:03 PM #9
dredhaus's Avatar
dredhaus dredhaus is offline
Member
 
Join Date: Jul 2004
Location: Palmer Twp., PA
Posts: 55
dredhaus is an unknown quantity at this point
dredhaus dredhaus is offline
Member
dredhaus's Avatar
 
Join Date: Jul 2004
Location: Palmer Twp., PA
Posts: 55
dredhaus is an unknown quantity at this point
My warranty did expire. I got it fixed though and all should be well tomorrow (they put the wrong tires on)!
__________________
2001 SR5
Dueler A/T Revo 265/70/16
new addition: T4R.ORG sticker ! haha
dredhaus is offline   Reply With QuoteReply With Quote
Old 11-29-2005, 10:28 PM #10
Aramis11 Aramis11 is offline
Junior Member
 
Join Date: Nov 2005
Location: SE U.S.
Age: 56
Posts: 1
Aramis11 is an unknown quantity at this point
Aramis11 Aramis11 is offline
Junior Member
 
Join Date: Nov 2005
Location: SE U.S.
Age: 56
Posts: 1
Aramis11 is an unknown quantity at this point
Exclamation P0440 Code

I stumbled on this forum looking for diagnostics for this fault. For what it is worth, the Check Engine lamp and this code did coincide with a Traction Control fault. The systems should not be related other than both having ECM codes. Anyone have the traction system lamps go away after repairing for the EVAP problem?
Aramis11 is offline   Reply With QuoteReply With Quote
Old 10-20-2006, 05:14 PM #11
Scot37027 Scot37027 is offline
Junior Member
 
Join Date: Oct 2006
Posts: 2
Scot37027 is an unknown quantity at this point
Scot37027 Scot37027 is offline
Junior Member
 
Join Date: Oct 2006
Posts: 2
Scot37027 is an unknown quantity at this point
Post VSC TRAC & TRAC OFF Lights

New User here and this site is a good find!
Same problem has occured on a 02 4runner I have w 105k miles. Checked the code and is P0440 x's 3 Evap Emissions Control Systems Malfunction. Autozone tech said is called a triple twin code P0440 listed 3 times same definition. Just topped off with gas and cap/seal tight/good. Recently had a new sound system installed and amp placed under the drivers seat. The problem happened in this sequence. I turned on the etc power button 5 min later while driving check engine and close behind the VSC TRAC & TRAC OFF lights came on. Could this be a wire off or sensor gone bad, or even a vacuum hose if so where should I look with this code? Thank you for any help as I try to do and can do most repairs myself.
__________________
S(ot
Scot37027 is offline   Reply With QuoteReply With Quote
Old 11-01-2006, 05:35 PM #12
snichols snichols is offline
Junior Member
 
Join Date: Nov 2006
Posts: 2
snichols is an unknown quantity at this point
snichols snichols is offline
Junior Member
 
Join Date: Nov 2006
Posts: 2
snichols is an unknown quantity at this point
VSC TRAC, TRAC OFF lights -- I'm an idiot

The same thing happened to me today, in my 02 4Runner -- VSC TRAC, TRAC OFF and CHeck ENGINE lights all appeared. So I went to my local dealer, and the first the tech did was check out my gas cap. Sure enough, it was loose.

Tech guaranteed that caused the problem -- also, he said the lights will go out after a week or so.

Steve Nichols
snichols is offline   Reply With QuoteReply With Quote
Old 11-01-2006, 07:10 PM #13
Scot37027 Scot37027 is offline
Junior Member
 
Join Date: Oct 2006
Posts: 2
Scot37027 is an unknown quantity at this point
Scot37027 Scot37027 is offline
Junior Member
 
Join Date: Oct 2006
Posts: 2
Scot37027 is an unknown quantity at this point
Smile

Yesterday I found out what the problem was.......
I had originally taken the 4runner in for a recall of the ball joint and was needed all day to replace parts plus 4 wheel alignment. I handed the service tech the codes I had and the closest possible answer to what the problem could be, from research on this site. He informed me that the test was near $90 to find out what was going on. Another $90 to recheck. They tested and got the same answer I gave them and put a new canister on the 4runner. Tech tested and it was fine. Shop foreman tested and it was failing. This is day 2 by the way with out my car. Then then traced the complete path of the vacuum lines and found the installation of the amp under the drivers seat is what caused the issue. The Best Buy install tech had drilled thru the floor into the vacuum hose. I had looked under the hood for a loose vacuum hose or broken and found nothing. Dealer returned my old canister and retested. This cost $444.00. Went to Best Buy and demanded a fix to my problem immediateley. Took some time to walk the manager trainee thru the whole process and how he was liable. I walked out with what was owed. I had noway of knowing what caused the problem but had a feeling it was somehow relted to the stereo system install.
__________________
S(ot
Scot37027 is offline   Reply With QuoteReply With Quote
Old 02-14-2007, 10:37 PM #14
KNOBmeister's Avatar
KNOBmeister KNOBmeister is offline
Junior Member
 
Join Date: Dec 2004
Location: Elbert, Colorado USA
Age: 71
Posts: 29
KNOBmeister is an unknown quantity at this point
KNOBmeister KNOBmeister is offline
Junior Member
KNOBmeister's Avatar
 
Join Date: Dec 2004
Location: Elbert, Colorado USA
Age: 71
Posts: 29
KNOBmeister is an unknown quantity at this point
Angry Re: VSC TRAC, TRAC OFF lights -- I'm an idiot

Quote:
Originally posted by snichols
The same thing happened to me today, in my 02 4Runner -- VSC TRAC, TRAC OFF and CHeck ENGINE lights all appeared. So I went to my local dealer, and the first the tech did was check out my gas cap. Sure enough, it was loose.

Tech guaranteed that caused the problem -- also, he said the lights will go out after a week or so.

Steve Nichols
Mine's still on ......... almost a month and still both lights are still on

Gas Cap is tight ......

Mine is a 04 4Runner .......
Suggestions?


Joe
__________________
2004 Toyota 4Runner V8 "Goldie" 3x Hella 500
1998 Chev Van "QEII" 5x Hella 500
1997 Honda Civic "Pearl" 2x Hella 500
1991 Miata "KNOBzilla" 2x Hella 550
1985 CJ7 "MudMagnet" 2x Hella 500
[I'm a light nut!]
KNOBmeister is offline   Reply With QuoteReply With Quote
Old 03-07-2007, 07:53 PM #15
a77boy a77boy is offline
Member
 
Join Date: Feb 2007
Location: Texas
Posts: 121
a77boy is an unknown quantity at this point
a77boy a77boy is offline
Member
 
Join Date: Feb 2007
Location: Texas
Posts: 121
a77boy is an unknown quantity at this point
Did you lights ever go out? mine are doing the same thing. '03 4 runner sr5 with V8
a77boy is offline   Reply With QuoteReply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
One cause & fix for "VSC TRAC" & "VSC OFF" lights, Zero Point Calibration MicaBlue03 Problems & Warranty Issues 279 06-10-2019 02:39 PM
Check Engine + VSC OFF + VSC Traction lights all came on?! Bamboozler 3rd gen T4Rs 6 01-24-2017 04:40 PM
Check Engine Light Won't Stop Reappearing At High Speed!! kabhunt 3rd gen T4Rs 15 12-13-2010 01:34 PM
Intermittent Check engine light??? 4RunnerSC Classic T4Rs 5 01-12-2009 11:49 PM
Check Engine & VSC Lights Come on; now off Mtneer001 4th Gen T4Rs 5 11-12-2007 11:43 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 03:02 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2019


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.