User Tag List

Reply
 
Thread Tools Rate Thread Display Modes
Old 08-14-2014, 01:17 PM #1
Hesk11dog's Avatar
Hesk11dog Hesk11dog is offline
Member
 
Join Date: Jul 2014
Location: Brookville, PA
Posts: 137
Hesk11dog is on a distinguished road
Hesk11dog Hesk11dog is offline
Member
Hesk11dog's Avatar
 
Join Date: Jul 2014
Location: Brookville, PA
Posts: 137
Hesk11dog is on a distinguished road
cruise control problems

I have a 97 limited, 2.5'' coil spacers with 265/75/16's. It is my daily driver and I take it on 2 hour trips every other week. The cruise control light on the dash lights up when I hit the button but it will not set the speed when i pull it down. Not sure if it is the CC module or just a wiring issue. I am new to this forum and it is freaking sweet.
Hesk11dog is offline   Reply With QuoteReply With Quote
Old 08-14-2014, 01:55 PM #2
jkoni426 jkoni426 is offline
Member
 
Join Date: Jul 2012
Location: MD
Posts: 185
Real Name: Joe
jkoni426 is on a distinguished road
jkoni426 jkoni426 is offline
Member
 
Join Date: Jul 2012
Location: MD
Posts: 185
Real Name: Joe
jkoni426 is on a distinguished road
Welcome, is the CEL on?
__________________
'99 T4R SR5 V6 4WD Imperial Jade Mica | B&M Trans Cooler | KYB Gas-a-Justs | URD O2 Sim | 199mm TBU
jkoni426 is offline   Reply With QuoteReply With Quote
Old 08-14-2014, 02:00 PM #3
Hesk11dog's Avatar
Hesk11dog Hesk11dog is offline
Member
 
Join Date: Jul 2014
Location: Brookville, PA
Posts: 137
Hesk11dog is on a distinguished road
Hesk11dog Hesk11dog is offline
Member
Hesk11dog's Avatar
 
Join Date: Jul 2014
Location: Brookville, PA
Posts: 137
Hesk11dog is on a distinguished road
No it hasn't came on because of that, thought it would throw a code but never did. I started checking some of the wires but didnt find anything unusual.
Hesk11dog is offline   Reply With QuoteReply With Quote
Old 08-14-2014, 02:21 PM #4
jkoni426 jkoni426 is offline
Member
 
Join Date: Jul 2012
Location: MD
Posts: 185
Real Name: Joe
jkoni426 is on a distinguished road
jkoni426 jkoni426 is offline
Member
 
Join Date: Jul 2012
Location: MD
Posts: 185
Real Name: Joe
jkoni426 is on a distinguished road
this should get you heading in the right direction:

http://tacoma.site40.net/4Runner_96-...sdenma/pst.pdf
__________________
'99 T4R SR5 V6 4WD Imperial Jade Mica | B&M Trans Cooler | KYB Gas-a-Justs | URD O2 Sim | 199mm TBU
jkoni426 is offline   Reply With QuoteReply With Quote
Old 08-14-2014, 02:29 PM #5
Hesk11dog's Avatar
Hesk11dog Hesk11dog is offline
Member
 
Join Date: Jul 2014
Location: Brookville, PA
Posts: 137
Hesk11dog is on a distinguished road
Hesk11dog Hesk11dog is offline
Member
Hesk11dog's Avatar
 
Join Date: Jul 2014
Location: Brookville, PA
Posts: 137
Hesk11dog is on a distinguished road
looks like it is this, i would like to fix it without going to a dealership but if it is the ECM, I'm screwed on that end
Attached Images
cruise control problems-problem-jpg 
Hesk11dog is offline   Reply With QuoteReply With Quote
Old 08-14-2014, 03:04 PM #6
jkoni426 jkoni426 is offline
Member
 
Join Date: Jul 2012
Location: MD
Posts: 185
Real Name: Joe
jkoni426 is on a distinguished road
jkoni426 jkoni426 is offline
Member
 
Join Date: Jul 2012
Location: MD
Posts: 185
Real Name: Joe
jkoni426 is on a distinguished road
if you have a multimeter I'd start with troubleshooting the control switch circuit:

http://tacoma.site40.net/4Runner_96-...a/controls.pdf

if it is the ecm, you can probably find one on ebay pretty cheap. good luck
__________________
'99 T4R SR5 V6 4WD Imperial Jade Mica | B&M Trans Cooler | KYB Gas-a-Justs | URD O2 Sim | 199mm TBU
jkoni426 is offline   Reply With QuoteReply With Quote
Old 08-15-2014, 09:14 AM #7
kball's Avatar
kball kball is offline
Senior Member
 
Join Date: Jul 2009
Location: SoCal
Posts: 1,785
kball is on a distinguished road
kball kball is offline
Senior Member
kball's Avatar
 
Join Date: Jul 2009
Location: SoCal
Posts: 1,785
kball is on a distinguished road
Do your brake lights work? If they aren't the cruise won't set.
__________________
1996 SR5 4Runner V6 4WD Auto
Toytec Ultimate w/ OME 890's plus 1.5" daystar spacer
60028 OME shocks, Goodyear Duratracs 265/75 -16
B&M 70268 with Magnefine filter, 199mm TBU
236K miles
kball is offline   Reply With QuoteReply With Quote
Old 08-15-2014, 01:39 PM #8
Frey's Avatar
Frey Frey is offline
Member
 
Join Date: Jul 2012
Location: Louisiana
Posts: 56
Frey is on a distinguished road
MY GARAGE
Frey Frey is offline
Member
Frey's Avatar
 
Join Date: Jul 2012
Location: Louisiana
Posts: 56
Frey is on a distinguished road
MY GARAGE
Quote:
Originally Posted by Hesk11dog View Post
looks like it is this, i would like to fix it without going to a dealership but if it is the ECM, I'm screwed on that end
My '97 has a similar issue. Sometimes it works as it should, more often it doesn't work at all. Thanks @jkoni426 for posting that diagram!
__________________
Frey // TLCA# 21125
2002 4Runner SR5 3.4L V6 4x4 Auto
2003 GX470 4.7L V8
SOLD: 1997 4Runner SR5 3.4L V6 4x4 5-speed Manual E-Locker
Frey is offline   Reply With QuoteReply With Quote
Old 08-15-2014, 05:18 PM #9
Scramble's Avatar
Scramble Scramble is offline
Elite Member
 
Join Date: Mar 2006
Location: Monroe, NY
Posts: 5,674
Real Name: Scramble
Scramble will become famous soon enough
MY GARAGE
Scramble Scramble is offline
Elite Member
Scramble's Avatar
 
Join Date: Mar 2006
Location: Monroe, NY
Posts: 5,674
Real Name: Scramble
Scramble will become famous soon enough
MY GARAGE
Thumbs up

My CC hasn't worked in years. I just bought an ECU off E-Bay for $30. That should fix it. Thanks for this thread.
__________________
____________

'99 4Runner - 2.7L 3RZ, 5 Speed, 4.56 Gears - Lifted, Locked & Loaded - 166k Original owner - http://www.toyota-4runner.org/3rd-ge...ld-thread.html
'99 Limited - E-Locker- Stock (for now) - 233k 2nd Owner http://www.toyota-4runner.org/3rd-ge...ted-build.html

Last edited by Scramble; 08-15-2014 at 11:00 PM.
Scramble is offline   Reply With QuoteReply With Quote
Old 08-15-2014, 05:25 PM #10
shotgun_willie shotgun_willie is offline
Member
 
Join Date: Aug 2014
Location: Tampa
Posts: 48
shotgun_willie is on a distinguished road
shotgun_willie shotgun_willie is offline
Member
 
Join Date: Aug 2014
Location: Tampa
Posts: 48
shotgun_willie is on a distinguished road
I just purchased my 97 and have had a similar issue. Mine is a 5-speed and for some reason the cruise control won't always work but if I sort of push the clutch pedal left and right with my foot it will start working. Not sure why it happens or why that works, just the advice the PO gave me and it works, so if you have the 5-speed that might help you out.
shotgun_willie is offline   Reply With QuoteReply With Quote
Old 08-15-2014, 10:51 PM #11
kball's Avatar
kball kball is offline
Senior Member
 
Join Date: Jul 2009
Location: SoCal
Posts: 1,785
kball is on a distinguished road
kball kball is offline
Senior Member
kball's Avatar
 
Join Date: Jul 2009
Location: SoCal
Posts: 1,785
kball is on a distinguished road
Quote:
Originally Posted by shotgun_willie View Post
I just purchased my 97 and have had a similar issue. Mine is a 5-speed and for some reason the cruise control won't always work but if I sort of push the clutch pedal left and right with my foot it will start working. Not sure why it happens or why that works, just the advice the PO gave me and it works, so if you have the 5-speed that might help you out.
Same reason I asked the OP about his brakes. There's a sensor/switch down at the pedal, and on manual trans they're on both the brake and clutch pedals. Your sensor is bad so the CC thinks you have the clutch pushed in which would over rev the engine if the cruise stayed on obviously.
__________________
1996 SR5 4Runner V6 4WD Auto
Toytec Ultimate w/ OME 890's plus 1.5" daystar spacer
60028 OME shocks, Goodyear Duratracs 265/75 -16
B&M 70268 with Magnefine filter, 199mm TBU
236K miles
kball is offline   Reply With QuoteReply With Quote
Old 08-16-2014, 11:13 AM #12
TRDteen's Avatar
TRDteen TRDteen is offline
Senior Member
 
Join Date: Aug 2012
Location: Aliso Viejo,CA
Age: 23
Posts: 1,118
Real Name: Matt
TRDteen is on a distinguished road
TRDteen TRDteen is offline
Senior Member
TRDteen's Avatar
 
Join Date: Aug 2012
Location: Aliso Viejo,CA
Age: 23
Posts: 1,118
Real Name: Matt
TRDteen is on a distinguished road
With my 5-speed 3rd gen, I have to pull the clutch ALL THE WAY OUT with my foot for the cc to work. If the clutch isnt all the way pulled back, the cruise control light will still come on, but it wont set.
__________________
Tread lightly and see you guys on the trail.
'99 Build Thread: http://www.toyota-4runner.org/3rd-ge...ld-thread.html
'98 Build Thread: http://www.toyota-4runner.org/3rd-ge...ld-thread.html
TRDteen is offline   Reply With QuoteReply With Quote
Old 08-18-2014, 12:09 AM #13
Hesk11dog's Avatar
Hesk11dog Hesk11dog is offline
Member
 
Join Date: Jul 2014
Location: Brookville, PA
Posts: 137
Hesk11dog is on a distinguished road
Hesk11dog Hesk11dog is offline
Member
Hesk11dog's Avatar
 
Join Date: Jul 2014
Location: Brookville, PA
Posts: 137
Hesk11dog is on a distinguished road
Quote:
Originally Posted by kball View Post
Do your brake lights work? If they aren't the cruise won't set.
My brake lights do work. It sounds like 5 speed T4R's have a bit of a problem with the CC. I'll try the peddle jig tomorrow and the millimeter checking connections if that fails. Thanks for all the help, who needs cruise control anyway
Hesk11dog is offline   Reply With QuoteReply With Quote
Old 04-20-2019, 10:25 AM #14
Stephen363 Stephen363 is offline
Junior Member
 
Join Date: Apr 2019
Location: Colorado Springs, CO
Age: 47
Posts: 11
Real Name: Mark
Stephen363 is on a distinguished road
Stephen363 Stephen363 is offline
Junior Member
 
Join Date: Apr 2019
Location: Colorado Springs, CO
Age: 47
Posts: 11
Real Name: Mark
Stephen363 is on a distinguished road
Cruise control issue revisited- New problem

Hey guys,
I'm new to the forum so please excuse me if I miss something here. I also cannot post a new thread yet, so this is the closest one I found. To preface my question, I've read through all the threads i could find and even used the alternate search tool on the home page but haven't found anything that has helped resolve my problem. I have a 1998 T4R, 4x4, 3.4L V6, with auto transmission and the Ford cruise control (as opposed to the Denso one the shop manual mentions is available). My problem is that the CC light will come on when engaged in park. The light will stay on when placed in drive but CC will not engage. If turned off while in drive it will not turn back on. It cannot be turned on at all when in drive. Here is what I've tried:
1. checked all fuses based on shop manual and these threads
2. Brake light (stop light) switch has been changed and checked for proper clearance. All lights work ok
3. Cable from CC computer to throttle body not binding or deformed
4. CC computer connector and wires appear to be fine
5. No codes at all appear on ECM with code reader. No fault lights or any other abnormal indications from the vehicle of any kind.
6. I have not checked the basic functions of the CC switch yet because i know the on/off switch works and until I can get it to turn on/off in drive the other functions are of secondary concern (I think...).

The troubleshooting guide in the shop manual is a little confusing and appears to need a couple of special tools, most importantly an inline connector to allow for voltage/signal readings (if I'm understanding it correctly). My final thought is to just take it to Toyota and see if they can find the problem, but wanted to check the vast knowledge base here first. Any help or suggestions is greatly appreciated.
Stephen363 is offline   Reply With QuoteReply With Quote
Old 04-21-2019, 08:32 AM #15
DaMonkey's Avatar
DaMonkey DaMonkey is offline
Member
 
Join Date: Feb 2017
Location: MN
Posts: 341
DaMonkey will become famous soon enough
DaMonkey DaMonkey is offline
Member
DaMonkey's Avatar
 
Join Date: Feb 2017
Location: MN
Posts: 341
DaMonkey will become famous soon enough
Quote:
Originally Posted by TRDteen View Post
With my 5-speed 3rd gen, I have to pull the clutch ALL THE WAY OUT with my foot for the cc to work. If the clutch isnt all the way pulled back, the cruise control light will still come on, but it wont set.
Mine had this for a few years after I bought it. Turned out to be internal leak in slave which then became a driveability issue. Dangerous and a truck became a menace. Very easy to swap in new mc sc, it fixed it real buttery like.
__________________
rock beats scissors. zip ties beat clips.

www.maluna.com - Scott
DaMonkey is offline   Reply With QuoteReply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 4th gen cruise control problems SikSemper 4th Gen T4Rs 6 12-17-2017 03:34 PM
Cruise Control light doesn't come on and Cruise doesn't work. CZ Eddie 3rd gen T4Rs 8 12-15-2012 08:09 PM
Cruise Control 4runnertank Classic T4Rs 2 03-07-2012 10:25 AM
Cruise Control problems 95 charhil63 Classic T4Rs 6 06-25-2011 08:19 PM
Cruise control GatorGreg Off Topic 1 06-27-2005 11:59 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 06:30 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2019


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.