User Tag List

Reply
 
Thread Tools Rate Thread Display Modes
Old 03-26-2019, 04:16 PM #16
lefty556 lefty556 is offline
Member
 
Join Date: Jan 2019
Location: Fort Worth, TX
Posts: 36
lefty556 is on a distinguished road
lefty556 lefty556 is offline
Member
 
Join Date: Jan 2019
Location: Fort Worth, TX
Posts: 36
lefty556 is on a distinguished road
I've got a bit more info to add. I had a co-worker go to lunch with me today, so I had someone that could keep an eye on the OBD Fusion app on my iPhone while I was driving.

The surging issue occurs in all gears when I can hold it between 1900 and 2200 RPM. It's worse in 2nd and 3rd than it is anywhere else, but it occurs in every gear.

In park or neutral, I can easily rev the engine to the redline. In gear, not so much. If I stand on the accelerator, it'll get to 3000 RPM, but barely, and not quickly.

When the surging occurs, the Bank 1, sensor 2 O2 sensor voltage drops down to the .1-.2 volt range. When I gas it to get out of the surge, the O2 sensor reads between .6 and .8 volts, depending on how much I'm on the throttle.

The exhaust leak is apparently getting worse, as it is louder today than it was over the weekend.

No codes showing as set or pending at this time.

Anybody have any idea on what I should look into?
__________________
2000 Silver SR5 4X4
lefty556 is offline   Reply With QuoteReply With Quote
Old 04-06-2019, 10:04 AM #17
lefty556 lefty556 is offline
Member
 
Join Date: Jan 2019
Location: Fort Worth, TX
Posts: 36
lefty556 is on a distinguished road
lefty556 lefty556 is offline
Member
 
Join Date: Jan 2019
Location: Fort Worth, TX
Posts: 36
lefty556 is on a distinguished road
So I replaced both cats, the A/F sensor and the O2 sensor last night. Holy crap! the difference is astounding!

The surging is, so far, gone. The 4Runner will accelerate going uphill now. I can easily hit 70-80 on the highway now. Looks like the problem is solved!
__________________
2000 Silver SR5 4X4
lefty556 is offline   Reply With QuoteReply With Quote
Old 04-06-2019, 01:23 PM #18
JRZEE2000TR4LTD's Avatar
JRZEE2000TR4LTD JRZEE2000TR4LTD is offline
Senior Member
 
Join Date: Mar 2014
Location: New Jersey
Age: 57
Posts: 1,963
Real Name: John
JRZEE2000TR4LTD will become famous soon enough JRZEE2000TR4LTD will become famous soon enough
JRZEE2000TR4LTD JRZEE2000TR4LTD is offline
Senior Member
JRZEE2000TR4LTD's Avatar
 
Join Date: Mar 2014
Location: New Jersey
Age: 57
Posts: 1,963
Real Name: John
JRZEE2000TR4LTD will become famous soon enough JRZEE2000TR4LTD will become famous soon enough
Quote:
Originally Posted by lefty556 View Post
So I replaced both cats, the A/F sensor and the O2 sensor last night. Holy crap! the difference is astounding!

The surging is, so far, gone. The 4Runner will accelerate going uphill now. I can easily hit 70-80 on the highway now. Looks like the problem is solved!
That's great. Kind of an expensive part chuck but as long as it's fixed it's all good. Assume you used AM cats. Which ones did you use? Walker? Bosal?
And hopefully you used Denso sensors.
__________________
SILVER 2000 4runner Limited TOTALED
WHITE/SILVER 1999 4runner Limited l Rear Locker l Tundra/890 coils | 5100 Bilsteins all around | Sonoran Steel Bumpstops l 199 mm Tundra brake upgrade | SCS Matte Gray Ray10 Rims | 275 70 17 BFG KO2 tires | LR UCAs | EIMKEITH panhard brackets | LED interior upgrade l Rear LED tailights l Pioneer AVH-X5700BHS Alpine Type "R" speakers NVX JAD800.4 Class D Amp Kenwood Under seat Subwoofer l Front window tint 20% l Weathertech window visors and floormats l OutGear Solutions Full Length roofrack l Morimoto 40" LED lightbar
JRZEE2000TR4LTD is offline   Reply With QuoteReply With Quote
Old 04-06-2019, 06:45 PM #19
lefty556 lefty556 is offline
Member
 
Join Date: Jan 2019
Location: Fort Worth, TX
Posts: 36
lefty556 is on a distinguished road
lefty556 lefty556 is offline
Member
 
Join Date: Jan 2019
Location: Fort Worth, TX
Posts: 36
lefty556 is on a distinguished road
Quote:
Originally Posted by JRZEE2000TR4LTD View Post
That's great. Kind of an expensive part chuck but as long as it's fixed it's all good. Assume you used AM cats. Which ones did you use? Walker? Bosal?
And hopefully you used Denso sensors.
I went with Walker for the cats and Denso for the sensors.
__________________
2000 Silver SR5 4X4
lefty556 is offline   Reply With QuoteReply With Quote
Reply

Tags
ago , air , engine , miles , premium

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 10:31 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2024 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2024 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2024 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2020