User Tag List

Reply
 
Thread Tools Rate Thread Display Modes
Old 12-09-2019, 07:55 PM #1
connormonty connormonty is offline
Junior Member
 
Join Date: Aug 2018
Location: NY
Posts: 9
connormonty is on a distinguished road
connormonty connormonty is offline
Junior Member
 
Join Date: Aug 2018
Location: NY
Posts: 9
connormonty is on a distinguished road
CDL problems...

Hey guys, fairly new to posting here but need help figuring this out!

I have a 2001 4runner sr5 4wd. Ive only had it for about 6 months and with winter rolling around 4wd has been on my mind. The car has about 230k on the body but the engine is fairly new.

Anyway, I've been having problems with the 4wd lately. Last week the 4wd on the fly button wasn't working so after reading forums and doing some research I flushed and refilled both the front and rear diff last week. That seemed to help as now the 4wd on the fly button works 9/10 times on engaging the AWD feature.

However, now im having problems with the CDL. After I press the button and work it into 4Hi by driving forward or reverse it'll eventually lock. The yellow light on the dash in the center becomes solid. Its locked and the VSC off light comes on too. However a few seconds later, maybe 10 or so, the dash lights start flashing, the VSC off light disappears and the vehicle goes back to just the 4 green wheel lights being on...

Cant find anything on this so please help!
connormonty is offline   Reply With QuoteReply With Quote
Reply

Tags
4wd , button , light , problems , vsc

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
problems, problems, just about in tears venusdelovely 4th Gen T4Rs 3 07-30-2015 11:55 PM
Ran it out of gas- problems now! Antman 5th gen T4Rs 49 04-02-2014 02:29 PM
AC Problems dezrtdwelr Problems & Warranty Issues 2 03-05-2014 06:19 AM
99 Problems 4Runner7 3rd gen T4Rs 6 06-26-2013 11:24 PM
o2 sensor problems and alignment problems jjlemus1 Classic T4Rs 34 06-01-2011 02:35 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 12:28 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2019


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.