User Tag List

Reply
 
Thread Tools Rate Thread Display Modes
Old 03-10-2020, 11:54 AM #16
jmacqueen's Avatar
jmacqueen jmacqueen is offline
Junior Member
 
Join Date: Aug 2007
Posts: 9
jmacqueen is on a distinguished road
jmacqueen jmacqueen is offline
Junior Member
jmacqueen's Avatar
 
Join Date: Aug 2007
Posts: 9
jmacqueen is on a distinguished road
Well I didn't find any problems with the power circuits going to the ECU, so yesterday when the ebay used ECU showed up I swapped them out, truck started and ran fine for 30 minutes, all the PIDs on the scanner looked good.. I didn't test drive because it was raining all day and I didn't want to take a chance on being stuck on the side of the road in the rain.

This morning I fired it up, drove 15 miles or so, truck is running great. So it seems the ECU was just intermittently cutting out internally on it's way out and is bad.

Still have the new fuel filter to install, even if it isn't plugged up it is overdue for a change.

It's definitely about time for me to do some projects, valve cover gaskets, timing belt and associated gear, replace cooling and vacuum hoses, and a few other things before moving on to a new paint job, carpet, headliner and upholstery etc. and finally replace my sagging rear springs. I don't see any new vehicles I like better than my 4runner, so it's time to get it set up for the next 200k miles. I might even replace the OEM cassette deck with a modern stereo.. ;)
__________________
Original owner 1996 SR5 4x4 5VZ-FE A/T Bone stock.
jmacqueen is offline   Reply With QuoteReply With Quote
Reply

Tags
back , engine , miles , start , started

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Instrument cluster intermittantly wonky Toyoter 4th Gen T4Rs 4 11-14-2017 07:26 PM
clutch pedal intermittantly not returning bills86e Classic T4Rs 1 07-09-2013 09:19 PM
I think my dog is dying 034RUNNER Off Topic 17 06-04-2012 01:56 PM
Dying Out JAHS10 Problems & Warranty Issues 2 04-11-2007 08:32 PM
95 4runner dying out 954Runner Classic T4Rs 4 03-20-2005 04:34 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 02:03 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2020