User Tag List

Reply
 
Thread Tools Rate Thread Display Modes
Old 05-30-2020, 12:56 AM #1
Crackership's Avatar
Crackership Crackership is offline
Junior Member
 
Join Date: Jun 2013
Location: Duvall, WA
Posts: 15
Real Name: Dave
Crackership is on a distinguished road
Crackership Crackership is offline
Junior Member
Crackership's Avatar
 
Join Date: Jun 2013
Location: Duvall, WA
Posts: 15
Real Name: Dave
Crackership is on a distinguished road
Hi, I just snagged a 3rd Gen T4R and I have some questions

Hi all,

I've had a 2nd gen T4R for nearly 10 years and have loved it but I just rolled the dice on a 1996 Limited with E-Locker I found for a song. Like, it was CHEAP.

It runs, but has a misfire on cyl2. I pulled the plug and it doesn't look like it's firing at all, so I'm figuring to throw a coil on it. Any suggestions or ones to avoid?

It also has some "mods", most of which involve butt connectors, electrical tape and zip ties. Now, like all good 2nd gen owners, I have a resistor taped into the EGR plug to keep the CEL from going off after the EGR valve crumbled in my hand one day, so I know not all "tape and zip ties" mods are totally janky, but being new to the 3rd gen, I don't know what's been done for a reason and what's just dumb. Hopefully you guys can tell me if there's any reason for any of these things before I go trying to figure out how to fix them.

First up is this guy, spliced into the diagnostic plug harness.


Second is this thingy zip-tied to the MAF harness


And finally, this box.. which I assume is a charcoal canister? Buzzes for a while after I shut the truck off.


Any ideas?

I really appreciate any help!

TIA
-Dave
Crackership is offline   Reply With QuoteReply With Quote
Old 05-30-2020, 01:11 AM #2
Theginger91 Theginger91 is offline
Junior Member
 
Join Date: Dec 2018
Location: North Florida
Posts: 10
Real Name: Elston
Theginger91 is on a distinguished road
Theginger91 Theginger91 is offline
Junior Member
 
Join Date: Dec 2018
Location: North Florida
Posts: 10
Real Name: Elston
Theginger91 is on a distinguished road
Quote:
Originally Posted by Crackership View Post
Hi all,

I've had a 2nd gen T4R for nearly 10 years and have loved it but I just rolled the dice on a 1996 Limited with E-Locker I found for a song. Like, it was CHEAP.

It runs, but has a misfire on cyl2. I pulled the plug and it doesn't look like it's firing at all, so I'm figuring to throw a coil on it. Any suggestions or ones to avoid?

It also has some "mods", most of which involve butt connectors, electrical tape and zip ties. Now, like all good 2nd gen owners, I have a resistor taped into the EGR plug to keep the CEL from going off after the EGR valve crumbled in my hand one day, so I know not all "tape and zip ties" mods are totally janky, but being new to the 3rd gen, I don't know what's been done for a reason and what's just dumb. Hopefully you guys can tell me if there's any reason for any of these things before I go trying to figure out how to fix them.

First up is this guy, spliced into the diagnostic plug harness.


Second is this thingy zip-tied to the MAF harness


And finally, this box.. which I assume is a charcoal canister? Buzzes for a while after I shut the truck off.


Any ideas?

I really appreciate any help!

TIA
-Dave
1st id check compression on #2 cyl.
Theginger91 is offline   Reply With QuoteReply With Quote
Old 05-30-2020, 01:40 AM #3
Tucson4runner's Avatar
Tucson4runner Tucson4runner is offline
Senior Member
 
Join Date: May 2011
Location: Tucson AZ
Posts: 2,194
Tucson4runner will become famous soon enough
Tucson4runner Tucson4runner is offline
Senior Member
Tucson4runner's Avatar
 
Join Date: May 2011
Location: Tucson AZ
Posts: 2,194
Tucson4runner will become famous soon enough
Can you follow those wires and see where they go?

Sent from my SM-N975U using Tapatalk
__________________
work in progress
Tucson4runner is offline   Reply With QuoteReply With Quote
Old 05-30-2020, 01:44 AM #4
Dieselchessy Dieselchessy is offline
Member
 
Join Date: Dec 2019
Location: SW Washington
Posts: 540
Dieselchessy has a spectacular aura about Dieselchessy has a spectacular aura about
Dieselchessy Dieselchessy is offline
Member
 
Join Date: Dec 2019
Location: SW Washington
Posts: 540
Dieselchessy has a spectacular aura about Dieselchessy has a spectacular aura about
The MAF connector thing is normal factory.
__________________
Owned 82, 83, 87 pickup, 98, 99 SR5 4runner
Currently own a 98 SR5, 5spd, 4x4, e-locker, no sunroof. 2012 LTD with the normal options.
Dieselchessy is offline   Reply With QuoteReply With Quote
Old 05-30-2020, 02:13 AM #5
Crackership's Avatar
Crackership Crackership is offline
Junior Member
 
Join Date: Jun 2013
Location: Duvall, WA
Posts: 15
Real Name: Dave
Crackership is on a distinguished road
Crackership Crackership is offline
Junior Member
Crackership's Avatar
 
Join Date: Jun 2013
Location: Duvall, WA
Posts: 15
Real Name: Dave
Crackership is on a distinguished road
Quote:
Originally Posted by Tucson4runner View Post
Can you follow those wires and see where they go?

Sent from my SM-N975U using Tapatalk
That's the plan for tomorrow. Just thought I'd ask before I go digging.. just in case that's the "unicorn rocket booster mod" and everyone's doing it or something like that.

Quote:
Originally Posted by Dieselchessy View Post
The MAF connector thing is normal factory.
Awesome! Glad I asked!
Crackership is offline   Reply With QuoteReply With Quote
Old 05-30-2020, 02:38 AM #6
TheSaturnV TheSaturnV is offline
Member
 
Join Date: Dec 2019
Posts: 90
TheSaturnV is on a distinguished road
TheSaturnV TheSaturnV is offline
Member
 
Join Date: Dec 2019
Posts: 90
TheSaturnV is on a distinguished road
See if the radiator has been replaced and check those LBJ's.
__________________
2000 Black LTD with ELOCKER, almost 100% stock
TheSaturnV is offline   Reply With QuoteReply With Quote
Old 05-30-2020, 02:58 AM #7
Crackership's Avatar
Crackership Crackership is offline
Junior Member
 
Join Date: Jun 2013
Location: Duvall, WA
Posts: 15
Real Name: Dave
Crackership is on a distinguished road
Crackership Crackership is offline
Junior Member
Crackership's Avatar
 
Join Date: Jun 2013
Location: Duvall, WA
Posts: 15
Real Name: Dave
Crackership is on a distinguished road
Quote:
Originally Posted by TheSaturnV View Post
See if the radiator has been replaced and check those LBJ's.
The radiator has been replaced, and I figured the LBJs are a given.
Crackership is offline   Reply With QuoteReply With Quote
Old 06-02-2020, 01:39 AM #8
Crackership's Avatar
Crackership Crackership is offline
Junior Member
 
Join Date: Jun 2013
Location: Duvall, WA
Posts: 15
Real Name: Dave
Crackership is on a distinguished road
Crackership Crackership is offline
Junior Member
Crackership's Avatar
 
Join Date: Jun 2013
Location: Duvall, WA
Posts: 15
Real Name: Dave
Crackership is on a distinguished road
Alright, so I chased those wires and it led me to a janky alarm install. So I pulled all of that out.

Also replaced the coil and the misfire is gone. Hooray!

It does still idle very rough though. It's worse when in gear and when warmed up. From reading this forum, that sounds like the IAC valve needs a good cleaning, you all agree? It's not throwing any codes.
Crackership is offline   Reply With QuoteReply With Quote
Old 06-02-2020, 08:15 AM #9
HiLife HiLife is offline
Member
 
Join Date: Mar 2014
Location: Trying to figure this out
Posts: 847
HiLife will become famous soon enough HiLife will become famous soon enough
HiLife HiLife is offline
Member
 
Join Date: Mar 2014
Location: Trying to figure this out
Posts: 847
HiLife will become famous soon enough HiLife will become famous soon enough
Yes I would remove the IAC and do a good and careful cleaning. Careful cause of the electric motor in the IAC.
I would clean the throttle body too while I'm at it.
HiLife is offline   Reply With QuoteReply With Quote
Old 06-02-2020, 10:16 AM #10
Hopeless Diamond's Avatar
Hopeless Diamond Hopeless Diamond is offline
Member
 
Join Date: Nov 2017
Location: Chumstick WA
Posts: 312
Hopeless Diamond will become famous soon enough Hopeless Diamond will become famous soon enough
Hopeless Diamond Hopeless Diamond is offline
Member
Hopeless Diamond's Avatar
 
Join Date: Nov 2017
Location: Chumstick WA
Posts: 312
Hopeless Diamond will become famous soon enough Hopeless Diamond will become famous soon enough
The charcoal canister buzzing is how my '96 talks to me and tries to get me to take it for a drive, like a puppy wanting to go on a walk I've had it sitting for multiple months and it will keep doing it.
Hopeless Diamond is offline   Reply With QuoteReply With Quote
Old 06-02-2020, 02:00 PM #11
phattyduck phattyduck is offline
Senior Member
 
Join Date: Mar 2016
Location: Pasadena, CA
Posts: 3,425
phattyduck is a splendid one to behold phattyduck is a splendid one to behold phattyduck is a splendid one to behold phattyduck is a splendid one to behold phattyduck is a splendid one to behold phattyduck is a splendid one to behold phattyduck is a splendid one to behold
phattyduck phattyduck is offline
Senior Member
 
Join Date: Mar 2016
Location: Pasadena, CA
Posts: 3,425
phattyduck is a splendid one to behold phattyduck is a splendid one to behold phattyduck is a splendid one to behold phattyduck is a splendid one to behold phattyduck is a splendid one to behold phattyduck is a splendid one to behold phattyduck is a splendid one to behold
Quote:
Originally Posted by Hopeless Diamond View Post
The charcoal canister buzzing is how my '96 talks to me and tries to get me to take it for a drive, like a puppy wanting to go on a walk I've had it sitting for multiple months and it will keep doing it.
Yup, the early charcoal canisters can make a buzzing / resonant sound. There is a TSB on it where they add a small chamber to the front most hose out the top to stop it. Not a problem, just annoying. Later charcoal canisters have at built in to the hose outlet (an extra chamber).

-Charlie
__________________
'99 4Runner SR5 Auto - 4WD swapped
'89 Camry Alltrac LE 3S-GTE 5spd
'16 Honda Odyssey
Previous: '88 Camry Alltrac LE 3S-GE BEAMS, 90 Camry 3S-GTE, 90 Camry DX, '03 WRX wagon, '08 Outback XT
phattyduck is offline   Reply With QuoteReply With Quote
Old 06-02-2020, 02:47 PM #12
Hopeless Diamond's Avatar
Hopeless Diamond Hopeless Diamond is offline
Member
 
Join Date: Nov 2017
Location: Chumstick WA
Posts: 312
Hopeless Diamond will become famous soon enough Hopeless Diamond will become famous soon enough
Hopeless Diamond Hopeless Diamond is offline
Member
Hopeless Diamond's Avatar
 
Join Date: Nov 2017
Location: Chumstick WA
Posts: 312
Hopeless Diamond will become famous soon enough Hopeless Diamond will become famous soon enough
yeah, gotten use to it, call the 4R Wheezy. It's just like me, a little exercise and it wheezes for hours
Hopeless Diamond is offline   Reply With QuoteReply With Quote
Old 06-02-2020, 03:48 PM #13
raulb21's Avatar
raulb21 raulb21 is offline
Junior Member
 
Join Date: Sep 2018
Location: Florida
Posts: 26
Real Name: Brett
raulb21 is on a distinguished road
raulb21 raulb21 is offline
Junior Member
raulb21's Avatar
 
Join Date: Sep 2018
Location: Florida
Posts: 26
Real Name: Brett
raulb21 is on a distinguished road
Quote:
Originally Posted by Crackership View Post
Alright, so I chased those wires and it led me to a janky alarm install. So I pulled all of that out.

Also replaced the coil and the misfire is gone. Hooray!

It does still idle very rough though. It's worse when in gear and when warmed up. From reading this forum, that sounds like the IAC valve needs a good cleaning, you all agree? It's not throwing any codes.
If cleaning doesn't do it, I'd just replace the IAC Valve. I had a CEL on and off for a while, traced it to that. When cleaning didn't do it, I just replaced the valve. Haven't had a problem since. Just don't strip the 4 screws getting it off, they can be a pain. Use one of those Japanese industrial screw drivers.
raulb21 is offline   Reply With QuoteReply With Quote
Reply

Tags
gen , mods , plug , tape , zip

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 4runner tranny questions possible swap questions. Did search samario1984 3rd gen T4Rs 5 06-09-2017 01:27 PM
snagged a manual 98 soupkitchen 3rd gen T4Rs 33 07-07-2016 09:45 PM
few questions kolelt 3rd gen T4Rs 7 09-13-2014 01:47 PM
Just snagged an 01 4runner sr5 with 45k! 01YO New Members 8 05-17-2012 04:35 PM
Garmin iQue voice nav questions and Topo maps questions. Expat Engines / Suspension / Wheels / Tires / Audio / Accessories 2 04-11-2005 09:49 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 11:37 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2020