User Tag List

Reply
 
Thread Tools Rate Thread Display Modes
Old 02-24-2021, 07:37 PM #1
T4topher's Avatar
T4topher T4topher is online now
Member
 
Join Date: Sep 2018
Location: San Francisco Ca
Posts: 603
T4topher is a jewel in the rough T4topher is a jewel in the rough T4topher is a jewel in the rough
T4topher T4topher is online now
Member
T4topher's Avatar
 
Join Date: Sep 2018
Location: San Francisco Ca
Posts: 603
T4topher is a jewel in the rough T4topher is a jewel in the rough T4topher is a jewel in the rough
Hesitation under acceleration from stop

This has been plaguing me for a while. When I do a rolling stop/stop very shortly and accelerate i get a slight hesitation. It revs for a split second then it seems like it dies a little then picks right back up. If I do a full stop and wait a second it won’t do it. Ive done quite a bit of maintenance on this thing so I have a decent head start on narrowing this down hopefully.. i try to stick with oem toyota parts where I can. Any suggestions/recommendations would be helpful!

2000 limited 5vzfe 184k miles no CEL and drives 100% fine except for this issue.

New info:
-seems to only happen when warmed up
-seems like it happens when it hits 1500 rpm
-seems like this is common with 99-00’s?

Here’s the relevant things I’ve done so far:
Replaced:
-plugs/wires
-fuel filter
-air filter
-timing belt (eBay kit Tim recommended)
-alternator brushes
-battery
-valve cover gaskets/pcv

Cleaned/rebuilt/tested:
-cleaned/rebuilt injectors (eBay kit)
-cleaned/swapped/tested MAF
-cleaned/tested IAC
-cleaned throttle body/intake manifold
-coil packs tested per FSM
-cleaned electrical connections on TB/MAF/TPS
-over drive/etc have no effect on this problem

Things that I’m thinking of trying:
-96-98 injectors?
-96-98 MAF?
-new throttle cable?
__________________
T4Tophers build (click here)

Last edited by T4topher; 03-05-2021 at 06:36 PM.
T4topher is online now   Reply With QuoteReply With Quote
Old 02-24-2021, 09:47 PM #2
the_welfare_wagon's Avatar
the_welfare_wagon the_welfare_wagon is offline
Member
 
Join Date: Sep 2020
Location: New York
Posts: 38
Real Name: Rich
the_welfare_wagon is on a distinguished road
the_welfare_wagon the_welfare_wagon is offline
Member
the_welfare_wagon's Avatar
 
Join Date: Sep 2020
Location: New York
Posts: 38
Real Name: Rich
the_welfare_wagon is on a distinguished road
How far does the RPM drop? A friend of mine had something similar and it turned out to be low tranny fluid. Turn out a line busted and from a stop the damn thing could barely get up on the rhino ramps it was so low
__________________
96 limited: 265/75s, 99 Talls W/5100s + OME 890s W/FJZ80 Shocks

Last edited by the_welfare_wagon; 02-24-2021 at 09:49 PM. Reason: More info
the_welfare_wagon is offline   Reply With QuoteReply With Quote
Old 02-24-2021, 10:30 PM #3
spartacus's Avatar
spartacus spartacus is offline
Senior Member
 
Join Date: Mar 2010
Location: denver
Posts: 1,835
spartacus is a name known to all spartacus is a name known to all spartacus is a name known to all spartacus is a name known to all spartacus is a name known to all spartacus is a name known to all
spartacus spartacus is offline
Senior Member
spartacus's Avatar
 
Join Date: Mar 2010
Location: denver
Posts: 1,835
spartacus is a name known to all spartacus is a name known to all spartacus is a name known to all spartacus is a name known to all spartacus is a name known to all spartacus is a name known to all
MAF's can be bad even when they are within spec.
spartacus is offline   Reply With QuoteReply With Quote
Old 02-24-2021, 10:44 PM #4
T4topher's Avatar
T4topher T4topher is online now
Member
 
Join Date: Sep 2018
Location: San Francisco Ca
Posts: 603
T4topher is a jewel in the rough T4topher is a jewel in the rough T4topher is a jewel in the rough
T4topher T4topher is online now
Member
T4topher's Avatar
 
Join Date: Sep 2018
Location: San Francisco Ca
Posts: 603
T4topher is a jewel in the rough T4topher is a jewel in the rough T4topher is a jewel in the rough
Quote:
Originally Posted by spartacus View Post
MAF's can be bad even when they are within spec.
Good to know, might get one just to rule it out..

Quote:
Originally Posted by the_welfare_wagon View Post
How far does the RPM drop? A friend of mine had something similar and it turned out to be low tranny fluid. Turn out a line busted and from a stop the damn thing could barely get up on the rhino ramps it was so low
I don’t think it’s that. It’s been happening for a while and it drives 100% completely fine other than this. I’ll take a peek at the fluid level though just to rule it out.

I’ll try to get a little video of it happening tomorrow..
__________________
T4Tophers build (click here)

Last edited by T4topher; 02-24-2021 at 10:52 PM.
T4topher is online now   Reply With QuoteReply With Quote
Old 02-24-2021, 10:58 PM #5
mtbtim's Avatar
mtbtim mtbtim is offline
Senior Member
 
Join Date: Feb 2015
Location: San Jose, California
Age: 55
Posts: 4,470
Real Name: Tim
mtbtim has much to be proud of mtbtim has much to be proud of mtbtim has much to be proud of mtbtim has much to be proud of mtbtim has much to be proud of mtbtim has much to be proud of mtbtim has much to be proud of mtbtim has much to be proud of mtbtim has much to be proud of mtbtim has much to be proud of
mtbtim mtbtim is offline
Senior Member
mtbtim's Avatar
 
Join Date: Feb 2015
Location: San Jose, California
Age: 55
Posts: 4,470
Real Name: Tim
mtbtim has much to be proud of mtbtim has much to be proud of mtbtim has much to be proud of mtbtim has much to be proud of mtbtim has much to be proud of mtbtim has much to be proud of mtbtim has much to be proud of mtbtim has much to be proud of mtbtim has much to be proud of mtbtim has much to be proud of
Have you tried cleaning your IAC?
__________________
"My old man is a television repairman, he's got this ultimate set of tools. I can fix it!"
mtbtim is offline   Reply With QuoteReply With Quote
Old 02-24-2021, 11:01 PM #6
T4topher's Avatar
T4topher T4topher is online now
Member
 
Join Date: Sep 2018
Location: San Francisco Ca
Posts: 603
T4topher is a jewel in the rough T4topher is a jewel in the rough T4topher is a jewel in the rough
T4topher T4topher is online now
Member
T4topher's Avatar
 
Join Date: Sep 2018
Location: San Francisco Ca
Posts: 603
T4topher is a jewel in the rough T4topher is a jewel in the rough T4topher is a jewel in the rough
Quote:
Originally Posted by mtbtim View Post
Have you tried cleaning your IAC?
Oh yes I did try that and I tested it as well, thank you Ill add that to the list.
__________________
T4Tophers build (click here)
T4topher is online now   Reply With QuoteReply With Quote
Old 02-25-2021, 09:17 AM #7
habanero's Avatar
habanero habanero is offline
Senior Member
 
Join Date: Oct 2005
Location: St. Louis area
Age: 53
Posts: 1,705
Real Name: Throws like a girl
habanero has a spectacular aura about habanero has a spectacular aura about habanero has a spectacular aura about
habanero habanero is offline
Senior Member
habanero's Avatar
 
Join Date: Oct 2005
Location: St. Louis area
Age: 53
Posts: 1,705
Real Name: Throws like a girl
habanero has a spectacular aura about habanero has a spectacular aura about habanero has a spectacular aura about
You don't mention the IAC...oh wait, you did. Nevermind that then.

You've been around for awhile, so likely know about the very hard to see wires on the maf sensor, but since I've seen many a post that turned out they were only cleaning the bulb and not the tiny delicate wires I'll throw that in the mix.
__________________
'96 4Runner SR5 4x4, manual, locker, manual hubs too. Stuff happened to it. Stuff is still happening to it. Okay, now the stuff is just getting ridiculous.
'99 4Runner SR5 Highlander, manual w/locker. Stuff is starting to happen to this one too...too much stuff! Too much stuff!!
http://www.yotatech.com/f200/habaner...thread-201751/
Quote:
Originally Posted by PWD4R View Post
I know this is a weird ass question but do you shave your legs or something?
habanero is offline   Reply With QuoteReply With Quote
Old 02-25-2021, 11:31 AM #8
T4topher's Avatar
T4topher T4topher is online now
Member
 
Join Date: Sep 2018
Location: San Francisco Ca
Posts: 603
T4topher is a jewel in the rough T4topher is a jewel in the rough T4topher is a jewel in the rough
T4topher T4topher is online now
Member
T4topher's Avatar
 
Join Date: Sep 2018
Location: San Francisco Ca
Posts: 603
T4topher is a jewel in the rough T4topher is a jewel in the rough T4topher is a jewel in the rough
Quote:
Originally Posted by habanero View Post
You don't mention the IAC...oh wait, you did. Nevermind that then.

You've been around for awhile, so likely know about the very hard to see wires on the maf sensor, but since I've seen many a post that turned out they were only cleaning the bulb and not the tiny delicate wires I'll throw that in the mix.
I did clean the small wire inside too, I basically used a whole can of MAF cleaner lol. However the first time I cleaned it I noticed a decent amount of caked on dirt over the “bulb” part of the MAF and I cleaned it off with a q tip as it wouldn’t come off with the MAF cleaner. I didn’t touch the small wires inside though. Not sure if I ruined the MAF when I did that or not as I know your not supposed to touch it..?
__________________
T4Tophers build (click here)
T4topher is online now   Reply With QuoteReply With Quote
Old 02-25-2021, 02:33 PM #9
alumarine alumarine is offline
Member
 
Join Date: Dec 2015
Location: Manitoba, Canada
Posts: 751
alumarine will become famous soon enough
alumarine alumarine is offline
Member
 
Join Date: Dec 2015
Location: Manitoba, Canada
Posts: 751
alumarine will become famous soon enough
I've had the same issue since I bought mine 5 years ago.

If I come to an abrupt stop and then immediately give it gas it stumbles for a moment and then catches.

Don't have a solution, just thought I'd share!
__________________
2000 4runner 4wd Auto V6 - Tru-Cool LPD4454 trans cooler in series
1991 4runner 4wd Auto V6
1990 4runner 4wd Auto V6
alumarine is offline   Reply With QuoteReply With Quote
Old 02-25-2021, 02:48 PM #10
WeakSauz WeakSauz is online now
Member
 
Join Date: Sep 2018
Location: Raleigh, NC
Posts: 376
WeakSauz has a spectacular aura about WeakSauz has a spectacular aura about
WeakSauz WeakSauz is online now
Member
 
Join Date: Sep 2018
Location: Raleigh, NC
Posts: 376
WeakSauz has a spectacular aura about WeakSauz has a spectacular aura about
I know it doesn't help you, but mine does it too.

My checklist looks very similar to yours
__________________
2000 SR5 4x4, Auto | Millennium Silver and Moon Mist | Geared and Locked | Jeep JK springs, Bilstiens/ BTF Fab | Shrockworks skids | Onboard Air | Manual Hubs | Alpine Audio
WeakSauz is online now   Reply With QuoteReply With Quote
Old 02-25-2021, 03:11 PM #11
Malcolm99's Avatar
Malcolm99 Malcolm99 is offline
Member
 
Join Date: May 2020
Location: Ontario
Posts: 332
Malcolm99 will become famous soon enough Malcolm99 will become famous soon enough
Malcolm99 Malcolm99 is offline
Member
Malcolm99's Avatar
 
Join Date: May 2020
Location: Ontario
Posts: 332
Malcolm99 will become famous soon enough Malcolm99 will become famous soon enough
My 99' does this since I got it, if it's idling at 700-750RPM warmed up and I quick blip the throttle 1/2-WOT in neutral or Drive, especially noticeable if I actuate the throttle from under the hood(a quick miss than throttle up), the only thing I haven't checked is valve clearance, front O2(FED) or another ECU which isn't easy to do on an immobilizer system. Done OEM MAF, TPS, Wires, Plugs, cleaned IAC & TB, compression test 195, fuel trims are normal now, new ATF and OE filter, checked timing marks, checked Crank rotor and crank pulley bolt, ran a ton of premium and Lucas fuel conditioner cleaner, Scoped cylinders-carbon minimal?, I have to induce it with an abrupt throttle blip ON/OFF. My 97 with double the miles and only used as a plow truck, doesn't do this but it has a different MAF and injectors, I began to wonder if this is a 99+ Thing it doesn't effect the way it drives just a weird hesitation/throttle cut if your goofing around, I'm considering swapping TB's incase that throttle stepper just isn't set up right.
__________________
99' Ltd E-locker grey wired, 4R Bilstein 5100, 99 tall coils, 906 OME & 1.5" spacers, 2015 4R Trail Edition 275/70R17, 1" RB BL
97' SR5 E-locker grey wired, Warn winch, 2" RB BL, Sonoran Steel 1.2 lift, dual battery, 1000W inverter, Hydraulic Arctic plow, 12" x 33" Baja Claw
92' Eclipse GSX AWD 6/4 bolt combo, 28 PSI boost, Meth injection, 750cc injectors, FMIC, 2.5" IC piping, full 3" exhaust, 350AWHP, lowered, Alum flywheel, 6 puck Clutch, Cams, JDM gear set,VC rear diff, EPROM ECU

Last edited by Malcolm99; 02-25-2021 at 03:20 PM.
Malcolm99 is offline   Reply With QuoteReply With Quote
Old 02-25-2021, 04:31 PM #12
T4topher's Avatar
T4topher T4topher is online now
Member
 
Join Date: Sep 2018
Location: San Francisco Ca
Posts: 603
T4topher is a jewel in the rough T4topher is a jewel in the rough T4topher is a jewel in the rough
T4topher T4topher is online now
Member
T4topher's Avatar
 
Join Date: Sep 2018
Location: San Francisco Ca
Posts: 603
T4topher is a jewel in the rough T4topher is a jewel in the rough T4topher is a jewel in the rough
Quote:
Originally Posted by Malcolm99 View Post
My 99' does this since I got it, if it's idling at 700-750RPM warmed up and I quick blip the throttle 1/2-WOT in neutral or Drive, especially noticeable if I actuate the throttle from under the hood(a quick miss than throttle up), the only thing I haven't checked is valve clearance, front O2(FED) or another ECU which isn't easy to do on an immobilizer system. Done OEM MAF, TPS, Wires, Plugs, cleaned IAC & TB, compression test 195, fuel trims are normal now, new ATF and OE filter, checked timing marks, checked Crank rotor and crank pulley bolt, ran a ton of premium and Lucas fuel conditioner cleaner, Scoped cylinders-carbon minimal?, I have to induce it with an abrupt throttle blip ON/OFF. My 97 with double the miles and only used as a plow truck, doesn't do this but it has a different MAF and injectors, I began to wonder if this is a 99+ Thing it doesn't effect the way it drives just a weird hesitation/throttle cut if your goofing around, I'm considering swapping TB's incase that throttle stepper just isn't set up right.
Interesting, I wonder how difficult it would be to swap to an older MAF/throttle body. I have a feeling there are some differences though. It does sort of seem like itís a 99-00 issue, everyone saying they have the same problem so far has a 2000 and you have a 99..

Quote:
Originally Posted by WeakSauz View Post
I know it doesn't help you, but mine does it too.

My checklist looks very similar to yours
Quote:
Originally Posted by alumarine View Post
I've had the same issue since I bought mine 5 years ago.

If I come to an abrupt stop and then immediately give it gas it stumbles for a moment and then catches.

Don't have a solution, just thought I'd share!
__________________
T4Tophers build (click here)
T4topher is online now   Reply With QuoteReply With Quote
Old 02-25-2021, 06:20 PM #13
Malcolm99's Avatar
Malcolm99 Malcolm99 is offline
Member
 
Join Date: May 2020
Location: Ontario
Posts: 332
Malcolm99 will become famous soon enough Malcolm99 will become famous soon enough
Malcolm99 Malcolm99 is offline
Member
Malcolm99's Avatar
 
Join Date: May 2020
Location: Ontario
Posts: 332
Malcolm99 will become famous soon enough Malcolm99 will become famous soon enough
I was thinking 96-98 injectors since our 99+ are prone to failure anyways and offer no mpg or performance improvement that is measurable. My truck is a 99 model built in Oct 98, and the 96-2000 use the same TB, IAC, TPS, I don't think the average person would notice this unless they blipped the throttle from under the hood while its warmed up idling at 700-750rpm, I cannot recreate this hesitation when my idle is 850+ rpms
__________________
99' Ltd E-locker grey wired, 4R Bilstein 5100, 99 tall coils, 906 OME & 1.5" spacers, 2015 4R Trail Edition 275/70R17, 1" RB BL
97' SR5 E-locker grey wired, Warn winch, 2" RB BL, Sonoran Steel 1.2 lift, dual battery, 1000W inverter, Hydraulic Arctic plow, 12" x 33" Baja Claw
92' Eclipse GSX AWD 6/4 bolt combo, 28 PSI boost, Meth injection, 750cc injectors, FMIC, 2.5" IC piping, full 3" exhaust, 350AWHP, lowered, Alum flywheel, 6 puck Clutch, Cams, JDM gear set,VC rear diff, EPROM ECU

Last edited by Malcolm99; 02-25-2021 at 06:24 PM.
Malcolm99 is offline   Reply With QuoteReply With Quote
Old 02-25-2021, 06:33 PM #14
T4topher's Avatar
T4topher T4topher is online now
Member
 
Join Date: Sep 2018
Location: San Francisco Ca
Posts: 603
T4topher is a jewel in the rough T4topher is a jewel in the rough T4topher is a jewel in the rough
T4topher T4topher is online now
Member
T4topher's Avatar
 
Join Date: Sep 2018
Location: San Francisco Ca
Posts: 603
T4topher is a jewel in the rough T4topher is a jewel in the rough T4topher is a jewel in the rough
Quote:
Originally Posted by Malcolm99 View Post
I was thinking 96-98 injectors since our are 99+ are prone to failure anyways and offer no mpg or performance improvement that is measurable. My truck is a 99 model built in Oct 98, and the 96-2000 use the same TB, IAC, TPS, I don't think the average person would notice this unless they blipped the throttle from under the hood while its warmed up idling at 700-750rpm, I cannot recreate this hesitation when my idle is 850+ rpms
Hmm well this happens for me wether itís warmed up or not. I havenít really payed attention to the rpms, when I make the video Iíll try to get the rpms too. Iíll have to take a look at 96-98 injectors..
__________________
T4Tophers build (click here)
T4topher is online now   Reply With QuoteReply With Quote
Old 03-04-2021, 10:39 PM #15
T4topher's Avatar
T4topher T4topher is online now
Member
 
Join Date: Sep 2018
Location: San Francisco Ca
Posts: 603
T4topher is a jewel in the rough T4topher is a jewel in the rough T4topher is a jewel in the rough
T4topher T4topher is online now
Member
T4topher's Avatar
 
Join Date: Sep 2018
Location: San Francisco Ca
Posts: 603
T4topher is a jewel in the rough T4topher is a jewel in the rough T4topher is a jewel in the rough
Quote:
Originally Posted by Malcolm99 View Post
I was thinking 96-98 injectors since our 99+ are prone to failure anyways and offer no mpg or performance improvement that is measurable. My truck is a 99 model built in Oct 98, and the 96-2000 use the same TB, IAC, TPS, I don't think the average person would notice this unless they blipped the throttle from under the hood while its warmed up idling at 700-750rpm, I cannot recreate this hesitation when my idle is 850+ rpms
I think I have to take back what I said about wether it’s warmed up or not. Now that I’ve been really trying to recreate the problem it does seem like it only happens when warmed up and it also seems to only happen around 1500 rpms as I’m accelerating. I just cleaned all the electrical connectors with contact cleaner and swapped MAFs with my buddy.. Nothing changed, going to try and go for another test drive in a bit and see if overdrive or etc makes a difference. I usually drive with etc on and overdrive on.

Edit: over drive/etc being off or on has no effect
__________________
T4Tophers build (click here)

Last edited by T4topher; 03-05-2021 at 12:00 AM.
T4topher is online now   Reply With QuoteReply With Quote
Reply

Tags
ebay , hesitation , kit , maf , tested

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Acceleration Hesitation Norcal_Mike 5th gen T4Rs 75 02-11-2019 10:49 PM
98 4r with bad hesitation under acceleration hardtime 3rd gen T4Rs 20 11-27-2018 11:41 AM
Acceleration hesitation from stop joshik 4th Gen T4Rs 14 06-30-2018 02:48 PM
hesitation during acceleration joshik 4th Gen T4Rs 1 04-07-2016 02:57 PM
hesitation in acceleration Craig11909 5th gen T4Rs 5 06-22-2015 06:44 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 09:48 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2020