User Tag List

Reply
 
Thread Tools Rate Thread Display Modes
Old 04-28-2021, 03:46 PM #16
Kanoe's Avatar
Kanoe Kanoe is offline
Senior Member
 
Join Date: Dec 2013
Location: Yukon
Posts: 1,279
Kanoe is just really nice Kanoe is just really nice Kanoe is just really nice Kanoe is just really nice
Kanoe Kanoe is offline
Senior Member
Kanoe's Avatar
 
Join Date: Dec 2013
Location: Yukon
Posts: 1,279
Kanoe is just really nice Kanoe is just really nice Kanoe is just really nice Kanoe is just really nice
Quote:
Originally Posted by KimIsAGuy View Post
Though, I am curious to why my radiator gave out like that? It's not that old of a radiator. This would be the 2nd time I replaced it, I'm at 408K on the motor. I hope it's just a bad radiator and the problem didn't spread to the engine or so.

Thanks guys for the help! Much appreciated.
Must have been restricting flow, either full of sediment or corroded. If you use good proper coolant and drain/fill on schedule it should stay clean as a whistle. What did the old rad look like inside?
__________________
-1996 4Runner. 3RZ 5-Spd. 4x4 Base model. OME2906/Toyota OEM rears with 2004 Tacoma Dual Rate Fronts on Bilstien 4600s.
-1993 Corolla Wagon 7AFE
-2001 Echo D.D.
Kanoe is offline   Reply With QuoteReply With Quote
Reply

Tags
60-70mph , engine , heater , temp , temperature

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine coolant temperature sensor Herculean T4R 3rd gen T4Rs 2 06-06-2018 04:33 PM
Engine Coolant Temperature sensor (ECT) and mileage radlynx 4th Gen T4Rs 5 03-10-2016 09:41 PM
Engine Coolant Temperature Sensor,how hard on a 1-10? TX_QtPi Classic T4Rs 1 07-23-2013 10:53 AM
Engine Coolant Temperature Gauge not working kdanielp3 Problems & Warranty Issues 2 12-17-2007 06:54 PM
Engine temperature sensor location? Husker Du Maintenance/Detailing 0 07-29-2007 06:37 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 08:53 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2020