User Tag List

Reply
 
Thread Tools Rate Thread Display Modes
Old 05-02-2021, 08:26 PM #1
Reechyz's Avatar
Reechyz Reechyz is offline
Member
 
Join Date: Feb 2019
Location: Hayward, CA
Posts: 31
Real Name: Richard
Reechyz is on a distinguished road
Reechyz Reechyz is offline
Member
Reechyz's Avatar
 
Join Date: Feb 2019
Location: Hayward, CA
Posts: 31
Real Name: Richard
Reechyz is on a distinguished road
VSC off and VSC TRAC light coming on with no CEL

Great peeps of the 3rd gen forum. I need some advice with the following issue:
Model: 2002 SR5 Sports Edition
Andy Mod 2.0 with TRAC OFF momentary switch installed with proper relay.
Problem Description:
- Start the car --> all dash lights comes on then off (normal so far)
- Shift gear to Drive/Reverse --> about half a second later VSC off and TRAC
dash light display comes on
- No check engine light warning --> OBDII scan does not report any fault/error
code
- Problem is the same even with the TRAC off defeat mod is removed

Has anyone seen/experienced this problem before? Could this be an issue with the speed or ABS sensors? Please help.
Reechyz is offline   Reply With QuoteReply With Quote
Old 05-03-2021, 11:55 AM #2
RumHam26 RumHam26 is offline
Member
 
Join Date: Oct 2017
Location: Palatine, IL
Posts: 132
RumHam26 is on a distinguished road
RumHam26 RumHam26 is offline
Member
 
Join Date: Oct 2017
Location: Palatine, IL
Posts: 132
RumHam26 is on a distinguished road
This could have to do with wheel speed sensors. You can look up how to test them with a multimeter. You can also check to see if they are seated properly in the hub. Apparently it is common for them to get slightly moved due to rust issues. Just do a site search for how to test your speed sensors.

I have something similar going on with my 2001. In my case, the traction control system was way too active even on dry pavement. At some point, my VSC/TRAC lights came on with no CEL. The problem went away, I assume because it disabled the system. I later notice the the Drive light bulb on my dash was out. So I went to replace it, and this turned off my VSC/TRAC lights and my overactive tractions control system was back. So, I pulled the bulb, the system disabled again, and now the lights stay on. I still need to clean and reseat my sensors, but they seem to be testing ok.
RumHam26 is offline   Reply With QuoteReply With Quote
Old 05-03-2021, 01:19 PM #3
rumfoord rumfoord is offline
Member
 
Join Date: Apr 2015
Location: Canada
Posts: 60
rumfoord is on a distinguished road
rumfoord rumfoord is offline
Member
 
Join Date: Apr 2015
Location: Canada
Posts: 60
rumfoord is on a distinguished road
had this happen to my 2005, scan showed it was the front right ABS sensor... perhaps 3rd gens are different and don't show up when scanned?
rumfoord is offline   Reply With QuoteReply With Quote
Old 05-03-2021, 01:28 PM #4
3bears 3bears is offline
Senior Member
 
Join Date: May 2015
Location: north east Fairbanks Alaska
Posts: 2,649
Real Name: 3 Bears
3bears is a glorious beacon of light 3bears is a glorious beacon of light 3bears is a glorious beacon of light 3bears is a glorious beacon of light 3bears is a glorious beacon of light
3bears 3bears is offline
Senior Member
 
Join Date: May 2015
Location: north east Fairbanks Alaska
Posts: 2,649
Real Name: 3 Bears
3bears is a glorious beacon of light 3bears is a glorious beacon of light 3bears is a glorious beacon of light 3bears is a glorious beacon of light 3bears is a glorious beacon of light
Quote:
Originally Posted by RumHam26 View Post
.................................... edited to this part..............

I have something similar going on with my 2001. In my case, the traction control system was way too active even on dry pavement. At some point, my VSC/TRAC lights came on with no CEL. The problem went away, I assume because it disabled the system. I later notice the the Drive light bulb on my dash was out. So I went to replace it, and this turned off my VSC/TRAC lights and my overactive tractions control system was back. So, I pulled the bulb, the system disabled again, and now the lights stay on. I still need to clean and reseat my sensors, but they seem to be testing ok.
not trying to hi jack thread...its related. So your answers might be heloful to all who read this thread.

So my trac lights and vsc light is on , as well as my cel for an O2 sensor. I have no other codes.
so my "drive" light does not work on dash either....I just assumed burned bulb..Are you saying that if that bulb is out it will trigger the trac and vsc lights to go on ? Hey Reechyz...are your "drive " light come on ?

otherwise, I have everything to do the andy 2.0 mod, just havent got to it yet. I have the 02 sensor ( denso) but have not got to it yet either. I had snow this weekend....and am just now getting warm enough to work on car.
__________________
2000 SR-5 Highlander. 4:30's, factory locker green
2001 SR-5...sold june 2021
2000 SR-5 V6 Auto . lifted, e locker, other cool stuff, totaled 10/20

Last edited by 3bears; 05-03-2021 at 01:31 PM.
3bears is offline   Reply With QuoteReply With Quote
Old 05-03-2021, 02:41 PM #5
ads2539's Avatar
ads2539 ads2539 is offline
Member
 
Join Date: Aug 2017
Location: Chicago
Posts: 932
ads2539 has a spectacular aura about ads2539 has a spectacular aura about ads2539 has a spectacular aura about
ads2539 ads2539 is offline
Member
ads2539's Avatar
 
Join Date: Aug 2017
Location: Chicago
Posts: 932
ads2539 has a spectacular aura about ads2539 has a spectacular aura about ads2539 has a spectacular aura about
Itís a common issue with 4th gens, but I donít know about 3rd gens.

If my VSC TRAC and VSC OFF lights are on, but the check engine light is not on, that means the settings/data for the car being level have been erased.

There are threads on this forum that explain how to fix the problem. If you search ďVSC TRAC OFF lights onĒ, you should be able to find the solution. Itís pretty straightforward. I have had to do the reset twice.
__________________
2004 Limited 4WD 180k miles. Stratosphere Mica paint, Stone interior. Too many mods to list here.
ads2539 is offline   Reply With QuoteReply With Quote
Old 05-03-2021, 06:44 PM #6
RumHam26 RumHam26 is offline
Member
 
Join Date: Oct 2017
Location: Palatine, IL
Posts: 132
RumHam26 is on a distinguished road
RumHam26 RumHam26 is offline
Member
 
Join Date: Oct 2017
Location: Palatine, IL
Posts: 132
RumHam26 is on a distinguished road
Quote:
Originally Posted by 3bears View Post
not trying to hi jack thread...its related. So your answers might be heloful to all who read this thread.

So my trac lights and vsc light is on , as well as my cel for an O2 sensor. I have no other codes.
so my "drive" light does not work on dash either....I just assumed burned bulb..Are you saying that if that bulb is out it will trigger the trac and vsc lights to go on ? Hey Reechyz...are your "drive " light come on ?

otherwise, I have everything to do the andy 2.0 mod, just havent got to it yet. I have the 02 sensor ( denso) but have not got to it yet either. I had snow this weekend....and am just now getting warm enough to work on car.
I was under the impression that a CEL comes along with VSC/TRAC lights, even if it's not a VSC related code, but I could be wrong. I would start with your O2 sensor and take it from there.

I do not understand the wiring of this car or electricity in general, so I really don't know what I'm talking about. BUT there does seem to be a correlation between my "D" light on the dash and my VSC lights. Replacing the bulb turned off my VSC/TRAC light allowing my faulty VSC system to enable. I tested this more than once.

I also believe that there are different levels to which OBD readers read codes. I have had codes read by mechanics that do not show up on my bluetooth/Torque app set up.
RumHam26 is offline   Reply With QuoteReply With Quote
Old 05-08-2021, 07:00 PM #7
Reechyz's Avatar
Reechyz Reechyz is offline
Member
 
Join Date: Feb 2019
Location: Hayward, CA
Posts: 31
Real Name: Richard
Reechyz is on a distinguished road
Reechyz Reechyz is offline
Member
Reechyz's Avatar
 
Join Date: Feb 2019
Location: Hayward, CA
Posts: 31
Real Name: Richard
Reechyz is on a distinguished road
Folks,

Just a quick update on this issue. Did further search on this forum and saw one thread that talked about this issue. Some folks reported exactly the same issue and was addressed by bulb replacement (#74 dash light ) or should I say restoring the original #74 bulbs from LEDs. I have upgraded my dash light to LEDs and did not pay attention before since in my case I also installed the Andy mod 2.0 and pretty much had TRAC and VSC disabled all the time. So, today, I went back and changed the PRND2L bulbs to standard #74 bulbs and sure enough the VSC and TRAC warning lights are no longer turning on when I shift gear. Thanks to this forum.
Reechyz is offline   Reply With QuoteReply With Quote
Old 05-08-2021, 07:26 PM #8
NJ-4Runner NJ-4Runner is offline
Member
 
Join Date: Jun 2020
Location: NJ Pine Barrens
Posts: 94
NJ-4Runner is on a distinguished road
NJ-4Runner NJ-4Runner is offline
Member
 
Join Date: Jun 2020
Location: NJ Pine Barrens
Posts: 94
NJ-4Runner is on a distinguished road
Quote:
Originally Posted by Reechyz View Post
Folks,

Just a quick update on this issue. Did further search on this forum and saw one thread that talked about this issue. Some folks reported exactly the same issue and was addressed by bulb replacement (#74 dash light ) or should I say restoring the original #74 bulbs from LEDs. I have upgraded my dash light to LEDs and did not pay attention before since in my case I also installed the Andy mod 2.0 and pretty much had TRAC and VSC disabled all the time. So, today, I went back and changed the PRND2L bulbs to standard #74 bulbs and sure enough the VSC and TRAC warning lights are no longer turning on when I shift gear. Thanks to this forum.
Thanks for the update. I also have this issue...and I also switched to LEDs in the main dash instrument cluster.

When your lights came on was the VSC and TRAC actually off/disabled or were the LEDs just making the lights come on?
NJ-4Runner is offline   Reply With QuoteReply With Quote
Old 05-10-2021, 01:31 AM #9
Reechyz's Avatar
Reechyz Reechyz is offline
Member
 
Join Date: Feb 2019
Location: Hayward, CA
Posts: 31
Real Name: Richard
Reechyz is on a distinguished road
Reechyz Reechyz is offline
Member
Reechyz's Avatar
 
Join Date: Feb 2019
Location: Hayward, CA
Posts: 31
Real Name: Richard
Reechyz is on a distinguished road
VSC for sure was getting disabled as I was not getting the beeping sound when cornering at faster speed. Was not able to test if this is the same with TRAC.
Reechyz is offline   Reply With QuoteReply With Quote
Old 05-11-2021, 12:35 PM #10
3bears 3bears is offline
Senior Member
 
Join Date: May 2015
Location: north east Fairbanks Alaska
Posts: 2,649
Real Name: 3 Bears
3bears is a glorious beacon of light 3bears is a glorious beacon of light 3bears is a glorious beacon of light 3bears is a glorious beacon of light 3bears is a glorious beacon of light
3bears 3bears is offline
Senior Member
 
Join Date: May 2015
Location: north east Fairbanks Alaska
Posts: 2,649
Real Name: 3 Bears
3bears is a glorious beacon of light 3bears is a glorious beacon of light 3bears is a glorious beacon of light 3bears is a glorious beacon of light 3bears is a glorious beacon of light
Quote:
Originally Posted by Reechyz View Post
Folks,

Just a quick update on this issue. Did further search on this forum and saw one thread that talked about this issue. Some folks reported exactly the same issue and was addressed by bulb replacement (#74 dash light ) or should I say restoring the original #74 bulbs from LEDs. I have upgraded my dash light to LEDs and did not pay attention before since in my case I also installed the Andy mod 2.0 and pretty much had TRAC and VSC disabled all the time. So, today, I went back and changed the PRND2L bulbs to standard #74 bulbs and sure enough the VSC and TRAC warning lights are no longer turning on when I shift gear. Thanks to this forum.
glad you got it fixed. interesting that the "drive" light bulb being out makes the others turn on. When I do my new 02 sensor, if that does not also turn off the lights, guess I will replace a dash bulb....
__________________
2000 SR-5 Highlander. 4:30's, factory locker green
2001 SR-5...sold june 2021
2000 SR-5 V6 Auto . lifted, e locker, other cool stuff, totaled 10/20
3bears is offline   Reply With QuoteReply With Quote
Reply

Tags
issue , light , problem , trac , vsc

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
VSC TRAC, TRAC OFF, and Check engine light all on. samdajellybeenie14 3rd gen T4Rs 13 02-19-2020 09:36 PM
Check engine light, VSC TRAC & TRAC OFF lights crainmain Maintenance/Detailing 118 05-14-2019 10:52 AM
Check engine light vsc trac & trac off lights come on piptraderfx New Members 5 03-14-2014 07:47 AM
vsc and trac control lights keep coming on virginiayota 4th Gen T4Rs 7 07-25-2012 10:55 AM
Check engine light Vsc trac Vsc trac off deadmaggot6 Problems & Warranty Issues 0 10-06-2008 09:44 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 02:15 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2020