User Tag List

Reply
 
Thread Tools Rate Thread Display Modes
Old 05-06-2021, 05:59 PM #1
gruenegenes gruenegenes is offline
Junior Member
 
Join Date: Jan 2021
Location: Texas
Posts: 25
gruenegenes is on a distinguished road
gruenegenes gruenegenes is offline
Junior Member
 
Join Date: Jan 2021
Location: Texas
Posts: 25
gruenegenes is on a distinguished road
Temporary, intermittent loss of power/hesitation

2002, SR5, 4WD, 170,000 miles

While driving, or starting from a stop, my 4Runner will lose power. It’s as if I took my foot off the accelerator. The engine doesn't die, it's just that the RPMs drop to idle and there is no response to the accelerator pedal. It doesn’t matter if move the pedal, floor it or do anything else. The power just cuts out. Within 1 to 3 seconds, it will regain power. However – and I think this is interesting – the power doesn’t come back with the power equivalent to the pedal position. It always ramps up slowly as if I’m starting slowly from a stop. In other words, if I have the pedal floored, when the power returns, it doesn’t jump to full throttle. It slowly builds back up to whatever position I have the pedal in.

The problem comes and goes. It will last for a few days, then be gone for weeks.

If it was the throttle position sensor, would the throttle slowly build up like it does or would it suddenly return to whatever position the pedal is in? Could it be the ECM?

I originally had a long crank issue that turned out to be a vacuum leak, but in the process, I did A LOT of work. All of this has been done

- Checked and cleaned all grounds in the engine compartment
- Replaced plugs
- Replaced plug wires
- Replaced battery
- Replaced fuel filter
- Replaced air filter
- Replaced PCV valve
- Replaced fuel pump and pump screen
- Replaced front (AF) and rear O2 sensors
- Replaced Fuel Pressure Regulator
- Refurbished original OEM fuel injectors
- Cleaned MAF sensor
- Cleaned throttle body
- Disconnected battery to clear memory
- Smoke tested for vacuum leaks – replaced hose clamps and vacuum plugs
- Ohm tested Throttle Control Motor, Throttle Position Sensor and Accelerator Pedal Position Sensor – all 3 passed (the 2002 doesn’t have an Idle Air Control Valve)
- No check engine light and no stored codes
- Ran through 2 cans of seafoam
- Replaced every fuse related to the ECU or fuel injection
- Took it to mechanic twice and he couldn't find anything
__________________
2002 SR5 4WD
gruenegenes is offline   Reply With QuoteReply With Quote
Old 05-06-2021, 11:28 PM #2
photoleif photoleif is offline
Member
 
Join Date: Oct 2019
Location: Dolores, CO
Posts: 220
Real Name: Leif
photoleif will become famous soon enough
photoleif photoleif is offline
Member
 
Join Date: Oct 2019
Location: Dolores, CO
Posts: 220
Real Name: Leif
photoleif will become famous soon enough
geez that's sounding a lot like a clutch problem i had with my pickup, but it's a manual and i see you've got a 2002 so that cause won't port over exactly. does your auto have a speed sensor on the transmission, and it could possibly be fouled? sorry for not being very familiar with that transmission. is this among those you resistance-tested? there's one on the tcase too?
__________________
'99 'Highlander' 4R SR5 5VZ-FE | 5-spd | LED lighting | TBU | 265-75R17 Duratrac stuffed after some pinch-weld convincing

'95 Xtra cab 5VZ-FE swap 5-spd | 33x10.50-15 BFG AT/KOs | 4" Superlift | ARB rear locker | OME torsion bars | Total Chaos idler arm & uniball | Smittybilt bumpers | Sportsman topper | Aisin manual hubs | K&N | Dual Optimas | Extended diff breathers | Bilstein 5100s | De-striped | Hella pencil-beams
photoleif is offline   Reply With QuoteReply With Quote
Old 05-07-2021, 12:24 AM #3
RumHam26 RumHam26 is offline
Member
 
Join Date: Oct 2017
Location: Palatine, IL
Posts: 132
RumHam26 is on a distinguished road
RumHam26 RumHam26 is offline
Member
 
Join Date: Oct 2017
Location: Palatine, IL
Posts: 132
RumHam26 is on a distinguished road
This sounds like when my overactive VSC/TRAC system kicks on. Do you ever notice the VSC/TRAC lights coming in during this?

You could test your wheel speed sensors, check the for damage/gear oil on them, and make sure they're proper seated (not lifting up from rust). You could also try disabling the VSC/TRAC system to see if still happens to rule this. I don't know how to do it, but the Andy Mod deals with this that.
RumHam26 is offline   Reply With QuoteReply With Quote
Old 05-07-2021, 09:22 AM #4
Bad Luck Bad Luck is offline
Senior Member
 
Join Date: Feb 2019
Location: Hot Springs, AR
Posts: 1,876
Real Name: Patrick
Bad Luck is a splendid one to behold Bad Luck is a splendid one to behold Bad Luck is a splendid one to behold Bad Luck is a splendid one to behold Bad Luck is a splendid one to behold Bad Luck is a splendid one to behold
Bad Luck Bad Luck is offline
Senior Member
 
Join Date: Feb 2019
Location: Hot Springs, AR
Posts: 1,876
Real Name: Patrick
Bad Luck is a splendid one to behold Bad Luck is a splendid one to behold Bad Luck is a splendid one to behold Bad Luck is a splendid one to behold Bad Luck is a splendid one to behold Bad Luck is a splendid one to behold
Have you looked at live data of your throttle position sensor while slowly applying the throttle? There might be a dead spot in the sensor that you won't pick up with a resistance check.
__________________
2000 Limited V6 Auto E-Locker
Bad Luck is offline   Reply With QuoteReply With Quote
Old 05-07-2021, 10:36 AM #5
Malcolm99's Avatar
Malcolm99 Malcolm99 is offline
Member
 
Join Date: May 2020
Location: Ontario
Posts: 348
Malcolm99 will become famous soon enough Malcolm99 will become famous soon enough
Malcolm99 Malcolm99 is offline
Member
Malcolm99's Avatar
 
Join Date: May 2020
Location: Ontario
Posts: 348
Malcolm99 will become famous soon enough Malcolm99 will become famous soon enough
What is your Fuel Trims ST/LT, and what is the MAF temp and flow readings. I'd probably throw a new MAF at it if you can't pull live data.
__________________
99' Ltd E-locker grey wired, 4R Bilstein 5100, 99 tall coils, 906 OME & 1.5" spacers, 2015 4R Trail Edition 275/70R17, 1" RB BL
97' SR5 E-locker grey wired, Warn winch, 2" RB BL, Sonoran Steel 1.2 lift, dual battery, 1000W inverter, Hydraulic Arctic plow, 12" x 33" Baja Claw
92' Eclipse GSX AWD 6/4 bolt combo, 28 PSI boost, Meth injection, 750cc injectors, FMIC, 2.5" IC piping, full 3" exhaust, 350AWHP, lowered, Alum flywheel, 6 puck Clutch, Cams, JDM gear set,VC rear diff, EPROM ECU

Last edited by Malcolm99; 05-08-2021 at 01:50 AM.
Malcolm99 is offline   Reply With QuoteReply With Quote
Old 05-10-2021, 11:26 PM #6
plcfcng's Avatar
plcfcng plcfcng is offline
Member
 
Join Date: Apr 2017
Location: Southern California (please don't hold it against me)
Posts: 419
Real Name: michael
plcfcng will become famous soon enough plcfcng will become famous soon enough
plcfcng plcfcng is offline
Member
plcfcng's Avatar
 
Join Date: Apr 2017
Location: Southern California (please don't hold it against me)
Posts: 419
Real Name: michael
plcfcng will become famous soon enough plcfcng will become famous soon enough
I would look into a clogged cat a Vac gauge that reads low is a easy check..
plcfcng is offline   Reply With QuoteReply With Quote
Reply

Tags
pedal , position , power , replaced , throttle

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mysterious, temporary power loss ølaf 3rd gen T4Rs 11 07-06-2017 11:56 AM
Temporary shudder and loss of power during shifting IBobi 3rd gen T4Rs 5 10-24-2016 07:57 PM
hesitation and loss of power Squirt 3rd gen T4Rs 2 02-11-2015 12:40 AM
Temporary loss of power ... need your help! Igoboe 3rd gen T4Rs 6 11-26-2012 07:59 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 05:10 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2020