User Tag List

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-19-2022, 07:30 PM #1
Lamer's Avatar
Lamer Lamer is offline
Member
 
Join Date: Jan 2012
Location: Houston, TX
Age: 34
Posts: 498
Real Name: Jake
Lamer will become famous soon enough Lamer will become famous soon enough
Lamer Lamer is offline
Member
Lamer's Avatar
 
Join Date: Jan 2012
Location: Houston, TX
Age: 34
Posts: 498
Real Name: Jake
Lamer will become famous soon enough Lamer will become famous soon enough
Question P340 fixed but still stalling

Howdy all.
a few times now i've had the vehicle shut down on me when I slow to a stop. at first it also triggered a check engine light [P340 - camshaft position sensor]. So I promptly replaced that and got going again.

Today on my way to work it stalled again but no check engine light. I have really no idea what to do. I have bought a new fuel filter to install later this week. but maybe injectors?

There is no lag when accelerating, and no funny shifting when going through gears (automatic).

When I come to a stop, I watch the rpms as they drop. its hit or miss but sometimes it drops to 525 and sometimes its 650 (is it should be). when it gets to 525 it sort of oscillates and sometimes dies.

Can anyone help me here?
__________________
https://i.imgur.com/WQdryKXm.jpg
The Sequel - 1996 4Runner SR5 - Houston, TX
The Original - 2001 4runner SR5 - SOLD
Etsy Page - Custom Pinstriping and Sign Making
@8LinePinstripe: Instagram
Lamer is offline   Reply With QuoteReply With Quote
Old 09-19-2022, 07:56 PM #2
Zhehan Zhehan is offline
Member
 
Join Date: Jul 2022
Location: Beaverton
Posts: 64
Zhehan is on a distinguished road
Zhehan Zhehan is offline
Member
 
Join Date: Jul 2022
Location: Beaverton
Posts: 64
Zhehan is on a distinguished road
Did you clean the Throttle Body lately?
__________________
2000 4Runner SR5 Manual Trans Federal Emissions - Tundra TRD/5100, LC 7.5 Coils/OME 60028, JBA UCA, SPC 25945 Rear Lower Links, TrakMotive Xtended Travel CV Axles TO-8043ET, South Bend Rally Clutch, ES & Whiteline Bushings, MagnaFlow Cat-Back, Deck-Plate Mod, AIRAID MIT, Perfect Power SMT-5, 4.56 Yukon Gears, Yukon Grizzly Rear Locker, 16x8 Wheels w/ 285/75 General Grabber AT2, 223K+ Miles
Zhehan is offline   Reply With QuoteReply With Quote
Old 09-19-2022, 08:14 PM #3
brillo_76's Avatar
brillo_76 brillo_76 is online now
Senior Member
 
Join Date: May 2017
Location: Western PA
Posts: 4,432
Real Name: Jon
brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future
brillo_76 brillo_76 is online now
Senior Member
brillo_76's Avatar
 
Join Date: May 2017
Location: Western PA
Posts: 4,432
Real Name: Jon
brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future
So it's not like manual clutch not being pushed in and hard stop. The engine rpm just fall off and stull. I probably clean the throttle body and the iac valve most likely your cause

Sent from my SM-A505U using Tapatalk
__________________
6 3rd gens listed in the build thread
Build Thread: https://www.toyota-4runner.org/3rd-g...os-builds.html
Brillo's Bucket Fluid Ex changer: https://www.toyota-4runner.org/3rd-g...ml#post3358086
Sparks Plugs Wire and Coil Information: https://www.toyota-4runner.org/3rd-g...ion-5vz-fe.htm
brillo_76 is online now   Reply With QuoteReply With Quote
Old 09-19-2022, 08:25 PM #4
Lamer's Avatar
Lamer Lamer is offline
Member
 
Join Date: Jan 2012
Location: Houston, TX
Age: 34
Posts: 498
Real Name: Jake
Lamer will become famous soon enough Lamer will become famous soon enough
Lamer Lamer is offline
Member
Lamer's Avatar
 
Join Date: Jan 2012
Location: Houston, TX
Age: 34
Posts: 498
Real Name: Jake
Lamer will become famous soon enough Lamer will become famous soon enough
Quote:
Originally Posted by brillo_76 View Post
So it's not like manual clutch not being pushed in and hard stop. The engine rpm just fall off and stull. I probably clean the throttle body and the iac valve most likely your cause

Sent from my SM-A505U using Tapatalk
correct, rpms just fall off to zero.
This is a much more time efficient option. i'll try to get that done this week. thanks!

Quote:
Originally Posted by Zhehan View Post
Did you clean the Throttle Body lately?
Indeed will try this. thanks!
__________________
https://i.imgur.com/WQdryKXm.jpg
The Sequel - 1996 4Runner SR5 - Houston, TX
The Original - 2001 4runner SR5 - SOLD
Etsy Page - Custom Pinstriping and Sign Making
@8LinePinstripe: Instagram
Lamer is offline   Reply With QuoteReply With Quote
Old 09-20-2022, 03:31 PM #5
Lamer's Avatar
Lamer Lamer is offline
Member
 
Join Date: Jan 2012
Location: Houston, TX
Age: 34
Posts: 498
Real Name: Jake
Lamer will become famous soon enough Lamer will become famous soon enough
Lamer Lamer is offline
Member
Lamer's Avatar
 
Join Date: Jan 2012
Location: Houston, TX
Age: 34
Posts: 498
Real Name: Jake
Lamer will become famous soon enough Lamer will become famous soon enough
Ok, throttle body cleaned. will see hoe confident I am on my way to work tomorrow.
__________________
https://i.imgur.com/WQdryKXm.jpg
The Sequel - 1996 4Runner SR5 - Houston, TX
The Original - 2001 4runner SR5 - SOLD
Etsy Page - Custom Pinstriping and Sign Making
@8LinePinstripe: Instagram
Lamer is offline   Reply With QuoteReply With Quote
Old 09-20-2022, 05:38 PM #6
Lamer's Avatar
Lamer Lamer is offline
Member
 
Join Date: Jan 2012
Location: Houston, TX
Age: 34
Posts: 498
Real Name: Jake
Lamer will become famous soon enough Lamer will become famous soon enough
Lamer Lamer is offline
Member
Lamer's Avatar
 
Join Date: Jan 2012
Location: Houston, TX
Age: 34
Posts: 498
Real Name: Jake
Lamer will become famous soon enough Lamer will become famous soon enough
Exclamation

well just picked up my daughter from day care and it stalled again, with the P0340 code again!
- it's a new (not OEM) camshaft position sensor! not happy.

Also, after cleaning the throttle body, it idles at 900rpm now but think that will just level out over time?
__________________
https://i.imgur.com/WQdryKXm.jpg
The Sequel - 1996 4Runner SR5 - Houston, TX
The Original - 2001 4runner SR5 - SOLD
Etsy Page - Custom Pinstriping and Sign Making
@8LinePinstripe: Instagram
Lamer is offline   Reply With QuoteReply With Quote
Old 09-20-2022, 07:12 PM #7
Zhehan Zhehan is offline
Member
 
Join Date: Jul 2022
Location: Beaverton
Posts: 64
Zhehan is on a distinguished road
Zhehan Zhehan is offline
Member
 
Join Date: Jul 2022
Location: Beaverton
Posts: 64
Zhehan is on a distinguished road
The reason I asked about cleaning the throttle body recently was it can cause issues like you're experiencing when debris fall into the IAC valve. This is a common problem when cleaning your TB. There are many threads about this issue. The high Idle you're experiencing now means you have debris in the IAC valve because you cleaned your TB. You're going to need to clean out the IAC valve to restore a normal idle speed.

The other symptoms you are experiencing related to the p0340 code are also symptomatic of IAC valve issues and throttle body issues. That's why we brought that subject up.

However, your main issue seems pretty specific to your Cam Position Sensor. The information you provided today I made that more apparent.

Having said that here is a thorough look at the p0340 code you are experiencing:

https://www.way.com/blog/p0340-error...shaft%20timing.
__________________
2000 4Runner SR5 Manual Trans Federal Emissions - Tundra TRD/5100, LC 7.5 Coils/OME 60028, JBA UCA, SPC 25945 Rear Lower Links, TrakMotive Xtended Travel CV Axles TO-8043ET, South Bend Rally Clutch, ES & Whiteline Bushings, MagnaFlow Cat-Back, Deck-Plate Mod, AIRAID MIT, Perfect Power SMT-5, 4.56 Yukon Gears, Yukon Grizzly Rear Locker, 16x8 Wheels w/ 285/75 General Grabber AT2, 223K+ Miles
Zhehan is offline   Reply With QuoteReply With Quote
Old 09-20-2022, 07:52 PM #8
RandyBobandy's Avatar
RandyBobandy RandyBobandy is offline
Member
 
Join Date: Jan 2019
Location: Southwest PA
Posts: 606
RandyBobandy is just really nice RandyBobandy is just really nice RandyBobandy is just really nice RandyBobandy is just really nice
RandyBobandy RandyBobandy is offline
Member
RandyBobandy's Avatar
 
Join Date: Jan 2019
Location: Southwest PA
Posts: 606
RandyBobandy is just really nice RandyBobandy is just really nice RandyBobandy is just really nice RandyBobandy is just really nice
Quote:
Originally Posted by Lamer View Post
- it's a new (not OEM) camshaft position sensor! not happy.
Thatís most likely your issue, get an oem sensor
RandyBobandy is offline   Reply With QuoteReply With Quote
Old 09-20-2022, 08:16 PM #9
brillo_76's Avatar
brillo_76 brillo_76 is online now
Senior Member
 
Join Date: May 2017
Location: Western PA
Posts: 4,432
Real Name: Jon
brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future
brillo_76 brillo_76 is online now
Senior Member
brillo_76's Avatar
 
Join Date: May 2017
Location: Western PA
Posts: 4,432
Real Name: Jon
brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future brillo_76 has a brilliant future
Also verify that wire harness to the cam sensor is good. Alot of times they deteriorate and need replaced as well...

Sent from my SM-A505U using Tapatalk
__________________
6 3rd gens listed in the build thread
Build Thread: https://www.toyota-4runner.org/3rd-g...os-builds.html
Brillo's Bucket Fluid Ex changer: https://www.toyota-4runner.org/3rd-g...ml#post3358086
Sparks Plugs Wire and Coil Information: https://www.toyota-4runner.org/3rd-g...ion-5vz-fe.htm
brillo_76 is online now   Reply With QuoteReply With Quote
Old 09-20-2022, 08:37 PM #10
spartacus's Avatar
spartacus spartacus is offline
Senior Member
 
Join Date: Mar 2010
Location: denver
Posts: 2,772
spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of
spartacus spartacus is offline
Senior Member
spartacus's Avatar
 
Join Date: Mar 2010
Location: denver
Posts: 2,772
spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of
Check the resistance is in spec.
Attached Images
P340 fixed but still stalling-screenshot_2022-09-20-16-22-44-1-jpg 
spartacus is offline   Reply With QuoteReply With Quote
Old 10-02-2022, 03:56 PM #11
Lamer's Avatar
Lamer Lamer is offline
Member
 
Join Date: Jan 2012
Location: Houston, TX
Age: 34
Posts: 498
Real Name: Jake
Lamer will become famous soon enough Lamer will become famous soon enough
Lamer Lamer is offline
Member
Lamer's Avatar
 
Join Date: Jan 2012
Location: Houston, TX
Age: 34
Posts: 498
Real Name: Jake
Lamer will become famous soon enough Lamer will become famous soon enough
Quote:
Originally Posted by Zhehan View Post
The reason I asked about cleaning the throttle body recently was it can cause issues like you're experiencing when debris fall into the IAC valve. This is a common problem when cleaning your TB. There are many threads about this issue. The high Idle you're experiencing now means you have debris in the IAC valve because you cleaned your TB. You're going to need to clean out the IAC valve to restore a normal idle speed.

The other symptoms you are experiencing related to the p0340 code are also symptomatic of IAC valve issues and throttle body issues. That's why we brought that subject up.

However, your main issue seems pretty specific to your Cam Position Sensor. The information you provided today I made that more apparent.

Having said that here is a thorough look at the p0340 code you are experiencing:

https://www.way.com/blog/p0340-error...shaft%20timing.
thanks for this, bookmarked.
the idle has actually come down to ~600 over a few days and seems to be holding. so far much more reliable. I plan on cleaning the entire intake from MAF to TB and IAC when I have time. (and replace fuel filter)

Quote:
Originally Posted by RandyBobandy View Post
Thatís most likely your issue, get an oem sensor
if I need to I will.

Quote:
Originally Posted by brillo_76 View Post
Also verify that wire harness to the cam sensor is good. Alot of times they deteriorate and need replaced as well...

Sent from my SM-A505U using Tapatalk
ya didnt get a good look at this. i'll check when I go back in

Quote:
Originally Posted by spartacus View Post
Check the resistance is in spec.
saw this on the toolmans videos, everything checks out.
__________________
https://i.imgur.com/WQdryKXm.jpg
The Sequel - 1996 4Runner SR5 - Houston, TX
The Original - 2001 4runner SR5 - SOLD
Etsy Page - Custom Pinstriping and Sign Making
@8LinePinstripe: Instagram
Lamer is offline   Reply With QuoteReply With Quote
Old 10-03-2022, 11:19 AM #12
spartacus's Avatar
spartacus spartacus is offline
Senior Member
 
Join Date: Mar 2010
Location: denver
Posts: 2,772
spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of
spartacus spartacus is offline
Senior Member
spartacus's Avatar
 
Join Date: Mar 2010
Location: denver
Posts: 2,772
spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of spartacus has much to be proud of
Crank shaft gear could have a broken tooth.
spartacus is offline   Reply With QuoteReply With Quote
Old 10-03-2022, 10:23 PM #13
diverscale's Avatar
diverscale diverscale is offline
Member
 
Join Date: Jul 2012
Location: canada
Posts: 858
diverscale will become famous soon enough
diverscale diverscale is offline
Member
diverscale's Avatar
 
Join Date: Jul 2012
Location: canada
Posts: 858
diverscale will become famous soon enough
Also, ensure you disassembled your idle air control valve from the t/b. The problem is the valve, not the t/b

I had the same issue, finally fixed it using Seafoam throttle body cleaner, as it leaves a highly lubricating ''residue'', which you don't clean.

I let the valve assembly sit in the thing for a night and cleaned it good.

Now just have to ''add'' seafoam t/b cleaner before every winter, 1 time a year, to keep the problem away. I just dismantle the piping and shoot it directly in the IAC opening before the throttle plate and then start the truck.

I didn't get your cam sensor code with the stalling though
__________________
1998 4runner SR5
diverscale is offline   Reply With QuoteReply With Quote
Old 10-29-2022, 02:57 PM #14
Lamer's Avatar
Lamer Lamer is offline
Member
 
Join Date: Jan 2012
Location: Houston, TX
Age: 34
Posts: 498
Real Name: Jake
Lamer will become famous soon enough Lamer will become famous soon enough
Lamer Lamer is offline
Member
Lamer's Avatar
 
Join Date: Jan 2012
Location: Houston, TX
Age: 34
Posts: 498
Real Name: Jake
Lamer will become famous soon enough Lamer will become famous soon enough
thanks all for the comments.

The car was running great for a little while and now I have 3 codes

P0340 / P0130 / P0133

P0340 - I'll probably go back and install the OEM sensor from the factory knowing that the aftermarket one isn't the fix but was cleaning the IAC valve. that salved my idle issue. i'll give the IAC another good clean anyways.

P0130 / P0133 - already have new O2 sensors on order.

should be a fun weekend, just not sure which weekend that will be.
__________________
https://i.imgur.com/WQdryKXm.jpg
The Sequel - 1996 4Runner SR5 - Houston, TX
The Original - 2001 4runner SR5 - SOLD
Etsy Page - Custom Pinstriping and Sign Making
@8LinePinstripe: Instagram
Lamer is offline   Reply With QuoteReply With Quote
Old 11-02-2022, 11:42 PM #15
theriddler's Avatar
theriddler theriddler is offline
Member
 
Join Date: Sep 2014
Location: Southern Indiana
Posts: 222
theriddler is on a distinguished road
theriddler theriddler is offline
Member
theriddler's Avatar
 
Join Date: Sep 2014
Location: Southern Indiana
Posts: 222
theriddler is on a distinguished road
Quote:
Originally Posted by Lamer View Post
Howdy all.
a few times now i've had the vehicle shut down on me when I slow to a stop. at first it also triggered a check engine light [P340 - camshaft position sensor]. So I promptly replaced that and got going again.

Today on my way to work it stalled again but no check engine light. I have really no idea what to do. I have bought a new fuel filter to install later this week. but maybe injectors?

There is no lag when accelerating, and no funny shifting when going through gears (automatic).

When I come to a stop, I watch the rpms as they drop. its hit or miss but sometimes it drops to 525 and sometimes its 650 (is it should be). when it gets to 525 it sort of oscillates and sometimes dies.

Can anyone help me here?
I'll take a stab at your problem since I've been researching this as well for my vehicle. Mine 4runner doesn't die though, it has a miss if i take off fast and when letting off the throttle when driving down the road, the rpms will take a dive and then come back up to normal. It's never died and is totally driveable but it is annoying. I plan on tackling this issue when i replace the timing belt, water pump, etc.

It could possibly be a crank gear that has a worn keyway. This video explains it...
One Reason why the Toyota 3.4 liter Engine is Sluggish on Throttle part 1 - YouTube
One Reason why the Toyota 3.4 liter Engine is Sluggish on Throttle FIX part 2 - YouTube

Another issue can be the cam sensor getting wet so check for any coolant leaks around the cam sensor. I have 1st hand experience with this, we had a 2002 4runner that we had the timing belt replaced on and shortly after getting it back it began to stall out. I noticed a slight coolant leak getting the cam sensor wet so i sprayed it off with contact cleaner and the vehicle immediately ran better. The mechanic fixed the leak and all was fine after that.

Good luck to you, please post us the fix when you find it
__________________

2002 4Runner Sport Edition-285/75R16 Duratracs, OME suspension, TRD wheels, Shrockworks front/rear bumpers, White Knuckle sliders, etc.
theriddler is offline   Reply With QuoteReply With Quote
Reply

Tags
accelerating , check , engine , light , stop

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dealer 'fixed' stripped thread but threads are in fact not fixed Toronto4runner2 Problems & Warranty Issues 2 08-06-2022 05:48 PM
Stalling on 4th Gen JP4RNR Problems & Warranty Issues 3 12-28-2012 01:20 AM
Stalling jroberts 3rd gen T4Rs 2 08-02-2012 01:16 AM
5th Gen ('12) Stalling Out? Infrared013 5th gen T4Rs 2 05-19-2012 06:43 PM
Stalling GreenRunner Problems & Warranty Issues 4 07-06-2007 07:46 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 08:52 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2022 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2022 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2022 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2020