User Tag List

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-04-2023, 03:06 PM #1
gruenegenes gruenegenes is offline
Member
 
Join Date: Jan 2021
Location: Texas
Posts: 44
gruenegenes is on a distinguished road
gruenegenes gruenegenes is offline
Member
 
Join Date: Jan 2021
Location: Texas
Posts: 44
gruenegenes is on a distinguished road
New ECU Not Working

My 4Runner runs fine with the exception of a brief power loss that happens 1 to 2 times/year. Last time the code said the ECU was bad.

I ordered a remanufactured ECU from Flagship One and the vehicle would crank but not start. I sent it back twice and all three units had the same problem - It cranks a but wonít start. I put the old one in and it starts fine. Am I doing something wrong?

2002 SR5 4WD
__________________
2002 SR5 4WD
gruenegenes is offline   Reply With QuoteReply With Quote
Old 11-04-2023, 09:30 PM #2
_Ace_'s Avatar
_Ace_ _Ace_ is offline
Member
 
Join Date: Oct 2023
Location: Colorado
Posts: 198
_Ace_ will become famous soon enough
_Ace_ _Ace_ is offline
Member
_Ace_'s Avatar
 
Join Date: Oct 2023
Location: Colorado
Posts: 198
_Ace_ will become famous soon enough
What code is your scanner reading?
__________________
1998 SR5 - 5 speed w/ 4.30 E-locker

My 1998 SR5 Build Thread
_Ace_ is offline   Reply With QuoteReply With Quote
Old 11-06-2023, 09:59 AM #3
Bad Luck Bad Luck is offline
Senior Member
 
Join Date: Feb 2019
Location: Hot Springs, AR
Posts: 4,410
Real Name: Patrick
Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute
Bad Luck Bad Luck is offline
Senior Member
 
Join Date: Feb 2019
Location: Hot Springs, AR
Posts: 4,410
Real Name: Patrick
Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute
Quote:
Originally Posted by gruenegenes View Post
My 4Runner runs fine with the exception of a brief power loss that happens 1 to 2 times/year. Last time the code said the ECU was bad.

I ordered a remanufactured ECU from Flagship One and the vehicle would crank but not start. I sent it back twice and all three units had the same problem - It cranks a but wonít start. I put the old one in and it starts fine. Am I doing something wrong?

2002 SR5 4WD
Sounds like the new ECM's don't have your immobilizer programmed into it. What was the original trouble code?
__________________
2000 SR5 V6 Manual 4WD https://www.toyota-4runner.org/3rd-g...biography.html
2000 Limited V6 Auto E-Locker Sold 3/2022
Bad Luck is offline   Reply With QuoteReply With Quote
Old 11-06-2023, 10:43 AM #4
gruenegenes gruenegenes is offline
Member
 
Join Date: Jan 2021
Location: Texas
Posts: 44
gruenegenes is on a distinguished road
gruenegenes gruenegenes is offline
Member
 
Join Date: Jan 2021
Location: Texas
Posts: 44
gruenegenes is on a distinguished road
The code was P1129. Details here:
Temporary, intermittent loss of power/hesitation

Was the immobilizer used on the 2002 model? If so is there a way to program it into the module?
__________________
2002 SR5 4WD
gruenegenes is offline   Reply With QuoteReply With Quote
Old 11-06-2023, 11:41 AM #5
Bad Luck Bad Luck is offline
Senior Member
 
Join Date: Feb 2019
Location: Hot Springs, AR
Posts: 4,410
Real Name: Patrick
Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute
Bad Luck Bad Luck is offline
Senior Member
 
Join Date: Feb 2019
Location: Hot Springs, AR
Posts: 4,410
Real Name: Patrick
Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute
Quote:
Originally Posted by gruenegenes View Post
The code was P1129. Details here:
Temporary, intermittent loss of power/hesitation

Was the immobilizer used on the 2002 model? If so is there a way to program it into the module?
As far as I know all 01-02's used an immobilizer system. There's a couple people that have reflashed their immobilizer but I can't remember who it was or how they did it.
__________________
2000 SR5 V6 Manual 4WD https://www.toyota-4runner.org/3rd-g...biography.html
2000 Limited V6 Auto E-Locker Sold 3/2022
Bad Luck is offline   Reply With QuoteReply With Quote
Old 11-06-2023, 04:35 PM #6
phattyduck phattyduck is offline
Elite Member
 
Join Date: Mar 2016
Location: Pasadena, CA
Posts: 5,403
phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute
phattyduck phattyduck is offline
Elite Member
 
Join Date: Mar 2016
Location: Pasadena, CA
Posts: 5,403
phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute
Quote:
Originally Posted by gruenegenes View Post
The code was P1129. Details here:
Temporary, intermittent loss of power/hesitation

Was the immobilizer used on the 2002 model? If so is there a way to program it into the module?


Top: No immobilizer
Bottom: Immobilizer

Which one do you have?

Immobilizer ECU and no immobilizer in vehicle = no start
Immobilizer ECU and mis-matched programming = no start

The immobilizer does not stop the engine from cranking, it stops it from starting.

-Charlie
__________________
'99 4Runner SR5 Auto - 4WD swapped
'89 Camry Alltrac LE 3S-GTE 5spd
'17 Chevy Volt Premier
'16 Honda Odyssey Elite
Previous: '88 Camry Alltrac LE 3S-GE BEAMS, 90 Camry 3S-GTE, 90 Camry DX, '03 WRX wagon, '08 Outback XT
phattyduck is offline   Reply With QuoteReply With Quote
Old 11-06-2023, 04:47 PM #7
Bad Luck Bad Luck is offline
Senior Member
 
Join Date: Feb 2019
Location: Hot Springs, AR
Posts: 4,410
Real Name: Patrick
Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute
Bad Luck Bad Luck is offline
Senior Member
 
Join Date: Feb 2019
Location: Hot Springs, AR
Posts: 4,410
Real Name: Patrick
Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute Bad Luck has a reputation beyond repute
Quote:
Originally Posted by phattyduck View Post


Top: No immobilizer
Bottom: Immobilizer

Which one do you have?

Immobilizer ECU and no immobilizer in vehicle = no start
Immobilizer ECU and mis-matched programming = no start

The immobilizer does not stop the engine from cranking, it stops it from starting.

-Charlie
Was that only for 01-02? My 2000 Limited had an immobilizer and the keys looked like the top key in your photo.
__________________
2000 SR5 V6 Manual 4WD https://www.toyota-4runner.org/3rd-g...biography.html
2000 Limited V6 Auto E-Locker Sold 3/2022
Bad Luck is offline   Reply With QuoteReply With Quote
Old 11-08-2023, 07:35 AM #8
gruenegenes gruenegenes is offline
Member
 
Join Date: Jan 2021
Location: Texas
Posts: 44
gruenegenes is on a distinguished road
gruenegenes gruenegenes is offline
Member
 
Join Date: Jan 2021
Location: Texas
Posts: 44
gruenegenes is on a distinguished road
Quote:
Originally Posted by phattyduck View Post


Top: No immobilizer
Bottom: Immobilizer

Which one do you have?

Immobilizer ECU and no immobilizer in vehicle = no start
Immobilizer ECU and mis-matched programming = no start

The immobilizer does not stop the engine from cranking, it stops it from starting.

-Charlie
Iím trying to upload a pic but it keeps telling me upload failed. The top of the key is thin black plastic. Nothing like the thickness of our 2016 highlander or 2017 tundra. Itís also generic. I donít think it has a chip in there. Does that mean it does not have an immobilizer?
__________________
2002 SR5 4WD
gruenegenes is offline   Reply With QuoteReply With Quote
Old 11-08-2023, 11:34 AM #9
_Ace_'s Avatar
_Ace_ _Ace_ is offline
Member
 
Join Date: Oct 2023
Location: Colorado
Posts: 198
_Ace_ will become famous soon enough
_Ace_ _Ace_ is offline
Member
_Ace_'s Avatar
 
Join Date: Oct 2023
Location: Colorado
Posts: 198
_Ace_ will become famous soon enough
Your image is too big. If you resize it to a smaller resolution/file size you can upload it.
__________________
1998 SR5 - 5 speed w/ 4.30 E-locker

My 1998 SR5 Build Thread
_Ace_ is offline   Reply With QuoteReply With Quote
Old 11-08-2023, 02:57 PM #10
gruenegenes gruenegenes is offline
Member
 
Join Date: Jan 2021
Location: Texas
Posts: 44
gruenegenes is on a distinguished road
gruenegenes gruenegenes is offline
Member
 
Join Date: Jan 2021
Location: Texas
Posts: 44
gruenegenes is on a distinguished road
Quote:
Originally Posted by _Ace_ View Post
Your image is too big. If you resize it to a smaller resolution/file size you can upload it.
Thank you. Compressed photo attached
Attached Images
New ECU Not Working-img_9060-jpeg 
__________________
2002 SR5 4WD
gruenegenes is offline   Reply With QuoteReply With Quote
Reply

Tags
back , ecu , fine , start , units

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 4Runner SR5 V6 - Auto-door lock, not working for a year, now magically working! Cookster Problems & Warranty Issues 1 08-09-2019 05:39 PM
Headlights not working on low, high beams working. HELP buckeye4runner08 4th Gen T4Rs 8 02-12-2017 11:29 PM
Turn signal not working? Std trouble shooting isn't working swapmeet 4th Gen T4Rs 9 09-14-2014 11:21 PM
95 rear window not working, motor can be heard working DLPDLP Classic T4Rs 22 01-29-2012 08:17 AM
2001 remote not working, rear wiper/defog not working theedudenator 3rd gen T4Rs 1 02-06-2011 01:10 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 12:42 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2024 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2024 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2024 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2020