User Tag List

Reply
 
Thread Tools Rate Thread Display Modes
Old 12-28-2023, 04:48 PM #1
tjcl0201 tjcl0201 is offline
Junior Member
 
Join Date: Oct 2021
Location: New Mexico
Posts: 10
tjcl0201 is on a distinguished road
tjcl0201 tjcl0201 is offline
Junior Member
 
Join Date: Oct 2021
Location: New Mexico
Posts: 10
tjcl0201 is on a distinguished road
'98 SR5 Rear Dome light

My '98 rear dome light only works when the switch is set to 'on'. It doesn't work when the switch is set to 'door'. Is the switch bad or am I missing something? Is that dome light only for the rear hatch?
tjcl0201 is offline   Reply With QuoteReply With Quote
Old 12-28-2023, 05:24 PM #2
maxthebird maxthebird is offline
Member
 
Join Date: Oct 2015
Location: North Carolina
Posts: 44
maxthebird is on a distinguished road
maxthebird maxthebird is offline
Member
 
Join Date: Oct 2015
Location: North Carolina
Posts: 44
maxthebird is on a distinguished road
If you are referring to the rear dome light (the one above the hatch opening), when the switch is set to off, the light is off at all times; when set to on, the light will be on at all times; when set to door, it will only light when the hatch is open. Sounds like your switch is bad either at the light or on the hatch . Here is a link to another thread that addresses this issue.
Rear Hatch Light Switch??? On/Off/Door Hope this helps.

Last edited by maxthebird; 12-28-2023 at 05:33 PM.
maxthebird is offline   Reply With QuoteReply With Quote
Old 12-28-2023, 05:43 PM #3
RodrickHeffley's Avatar
RodrickHeffley RodrickHeffley is offline
Member
 
Join Date: Jun 2020
Location: UT
Age: 20
Posts: 488
RodrickHeffley has a spectacular aura about RodrickHeffley has a spectacular aura about
RodrickHeffley RodrickHeffley is offline
Member
RodrickHeffley's Avatar
 
Join Date: Jun 2020
Location: UT
Age: 20
Posts: 488
RodrickHeffley has a spectacular aura about RodrickHeffley has a spectacular aura about
I would check to make sure that the "door ajar" light on the cluster is on when the door is open. If it's not, you more than likely have a bad latch sensor, but in my case I replaced that and the issue persisted.
__________________
----------------
1998 4Runner Limited 4WD w/Rear Locker
281k Miles
Build Thread
----------------
RodrickHeffley is offline   Reply With QuoteReply With Quote
Old 12-29-2023, 01:03 AM #4
pluton's Avatar
pluton pluton is offline
Senior Member
 
Join Date: Nov 2012
Location: Santa Monica, CA
Posts: 1,418
Real Name: Keith
pluton has a spectacular aura about pluton has a spectacular aura about pluton has a spectacular aura about
pluton pluton is offline
Senior Member
pluton's Avatar
 
Join Date: Nov 2012
Location: Santa Monica, CA
Posts: 1,418
Real Name: Keith
pluton has a spectacular aura about pluton has a spectacular aura about pluton has a spectacular aura about
Both of the dome switches in my '97 worked flawlessly in 2013, but since about 2020 the 'door' position *on both switches* is a bit flaky. Try, when the door is open, working the switch back and forth many times, fast and slow. If it works intermittently, that suggests perhaps some corrosion or wear on the contacts. I haven't dismantled mine to investigate...yet.
__________________
97 4R SR5, 4WD/Elock, 3.4, 5spd. OME881/890 springs/OME shocks, 265/70/16 BFG AT/KO2.
pluton is offline   Reply With QuoteReply With Quote
Old 12-29-2023, 03:14 PM #5
phattyduck phattyduck is online now
Elite Member
 
Join Date: Mar 2016
Location: Pasadena, CA
Posts: 5,407
phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute
phattyduck phattyduck is online now
Elite Member
 
Join Date: Mar 2016
Location: Pasadena, CA
Posts: 5,407
phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute phattyduck has a reputation beyond repute
Quote:
Originally Posted by pluton View Post
Both of the dome switches in my '97 worked flawlessly in 2013, but since about 2020 the 'door' position *on both switches* is a bit flaky. Try, when the door is open, working the switch back and forth many times, fast and slow. If it works intermittently, that suggests perhaps some corrosion or wear on the contacts. I haven't dismantled mine to investigate...yet.
Yup, for the rear hatch, it can be the light itself (corroded position of the switch), the hatch latch (positions switch is inside the latch mechanism) or hatch wiring.

Check the door ajar indicator first (cluster) to verify hatch wiring and latch switch, then go from there. Do the rest of the functions in the hatch work? (window, wiper, defroster, license plate lights)

-Charlie
__________________
'99 4Runner SR5 Auto - 4WD swapped
'89 Camry Alltrac LE 3S-GTE 5spd
'17 Chevy Volt Premier
'16 Honda Odyssey Elite
Previous: '88 Camry Alltrac LE 3S-GE BEAMS, 90 Camry 3S-GTE, 90 Camry DX, '03 WRX wagon, '08 Outback XT
phattyduck is online now   Reply With QuoteReply With Quote
Old 12-29-2023, 05:06 PM #6
Ben Dejo Ben Dejo is offline
Junior Member
 
Join Date: Sep 2021
Location: Albuquerque
Posts: 6
Ben Dejo is on a distinguished road
Ben Dejo Ben Dejo is offline
Junior Member
 
Join Date: Sep 2021
Location: Albuquerque
Posts: 6
Ben Dejo is on a distinguished road
Quote:
Originally Posted by tjcl0201 View Post
My '98 rear dome light only works when the switch is set to 'on'. It doesn't work when the switch is set to 'door'. Is the switch bad or am I missing something? Is that dome light only for the rear hatch?
The wire bundle for the rear hatch will overtime have wires that pull apart. I had the same thing happen to me. Check out this video from Timmy to see what Im on about. Rear Hatch Wiring Repair (3rd Gen 4runner) - YouTube

After I fixed all the wires in the bundle that broke, I could lock my rear hatch with the remote key fob and all my door locks worked better. After all of that, my rear hatch light stopped working completely. I found the switch in the door latch, with the wire corroded off. Beyond repair since its molded in with epoxy. It wont trigger the "door open" idiot light on the dash since that wire broke.
Good luck
Ben Dejo is offline   Reply With QuoteReply With Quote
Old 12-31-2023, 06:33 PM #7
tjcl0201 tjcl0201 is offline
Junior Member
 
Join Date: Oct 2021
Location: New Mexico
Posts: 10
tjcl0201 is on a distinguished road
tjcl0201 tjcl0201 is offline
Junior Member
 
Join Date: Oct 2021
Location: New Mexico
Posts: 10
tjcl0201 is on a distinguished road
Quote:
Originally Posted by phattyduck View Post
Yup, for the rear hatch, it can be the light itself (corroded position of the switch), the hatch latch (positions switch is inside the latch mechanism) or hatch wiring.

Check the door ajar indicator first (cluster) to verify hatch wiring and latch switch, then go from there. Do the rest of the functions in the hatch work? (window, wiper, defroster, license plate lights)

-Charlie
I will check to see if the light in the cluster works. I have not investigated yet cuz I wasn't sure where I should start.

My glove box light also isn't working. All 3 of the tiny bulbs...glove box and both climate control bulbs were burned out. Replaced both climate control bulbs and they work fine. Glove box isn't. Ugh.

This is my only vehicle and I'd like to keep it in good shape if I can.
tjcl0201 is offline   Reply With QuoteReply With Quote
Old 12-31-2023, 06:45 PM #8
tjcl0201 tjcl0201 is offline
Junior Member
 
Join Date: Oct 2021
Location: New Mexico
Posts: 10
tjcl0201 is on a distinguished road
tjcl0201 tjcl0201 is offline
Junior Member
 
Join Date: Oct 2021
Location: New Mexico
Posts: 10
tjcl0201 is on a distinguished road
Quote:
Originally Posted by phattyduck View Post
Yup, for the rear hatch, it can be the light itself (corroded position of the switch), the hatch latch (positions switch is inside the latch mechanism) or hatch wiring.

Check the door ajar indicator first (cluster) to verify hatch wiring and latch switch, then go from there. Do the rest of the functions in the hatch work? (window, wiper, defroster, license plate lights)

-Charlie

Well, the light does not come on in the instrument cluster when the rear hatch is open.

The rest of the stuff on the hatch works. The rear wiper and wiper fluid. The window rolls up and down.

License plate lights also work. Had to replace a bulb but they both work.

Last edited by tjcl0201; 12-31-2023 at 06:47 PM.
tjcl0201 is offline   Reply With QuoteReply With Quote
Reply

Tags
dome , light , rear , set , switch

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear dome light failing down DRC 4th Gen T4Rs 3 12-05-2018 07:20 PM
rear dome light rear seat audio wiring eric4runner Problems & Warranty Issues 1 02-01-2016 09:10 AM
Rear dome light rlarue New Members 2 03-28-2012 10:48 PM
Rear wiper/rear defroster/dome light not working... fuses? BBV 4th Gen T4Rs 5 03-12-2011 02:55 PM
Rear Compartment Dome Light inthedark Problems & Warranty Issues 10 09-24-2004 03:06 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 03:40 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2024 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2024 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2024 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2020