User Tag List

Reply
 
Thread Tools Rate Thread Display Modes
Old 07-22-2015, 12:34 PM #1
nasdamus's Avatar
nasdamus nasdamus is offline
Member
 
Join Date: Jan 2010
Location: Odenton, MD
Posts: 88
nasdamus is on a distinguished road
nasdamus nasdamus is offline
Member
nasdamus's Avatar
 
Join Date: Jan 2010
Location: Odenton, MD
Posts: 88
nasdamus is on a distinguished road
P0171 - System Too Lean (Bank 1)

Looking for some thoughts. 2003 V6. Keep getting a P0171 code. I pulled the MAF and cleaned it, same with the TB. Came back on after 10 miles. I checked all the vacuum hoses, all seems fine. I replaced the MAF with a known working extra i had, came back after 15 miles. Replaced the air filter (had to anyways), ran some Techron Fuel System Cleaner through a full tank of Shell gasoline. Took a little while to come back on but eventually did (maybe 45 miles).

5,000 miles ago I did replace all spark plugs as well as the PCV valve.

2.5 years ago (20,000 miles ago) i replaced the B1S1 o2 sensor (was getting a P2238 code) with a Denso 234-9047.

Any thoughts on what i should try next? Been searching around and checked most suggestions. I'm currently getting a real rough idle at stop, not stalling out but close.
__________________
2003 Black V6 4WD SR5
nasdamus is offline   Reply With QuoteReply With Quote
Old 07-22-2015, 12:45 PM #2
paperchasin paperchasin is offline
Member
 
Join Date: Apr 2015
Location: SoCal
Posts: 254
paperchasin is on a distinguished road
paperchasin paperchasin is offline
Member
 
Join Date: Apr 2015
Location: SoCal
Posts: 254
paperchasin is on a distinguished road
Need more information, but I'm leaning towards a fuel system problem. Are you able to get fuel trim (both short and long term) info? Preferably for both idle and 2500RPM conditions.
__________________
07 V6 Limited 4WD; FJ Springs + Bilstein 5100's
16 Lexus GX460
paperchasin is offline   Reply With QuoteReply With Quote
Old 07-22-2015, 01:32 PM #3
fullboogie fullboogie is offline
Member
 
Join Date: Mar 2014
Location: Texas
Posts: 322
Real Name: David
fullboogie is on a distinguished road
fullboogie fullboogie is offline
Member
 
Join Date: Mar 2014
Location: Texas
Posts: 322
Real Name: David
fullboogie is on a distinguished road
Bad O2 sensor - change it.
fullboogie is offline   Reply With QuoteReply With Quote
Old 03-29-2016, 07:03 AM #4
Hyfyer1 Hyfyer1 is offline
Junior Member
 
Join Date: Mar 2016
Location: Downingtown PA
Posts: 2
Hyfyer1 is on a distinguished road
Hyfyer1 Hyfyer1 is offline
Junior Member
 
Join Date: Mar 2016
Location: Downingtown PA
Posts: 2
Hyfyer1 is on a distinguished road
I have the same 4Runner, and I'm currently getting P0171 & P0174....checked Vacuum hoses for leaks...all good. All O2 sensor were replaced 3000 miles ago, MAF & TB are fine....The vehicle intermediately bogged on upon acceleration.....Saw A video on this saying it could possibly be a clogged cat, putting excessive exhaust pressure on the engine. So I pulled my cats and noticed one was clogged, I cleaned it and now it got worse. The vehicle just has no pick up when pressing the gas. (Yes I replaced the Fuel Pump a few months ago) I'm going to drill out my cat to see if it remedy's the situation...I'll let you know.
Hyfyer1 is offline   Reply With QuoteReply With Quote
Old 04-28-2016, 10:08 AM #5
celicaben celicaben is offline
Junior Member
 
Join Date: Apr 2016
Location: Bronx NY
Posts: 7
Real Name: Ben Bromberg
celicaben is on a distinguished road
celicaben celicaben is offline
Junior Member
 
Join Date: Apr 2016
Location: Bronx NY
Posts: 7
Real Name: Ben Bromberg
celicaben is on a distinguished road
Angry

i'm having the same issues along with a misfire on cylinders 2-6, also getting "system too lean", and engine sounds like it's running on half the cylinders and bucks when starting out from a stop. i've replaced:
1. plugs
2. wires
3. coil packs and boots
4. pcv valve and gasket
5. mass air flow sensor
6. air filter (k&n cold air intake already installed, engine ran flawless on this for 10 years now)
7. put injector cleaner via fuel tank 4 times now each on a full tank of reliable gas.
8. o2 sensors (both done 10 k miles ago no issues yet there or codes)
what should i do next? i'm thinking its in the throttle body sensor and the idle air control unit. am i right or is it the injectors at this point? PLEASE HELP I NEED TO GET THIS FIXED ASAP
__________________
01 sr5 4runner auto, AEM cold air intake, flowmaster exhaust, viking 3gal air tank with compressor, much more to come.....

Last edited by celicaben; 04-28-2016 at 10:16 AM.
celicaben is offline   Reply With QuoteReply With Quote
Old 04-02-2017, 10:51 AM #6
pjku79 pjku79 is offline
Member
 
Join Date: Jan 2017
Location: San Antonio, TX
Posts: 136
pjku79 is on a distinguished road
pjku79 pjku79 is offline
Member
 
Join Date: Jan 2017
Location: San Antonio, TX
Posts: 136
pjku79 is on a distinguished road
Anyone resolve this? I'm having the same problem on a v8. Figure it might carry over.
pjku79 is offline   Reply With QuoteReply With Quote
Old 10-16-2018, 01:45 AM #7
djpope09 djpope09 is offline
Member
 
Join Date: Dec 2017
Location: Washington
Posts: 264
djpope09 will become famous soon enough
djpope09 djpope09 is offline
Member
 
Join Date: Dec 2017
Location: Washington
Posts: 264
djpope09 will become famous soon enough
Quote:
Originally Posted by celicaben View Post
i'm having the same issues along with a misfire on cylinders 2-6, also getting "system too lean", and engine sounds like it's running on half the cylinders and bucks when starting out from a stop. i've replaced:
1. plugs
2. wires
3. coil packs and boots
4. pcv valve and gasket
5. mass air flow sensor
6. air filter (k&n cold air intake already installed, engine ran flawless on this for 10 years now)
7. put injector cleaner via fuel tank 4 times now each on a full tank of reliable gas.
8. o2 sensors (both done 10 k miles ago no issues yet there or codes)
what should i do next? i'm thinking its in the throttle body sensor and the idle air control unit. am i right or is it the injectors at this point? PLEASE HELP I NEED TO GET THIS FIXED ASAP
Did you ever solve this? I'm getting the fault and misfire on cylinder 1. I don't want to start throwing parts at it if I can help it.
djpope09 is offline   Reply With QuoteReply With Quote
Old 10-16-2018, 07:44 AM #8
UrbanRunner651's Avatar
UrbanRunner651 UrbanRunner651 is offline
Member
 
Join Date: Aug 2017
Location: MN
Posts: 264
Real Name: Newell
UrbanRunner651 will become famous soon enough
UrbanRunner651 UrbanRunner651 is offline
Member
UrbanRunner651's Avatar
 
Join Date: Aug 2017
Location: MN
Posts: 264
Real Name: Newell
UrbanRunner651 will become famous soon enough
Was getting the code off and on for a couple months. Tracked it down to a crack in the header manifold. Replaced both sides with some JBA shorties and haven't had a problem since.
UrbanRunner651 is offline   Reply With QuoteReply With Quote
Old 10-22-2018, 07:27 PM #9
djpope09 djpope09 is offline
Member
 
Join Date: Dec 2017
Location: Washington
Posts: 264
djpope09 will become famous soon enough
djpope09 djpope09 is offline
Member
 
Join Date: Dec 2017
Location: Washington
Posts: 264
djpope09 will become famous soon enough
Quote:
Originally Posted by UrbanRunner651 View Post
Was getting the code off and on for a couple months. Tracked it down to a crack in the header manifold. Replaced both sides with some JBA shorties and haven't had a problem since.
How did you find the leak in the manifold? Was it pretty obvious?

Could you provide a link for the headers you bought?
djpope09 is offline   Reply With QuoteReply With Quote
Old 10-23-2018, 08:23 AM #10
UrbanRunner651's Avatar
UrbanRunner651 UrbanRunner651 is offline
Member
 
Join Date: Aug 2017
Location: MN
Posts: 264
Real Name: Newell
UrbanRunner651 will become famous soon enough
UrbanRunner651 UrbanRunner651 is offline
Member
UrbanRunner651's Avatar
 
Join Date: Aug 2017
Location: MN
Posts: 264
Real Name: Newell
UrbanRunner651 will become famous soon enough
Quote:
Originally Posted by djpope09 View Post
link?
On sale at URD, probably cheaper elsewhere or if you wait until black friday. Different coating options available.
https://www.urdusa.com/jba-headers-2...ilver-ceramic/

I could hear a ticking/exhaust sound that wasn't normal inside the bay and eventually the crack grew large enough I could see it just from looking. It was a shitty weld on an aftermarket header for me but the codes are a pretty good indicator of a leak. You can use a cheap stethoscope without the end on it to listen to areas of the manifold and identify the leak. Or just bring it in to a shop for a quote and they'll find it for you.
UrbanRunner651 is offline   Reply With QuoteReply With Quote
Old 10-23-2018, 08:47 AM #11
Jan777 Jan777 is offline
Member
 
Join Date: Jun 2013
Location: Pristina, Kosovo
Posts: 132
Jan777 is on a distinguished road
Jan777 Jan777 is offline
Member
 
Join Date: Jun 2013
Location: Pristina, Kosovo
Posts: 132
Jan777 is on a distinguished road
to summarize, the causes can be:

1. cracked header manifold
2. defect O2 sensor

Anything I miss?

I have the same symptoms and guess its the manifold, but before starting works I collect all the possible causes!
Jan777 is offline   Reply With QuoteReply With Quote
Old 10-24-2018, 12:03 PM #12
djpope09 djpope09 is offline
Member
 
Join Date: Dec 2017
Location: Washington
Posts: 264
djpope09 will become famous soon enough
djpope09 djpope09 is offline
Member
 
Join Date: Dec 2017
Location: Washington
Posts: 264
djpope09 will become famous soon enough
Quote:
Originally Posted by Jan777 View Post
1. cracked header manifold
2. defect O2 sensor

Anything I miss?

I have the same symptoms and guess its the manifold, but before starting works I collect all the possible causes!
I don't want to muddy the waters, but I'll add that I got this code after having a misfire on cylinder 1. It was misfiring bad enough to cause the too lean code. If you don't have a misfire I think your list is correct.
djpope09 is offline   Reply With QuoteReply With Quote
Old 05-02-2019, 03:49 PM #13
earthrealm earthrealm is offline
Senior Member
 
Join Date: Jan 2012
Location: darkside of the moon
Posts: 1,549
earthrealm will become famous soon enough earthrealm will become famous soon enough
earthrealm earthrealm is offline
Senior Member
 
Join Date: Jan 2012
Location: darkside of the moon
Posts: 1,549
earthrealm will become famous soon enough earthrealm will become famous soon enough
hmmm, lemme examine my manifold, as mine is only bank 2 , p0174
__________________
2005 v6, galactic grey 4wd auto : pioneer avh 4400bh dvd hu, pyle reverse cam
2003 rav4 titanuim silver 4wd auto......sold
2004 rav4 titanuim silver 4wd auto : pionneer avhx 5500bt hu, pyle reverse cam
earthrealm is offline   Reply With QuoteReply With Quote
Old 05-03-2019, 11:49 AM #14
81runner's Avatar
81runner 81runner is offline
Member
 
Join Date: Mar 2018
Location: Moorpark CA
Age: 42
Posts: 479
Real Name: Elliott
81runner has a spectacular aura about 81runner has a spectacular aura about
81runner 81runner is offline
Member
81runner's Avatar
 
Join Date: Mar 2018
Location: Moorpark CA
Age: 42
Posts: 479
Real Name: Elliott
81runner has a spectacular aura about 81runner has a spectacular aura about
A lean bank on only one side can be down stream sensors, or it could be fouling injectors.
__________________
2007 SR5 V6 4WD 205k, Titanium Metallic. 5100s, OME 885/895, extended rear links, ST Maxx 255/75 R17 on 17x8s, mud flap delete,TB spacer, Spectre CAI, DRL delete, HCF delete, DAC delete, K&N cabin filter, TPMS bypass, Fog light mod, USB galore, dash cam, LED lights all over, rear bumper lights, cbi ditch light brackets w/lights, atrac off, OBA w/2 gallon tank/hidden hook up, Trailgear welded sliders, Rocksteady skids, custom swing-out, 3⁰, SE hood w/working vent, Sprint booster, JET MAF, Kenwood TM-V71a w/motorized antenna, custom dual battery, custom roof rack/lights, custom TRED mount, external 12v, rear diff breather, pck, Freedom UCAs, custom stereo, Aluminum rad, trans cooler, 240A alternator...for now...
81runner is offline   Reply With QuoteReply With Quote
Old 05-03-2019, 02:46 PM #15
earthrealm earthrealm is offline
Senior Member
 
Join Date: Jan 2012
Location: darkside of the moon
Posts: 1,549
earthrealm will become famous soon enough earthrealm will become famous soon enough
earthrealm earthrealm is offline
Senior Member
 
Join Date: Jan 2012
Location: darkside of the moon
Posts: 1,549
earthrealm will become famous soon enough earthrealm will become famous soon enough
Quote:
Originally Posted by 81runner View Post
A lean bank on only one side can be down stream sensors, or it could be fouling injectors.
I THINK A CRACK IN THE MANIFOLD of that bank could also throw the CEL. lemme look at my oxygen sensor readings again , last time i checked, they looked fairly normal/within range
__________________
2005 v6, galactic grey 4wd auto : pioneer avh 4400bh dvd hu, pyle reverse cam
2003 rav4 titanuim silver 4wd auto......sold
2004 rav4 titanuim silver 4wd auto : pionneer avhx 5500bt hu, pyle reverse cam
earthrealm is offline   Reply With QuoteReply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
P0171 Lean bank 1 Question jhueter 3rd gen T4Rs 43 08-21-2023 09:48 PM
How to Fix P0171 System to Lean Code speedgoat 3rd gen T4Rs 13 04-10-2022 04:33 PM
P0171 Code - Lean Bank 1... Help? jpontius 3rd gen T4Rs 5 02-23-2013 11:00 AM
Check engine:P0171 system lean jmnral 3rd gen T4Rs 4 03-06-2011 10:33 PM
P0171 (B1 System Too Lean) Rescue84 Problems & Warranty Issues 2 09-27-2006 03:47 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 01:17 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2024 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2024 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2024 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2020