User Tag List

Reply
 
Thread Tools Rate Thread Display Modes
Old 01-28-2019, 12:21 PM #1
john123drury john123drury is offline
Member
 
Join Date: Jul 2014
Location: PA
Posts: 58
john123drury is on a distinguished road
john123drury john123drury is offline
Member
 
Join Date: Jul 2014
Location: PA
Posts: 58
john123drury is on a distinguished road
Warning dash lights intermittently on

Hey gang - 4Runner SR5 2005 170K. I'm having a wierd intermittent issue with the lights on the right side of the dash cluster. See attached image. Thing is it's not consistent. Sometimes when I start the car, the lights will stay on until I turn off the car and start it again. After the 2nd start, usually they go off. Sometimes they don't. But even if they remain on, at some point while running my errands, the lights eventually go off like normal after the initial start up.

And then other times everything is fine. I could go days or weeks with no problems at all. The lights behave normally.

I don't notice anything else out of the ordinary. And it's only on this particular cluster (all of the other dash lights are fine). I even changed the brake light switch thinking that might cause the issue. Can't think of what else it would be. Any suggestions?
john123drury is offline   Reply With QuoteReply With Quote
Old 01-28-2019, 12:23 PM #2
john123drury john123drury is offline
Member
 
Join Date: Jul 2014
Location: PA
Posts: 58
john123drury is on a distinguished road
john123drury john123drury is offline
Member
 
Join Date: Jul 2014
Location: PA
Posts: 58
john123drury is on a distinguished road
pic of issue
Attached Images
Warning dash lights intermittently on-20190122_080346-jpg 
john123drury is offline   Reply With QuoteReply With Quote
Old 01-28-2019, 12:45 PM #3
DMX512 DMX512 is offline
Member
 
Join Date: Jul 2016
Location: Louisville, KY
Posts: 198
Real Name: Ben
DMX512 will become famous soon enough
DMX512 DMX512 is offline
Member
 
Join Date: Jul 2016
Location: Louisville, KY
Posts: 198
Real Name: Ben
DMX512 will become famous soon enough
This is gonna sound strange, but....It is probably your gas cap. My 2007 was doing the same thing and, through this forum I discovered the fix.
I just went to one of the auto parts stores and got a generic gas cap. It has been fine since.
__________________
2007 SR5 v6 4x4
Black
17" wheels
200000 miles
Constant 12v Mod / TPMS Mod
DMX512 is offline   Reply With QuoteReply With Quote
Old 01-28-2019, 12:46 PM #4
Burt Burt is offline
Member
 
Join Date: Nov 2008
Location: Denver Area
Posts: 633
Burt is on a distinguished road
Burt Burt is offline
Member
 
Join Date: Nov 2008
Location: Denver Area
Posts: 633
Burt is on a distinguished road
Pull the codes. Could have ABS issue.
__________________
Burt

2008 SR5 V6 4WD
1984 1/2 GT350 Mustang
2019 F250 SuperDuty
Burt is offline   Reply With QuoteReply With Quote
Old 01-28-2019, 03:26 PM #5
Sithrebel15 Sithrebel15 is offline
Junior Member
 
Join Date: Oct 2016
Posts: 19
Sithrebel15 is on a distinguished road
Sithrebel15 Sithrebel15 is offline
Junior Member
 
Join Date: Oct 2016
Posts: 19
Sithrebel15 is on a distinguished road
I'd put money on it being a wheel speed sensor.
Sithrebel15 is offline   Reply With QuoteReply With Quote
Old 01-28-2019, 06:25 PM #6
jcaino jcaino is offline
Member
 
Join Date: Sep 2018
Location: Pittsburgh
Posts: 180
jcaino will become famous soon enough jcaino will become famous soon enough
jcaino jcaino is offline
Member
 
Join Date: Sep 2018
Location: Pittsburgh
Posts: 180
jcaino will become famous soon enough jcaino will become famous soon enough
Definitely pull the codes before spending any money. Unless you want to buy a code reader.
__________________
2003 Galactic Gray Mica Limited V8
Inside: Pioneer AVH-2300NEX w/ backup cam, Pioneer Sub | LED lighting | always-on USB charging | MPPT controller | BlueSea breakers and circuit blocks | Dometic CFX3 55im | Custom floor with pullout table | Custom drawer setup
Outside: LED Ditch lights on CBI brackets | RCI skid plates | RCI rock sliders | 150w solar
Suspension & Tires: Bilstein 5100's w/ Dobinson c59-314 & c59-505 | Airlift bags | 5th Gen Trail wheels & Wildpeak A/T3W 275/70/17
jcaino is offline   Reply With QuoteReply With Quote
Old 01-28-2019, 10:07 PM #7
ScooterMD's Avatar
ScooterMD ScooterMD is offline
Member
 
Join Date: Dec 2016
Location: Arizona
Posts: 92
ScooterMD is on a distinguished road
ScooterMD ScooterMD is offline
Member
ScooterMD's Avatar
 
Join Date: Dec 2016
Location: Arizona
Posts: 92
ScooterMD is on a distinguished road
Quote:
Originally Posted by DMX512 View Post
This is gonna sound strange, but....It is probably your gas cap. My 2007 was doing the same thing and, through this forum I discovered the fix.
I just went to one of the auto parts stores and got a generic gas cap. It has been fine since.
fully agree. i had the same issue. i don't recall if i pulled any codes. there are many posts on this. i didn't believe it but decided to buy a Toyota gas cap anyway because it was a cheap possible solution; problem fixed immediately. i believe it has to do with pressure in the fuel lines. you might just make sure your current gas cap is tight as hell.
__________________
07 Sport V6
ScooterMD is offline   Reply With QuoteReply With Quote
Old 01-29-2019, 11:38 AM #8
rmstucky rmstucky is offline
Member
 
Join Date: Aug 2010
Location: Lake Tapps, WA
Posts: 69
rmstucky is on a distinguished road
rmstucky rmstucky is offline
Member
 
Join Date: Aug 2010
Location: Lake Tapps, WA
Posts: 69
rmstucky is on a distinguished road
I had this same issue (eventually with an intermittent shift interlock over time, couldn't' shift out of park) although no CEL and no codes! Ended up being the Brake Light Switch...

brake stop lamp switch
rmstucky is offline   Reply With QuoteReply With Quote
Old 01-29-2019, 12:32 PM #9
wc11's Avatar
wc11 wc11 is offline
Member
 
Join Date: Jul 2013
Location: Ontario, Canada
Posts: 642
wc11 will become famous soon enough
wc11 wc11 is offline
Member
wc11's Avatar
 
Join Date: Jul 2013
Location: Ontario, Canada
Posts: 642
wc11 will become famous soon enough
Brake light switch
wc11 is offline   Reply With QuoteReply With Quote
Old 01-30-2019, 06:41 PM #10
john123drury john123drury is offline
Member
 
Join Date: Jul 2014
Location: PA
Posts: 58
john123drury is on a distinguished road
john123drury john123drury is offline
Member
 
Join Date: Jul 2014
Location: PA
Posts: 58
john123drury is on a distinguished road
Thanks. As mentioned in the OP, I have already replaced the brake light switch. I don't have any codes coming up. I will try the gas cap fix and will report back in time with a result. Much appreciated everyone
john123drury is offline   Reply With QuoteReply With Quote
Old 01-30-2019, 07:14 PM #11
ScooterMD's Avatar
ScooterMD ScooterMD is offline
Member
 
Join Date: Dec 2016
Location: Arizona
Posts: 92
ScooterMD is on a distinguished road
ScooterMD ScooterMD is offline
Member
ScooterMD's Avatar
 
Join Date: Dec 2016
Location: Arizona
Posts: 92
ScooterMD is on a distinguished road
Quote:
Originally Posted by john123drury View Post
Thanks. As mentioned in the OP, I have already replaced the brake light switch. I don't have any codes coming up. I will try the gas cap fix and will report back in time with a result. Much appreciated everyone
Sugggest buying an OEM cap online, and in the meantime before it arrives, try tightening your current gas cap really well and making sure there is no gunk on its threads.
__________________
07 Sport V6
ScooterMD is offline   Reply With QuoteReply With Quote
Old 01-31-2019, 01:08 AM #12
hgill's Avatar
hgill hgill is offline
Member
 
Join Date: Feb 2010
Location: Bakersfield, CA
Posts: 415
hgill will become famous soon enough
hgill hgill is offline
Member
hgill's Avatar
 
Join Date: Feb 2010
Location: Bakersfield, CA
Posts: 415
hgill will become famous soon enough
I recall having a similar issues a few years back because of my gas cap. Went and bought oem from the dealership if i recall. Hopes its as simple as the gas cap OP. Best of luck.
hgill is offline   Reply With QuoteReply With Quote
Old 02-12-2019, 12:10 PM #13
john123drury john123drury is offline
Member
 
Join Date: Jul 2014
Location: PA
Posts: 58
john123drury is on a distinguished road
john123drury john123drury is offline
Member
 
Join Date: Jul 2014
Location: PA
Posts: 58
john123drury is on a distinguished road
UPDATE - gas cap did NOT fix the issue. Same day as installing a new Toyota cap, the lights on the dash came on. Again the problem remains sporadic. Some days there are no lights, and other days they stay on. The issue seems to be more prominent on cold starts (e.g. morning after the car was sitting in the garage for a day or 2). Once it's been driving for a bit, if I restart the car, the lights usually (but not always) will go off as they should.

Again - I have already replaced the brake light switch. And there are no codes on the ECM. Anyone have any other suggestions?
john123drury is offline   Reply With QuoteReply With Quote
Old 04-24-2019, 09:36 AM #14
john123drury john123drury is offline
Member
 
Join Date: Jul 2014
Location: PA
Posts: 58
john123drury is on a distinguished road
john123drury john123drury is offline
Member
 
Join Date: Jul 2014
Location: PA
Posts: 58
john123drury is on a distinguished road
UPDATE: still experiencing this same issue. Extremely intermittent. I've gone weeks with no light issues at all. Then all of a sudden on a morning startup, the lights stay on. I can't find anything on the forums where people have experienced similar issues. Does anyone have any suggestions???
john123drury is offline   Reply With QuoteReply With Quote
Old 04-24-2019, 01:16 PM #15
djpope09 djpope09 is offline
Member
 
Join Date: Dec 2017
Location: Washington
Posts: 223
djpope09 will become famous soon enough
djpope09 djpope09 is offline
Member
 
Join Date: Dec 2017
Location: Washington
Posts: 223
djpope09 will become famous soon enough
Quote:
Originally Posted by john123drury View Post
UPDATE: still experiencing this same issue. Extremely intermittent. I've gone weeks with no light issues at all. Then all of a sudden on a morning startup, the lights stay on. I can't find anything on the forums where people have experienced similar issues. Does anyone have any suggestions???
This is going to sound dumb, but do you have your phone charging in the cigarette lighter?

My wife was driving ours recently and had all these lights come on. I drove it for a couple days and couldn't get it to happen. Check for codes and there were none. She's driving it again and it happened again. For her it's the tire slip indicator with beeping and then the beeping stops and the VSC lights come on. She unplugged her phone and it stopped doing it. Plugged her phone back in and it started up again.

I don't know if it's the charger or her phone or if either is really the issue, but it only happens when she's charging her phone. I'm going to be testing out another charger when I get a chance to see if I can narrow it down.

Last edited by djpope09; 04-24-2019 at 01:18 PM. Reason: Edited to add that I didn't have any OBD faults
djpope09 is offline   Reply With QuoteReply With Quote
Reply

Tags
car , dash , fine , lights , start

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dash Warning Lights?Alarm Sound? Hi-Tek RedNek 3rd gen T4Rs 17 07-23-2018 09:23 PM
VSC not engaging, no warning lights on dash Majindan 3rd gen T4Rs 0 06-24-2018 05:45 AM
Dash Warning Lights On <<<< 4th Gen T4Rs 10 04-03-2016 02:10 PM
Dash warning lights staying on? Ill Classic T4Rs 8 02-04-2014 08:16 PM
Dash warning lights lit for apparently no reason... UoD Problems & Warranty Issues 2 02-13-2006 09:00 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 04:49 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2020