User Tag List
benny_js

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-11-2021, 10:06 PM #1
benny_js benny_js is offline
Junior Member
 
Join Date: Jan 2021
Location: San Diego
Posts: 10
benny_js is on a distinguished road
benny_js benny_js is offline
Junior Member
 
Join Date: Jan 2021
Location: San Diego
Posts: 10
benny_js is on a distinguished road
HELP! 4wd not working (p2772)

Hello pals,
While off roading a couple weekends ago, I engaged 4 low and when I was ready to move to high, the beeping of unsuccessful disengage happened (also my cluster was replace by the previous owner for a non4wd so the beeping and obvious driving conditions are the only way for me to tell when my 4 is engaged). I tried all of the possible combinations to disengage it but nothin. Long story short, I got towed home and when trying to fix it, my check engine light came on and it gave me P2772 code, and the engine started shaking. Also, I got towed back home and when loading in on the truck, it did not seem to be engaged in 4wd at all.

Finally at home (I still got towed home) I tested it again and yes, my 4wd was not engaged but when I would move the switch out of 4lo it will beep. What I did was check the 4wd actuator: I noticed there was a hose unplugged, probably a vacuum line, so I put it back in place. Then I opened the actuator and removed it, the servomotor that moves the rod for 4hi/lo was tested and it was running. I assembled it back together, and went for a test drive. My 4wd was not engaged, the shaking stopped and I was finally able to move the switch to 2wd without the beeping. I cleared the check engine code and after about 800 miles I have not had an issue nor the light has came back on.

I finally made some money to start fixing it. Now, I got bilsteins all around about 5 months ago and my mechanic told me one cv axle was leaking. He said I did not need to replace it right away but that he recommended to do it if I was planning on off roading. Before having the disengagement issue, I did not use my 4wd at all, and about two weeks before it, I noticed the leaking had stopped.

So my question is, should I start by replacing the cv axles? Or could it be the actuator? Also I hope it is not the whole trasnfer case and if so how can I tell?

I have not done any testing anymore since it is my daily (to my 5 mile job) and so it is fine with only 2wd at the moment. Thanks for the help
benny_js is offline   Reply With QuoteReply With Quote
Reply

Tags
4wd , back , engaged , home , towed

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 4Runner V6 4x4 stuck in 4hi. But saying 4lo. P2772 pahaf91 4th Gen T4Rs 2 08-11-2019 01:21 AM
2003 4Runner SR5 V6 - Auto-door lock, not working for a year, now magically working! Cookster Problems & Warranty Issues 1 08-09-2019 05:39 PM
Turn signal not working? Std trouble shooting isn't working swapmeet 4th Gen T4Rs 9 09-14-2014 11:21 PM
95 rear window not working, motor can be heard working DLPDLP Classic T4Rs 22 01-29-2012 08:17 AM
2001 remote not working, rear wiper/defog not working theedudenator 3rd gen T4Rs 1 02-06-2011 01:10 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 01:47 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2020