User Tag List

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-14-2023, 09:50 PM #1
cice cice is offline
Member
 
Join Date: Jan 2012
Posts: 61
cice is on a distinguished road
cice cice is offline
Member
 
Join Date: Jan 2012
Posts: 61
cice is on a distinguished road
V8 Just Died at a Stoplight...

Hi folks,
I have a 2007 V8 with 238k miles. It still runs like new... except today, while sitting in traffic at a stoplight I looked down and the engine had just stopped. The CEL, battery, and oil lights were all on. I put it in park, turned the key and it fired right back up. No CEL and no pending codes. I've driven it around tonight and it hasn't had any issues. No hesitation, sputtering, or randomly shutting off. Just rock solid like usual. I filled up the tank and added a can of Sea Foam. Any other ideas on what could have caused the random engine stop?

Thanks!
cice is offline   Reply With QuoteReply With Quote
Old 11-14-2023, 10:31 PM #2
rdruss's Avatar
rdruss rdruss is offline
Senior Member
 
Join Date: Oct 2013
Location: illinois
Posts: 1,570
Real Name: Ron
rdruss is a splendid one to behold rdruss is a splendid one to behold rdruss is a splendid one to behold rdruss is a splendid one to behold rdruss is a splendid one to behold rdruss is a splendid one to behold rdruss is a splendid one to behold
rdruss rdruss is offline
Senior Member
rdruss's Avatar
 
Join Date: Oct 2013
Location: illinois
Posts: 1,570
Real Name: Ron
rdruss is a splendid one to behold rdruss is a splendid one to behold rdruss is a splendid one to behold rdruss is a splendid one to behold rdruss is a splendid one to behold rdruss is a splendid one to behold rdruss is a splendid one to behold
No solid ideas, but when last do plugs, timing belt, battery? Check your battery terminals for one being loose.
__________________
2003 Limited, V8, AWD. 4600 Bils/FJ springs, 1/2" spacer, SPC UCA, Super Pro bushings in front LCA and in all rear control arms, Michelin 265/65R17 LTX/Defenders, stock wheels with homemade center caps, Stop Tech slotted rotors w/Posi Quiet pads all around.
rdruss is offline   Reply With QuoteReply With Quote
Old 11-14-2023, 10:33 PM #3
cice cice is offline
Member
 
Join Date: Jan 2012
Posts: 61
cice is on a distinguished road
cice cice is offline
Member
 
Join Date: Jan 2012
Posts: 61
cice is on a distinguished road
Excellent suggestions, thank you! Plugs are due at 240k (already have them in the garage). Battery terminals are solid and connected well (had that happen before where they were loose) Timing belt was done about 30k miles ago. Battery is 2-3 years old.. but the engine cranks really hard so I think the battery is fine...
cice is offline   Reply With QuoteReply With Quote
Old 11-14-2023, 10:34 PM #4
cice cice is offline
Member
 
Join Date: Jan 2012
Posts: 61
cice is on a distinguished road
cice cice is offline
Member
 
Join Date: Jan 2012
Posts: 61
cice is on a distinguished road
It seems... and now I'm biased... to idle lower than it used to. It ideas around 500 - 480 RPM when the A/C compressor isn't running. Could that be the issue? The RPMs dropped too low and the ECU shut off the engine?
cice is offline   Reply With QuoteReply With Quote
Old 11-14-2023, 10:34 PM #5
MrSeth's Avatar
MrSeth MrSeth is offline
Member
 
Join Date: Feb 2015
Location: Texas
Posts: 443
Real Name: Seth
MrSeth is a jewel in the rough MrSeth is a jewel in the rough MrSeth is a jewel in the rough MrSeth is a jewel in the rough
MrSeth MrSeth is offline
Member
MrSeth's Avatar
 
Join Date: Feb 2015
Location: Texas
Posts: 443
Real Name: Seth
MrSeth is a jewel in the rough MrSeth is a jewel in the rough MrSeth is a jewel in the rough MrSeth is a jewel in the rough
Quote:
Originally Posted by rdruss View Post
No solid ideas, but when last do plugs, timing belt, battery? Check your battery terminals for one being loose.
I am going to second that you check your serpentine belt AND battery terminals. Sometimes they can wiggle off or just be loose enough to kill it.
__________________
2006 Shadow Mica SR5 v6
1" BL, Fox Racing UCA's, RC 3" N3 Lift, Rock Trix RT110 -12 Wheels, 315/70R17 Goodyear Territory MT, Tacoma Front Bumper, 5th Gen 4R Tire Carrier, Big Lion LED's

Last edited by MrSeth; 11-14-2023 at 10:37 PM. Reason: put timing instead of serpentine
MrSeth is offline   Reply With QuoteReply With Quote
Old 11-14-2023, 10:35 PM #6
cice cice is offline
Member
 
Join Date: Jan 2012
Posts: 61
cice is on a distinguished road
cice cice is offline
Member
 
Join Date: Jan 2012
Posts: 61
cice is on a distinguished road
What do you mean by check the timing belt? It is buried in the engine... Do you mean the serpentine belt?
cice is offline   Reply With QuoteReply With Quote
Old 11-14-2023, 10:37 PM #7
MrSeth's Avatar
MrSeth MrSeth is offline
Member
 
Join Date: Feb 2015
Location: Texas
Posts: 443
Real Name: Seth
MrSeth is a jewel in the rough MrSeth is a jewel in the rough MrSeth is a jewel in the rough MrSeth is a jewel in the rough
MrSeth MrSeth is offline
Member
MrSeth's Avatar
 
Join Date: Feb 2015
Location: Texas
Posts: 443
Real Name: Seth
MrSeth is a jewel in the rough MrSeth is a jewel in the rough MrSeth is a jewel in the rough MrSeth is a jewel in the rough
Quote:
Originally Posted by cice View Post
It seems... and now I'm biased... to idle lower than it used to. It ideas around 500 - 480 RPM when the A/C compressor isn't running. Could that be the issue? The RPMs dropped too low and the ECU shut off the engine?
FSM states 650 to 750 rpm at idle is normal (for reference)

I once had a DIRTY air filter on my V8 and it low idled too. Lost power on acceleration, sputtered etc.. I wonder if its that?
__________________
2006 Shadow Mica SR5 v6
1" BL, Fox Racing UCA's, RC 3" N3 Lift, Rock Trix RT110 -12 Wheels, 315/70R17 Goodyear Territory MT, Tacoma Front Bumper, 5th Gen 4R Tire Carrier, Big Lion LED's
MrSeth is offline   Reply With QuoteReply With Quote
Old 11-14-2023, 10:38 PM #8
MrSeth's Avatar
MrSeth MrSeth is offline
Member
 
Join Date: Feb 2015
Location: Texas
Posts: 443
Real Name: Seth
MrSeth is a jewel in the rough MrSeth is a jewel in the rough MrSeth is a jewel in the rough MrSeth is a jewel in the rough
MrSeth MrSeth is offline
Member
MrSeth's Avatar
 
Join Date: Feb 2015
Location: Texas
Posts: 443
Real Name: Seth
MrSeth is a jewel in the rough MrSeth is a jewel in the rough MrSeth is a jewel in the rough MrSeth is a jewel in the rough
Quote:
Originally Posted by cice View Post
What do you mean by check the timing belt? It is buried in the engine... Do you mean the serpentine belt?
sorry friend, yes, serpentine belt. If they are hard and worn, they can slip a lot leading to your alternator not charging your battery or powering your vehicle as well as it could be.
__________________
2006 Shadow Mica SR5 v6
1" BL, Fox Racing UCA's, RC 3" N3 Lift, Rock Trix RT110 -12 Wheels, 315/70R17 Goodyear Territory MT, Tacoma Front Bumper, 5th Gen 4R Tire Carrier, Big Lion LED's
MrSeth is offline   Reply With QuoteReply With Quote
Old 11-14-2023, 10:45 PM #9
rdruss's Avatar
rdruss rdruss is offline
Senior Member
 
Join Date: Oct 2013
Location: illinois
Posts: 1,570
Real Name: Ron
rdruss is a splendid one to behold rdruss is a splendid one to behold rdruss is a splendid one to behold rdruss is a splendid one to behold rdruss is a splendid one to behold rdruss is a splendid one to behold rdruss is a splendid one to behold
rdruss rdruss is offline
Senior Member
rdruss's Avatar
 
Join Date: Oct 2013
Location: illinois
Posts: 1,570
Real Name: Ron
rdruss is a splendid one to behold rdruss is a splendid one to behold rdruss is a splendid one to behold rdruss is a splendid one to behold rdruss is a splendid one to behold rdruss is a splendid one to behold rdruss is a splendid one to behold
Ever cleaned your mass air sensor and throttle body?
__________________
2003 Limited, V8, AWD. 4600 Bils/FJ springs, 1/2" spacer, SPC UCA, Super Pro bushings in front LCA and in all rear control arms, Michelin 265/65R17 LTX/Defenders, stock wheels with homemade center caps, Stop Tech slotted rotors w/Posi Quiet pads all around.
rdruss is offline   Reply With QuoteReply With Quote
Old 11-14-2023, 11:08 PM #10
cice cice is offline
Member
 
Join Date: Jan 2012
Posts: 61
cice is on a distinguished road
cice cice is offline
Member
 
Join Date: Jan 2012
Posts: 61
cice is on a distinguished road
Thanks guys, changed the air filter two weeks ago and also cleaned the MAF. Serpentine belt is a good idea though, and the A/C was cycling so maybe it slipped...
cice is offline   Reply With QuoteReply With Quote
Old 11-15-2023, 11:41 AM #11
Zero0575's Avatar
Zero0575 Zero0575 is offline
Member
 
Join Date: Jun 2019
Location: Indianapolis, IN
Age: 35
Posts: 153
Real Name: Casey
Zero0575 will become famous soon enough Zero0575 will become famous soon enough
Zero0575 Zero0575 is offline
Member
Zero0575's Avatar
 
Join Date: Jun 2019
Location: Indianapolis, IN
Age: 35
Posts: 153
Real Name: Casey
Zero0575 will become famous soon enough Zero0575 will become famous soon enough
Any chance you have a secondary air pump bypass kit? I had the same issue, eventually giving me rich codes after dying a couple times. Ended up being my secondary air pump bypass went bad. Lifetime warranty replaced for free, and no issues since replacing.
__________________
2007 Limited V8 | 275/70/18 Falken Wildpeak AT3W | Spidertrax | 4xInnovations Weld On Sliders | Victory 4x4 Blitz Front Bumper | TNF Rear Bumper | Smittybuilt Winch | KOYORAD Aluminum Radiator |OME 886 Front/Toytec Superflex Rear and OME Shocks/Struts | JBA High Caster UCA | Rebuilt LCA with Superpro bushings + Moog BJ | HCF Delete | Doug Thorley Shorty Headers | Magnaflow HFC | Gibson Catback | Rear Diff Breather Extension | 20" Spot/Flood | 9" Spots | DD SS3 Yellow Fogs | Amber Grill Lights | Fog Lights Anytime Mod
Zero0575 is offline   Reply With QuoteReply With Quote
Old 12-04-2023, 11:52 AM #12
cice cice is offline
Member
 
Join Date: Jan 2012
Posts: 61
cice is on a distinguished road
cice cice is offline
Member
 
Join Date: Jan 2012
Posts: 61
cice is on a distinguished road
It did it again today. What bypass kit did you have installed? The slyfox one?
cice is offline   Reply With QuoteReply With Quote
Old 12-11-2023, 01:56 PM #13
gaber6 gaber6 is offline
Member
 
Join Date: Aug 2017
Location: Ohio
Posts: 580
gaber6 has a spectacular aura about gaber6 has a spectacular aura about
gaber6 gaber6 is offline
Member
 
Join Date: Aug 2017
Location: Ohio
Posts: 580
gaber6 has a spectacular aura about gaber6 has a spectacular aura about
Maybe a small vacuum leak?
Perhaps a dying battery also. I had many electronic gremlins when my battery was going.
gaber6 is offline   Reply With QuoteReply With Quote
Old 12-11-2023, 04:25 PM #14
xtremewlr's Avatar
xtremewlr xtremewlr is offline
Member
 
Join Date: Nov 2019
Location: Tucson, AZ
Posts: 815
Real Name: Todd
xtremewlr is a splendid one to behold xtremewlr is a splendid one to behold xtremewlr is a splendid one to behold xtremewlr is a splendid one to behold xtremewlr is a splendid one to behold xtremewlr is a splendid one to behold xtremewlr is a splendid one to behold
xtremewlr xtremewlr is offline
Member
xtremewlr's Avatar
 
Join Date: Nov 2019
Location: Tucson, AZ
Posts: 815
Real Name: Todd
xtremewlr is a splendid one to behold xtremewlr is a splendid one to behold xtremewlr is a splendid one to behold xtremewlr is a splendid one to behold xtremewlr is a splendid one to behold xtremewlr is a splendid one to behold xtremewlr is a splendid one to behold
Quote:
Originally Posted by cice View Post
It did it again today. What bypass kit did you have installed? The slyfox one?
Clean the throttle body as rdruss suggested.

Change the spark plugs that you said you have sitting in the garage.

Disconnect the battery for about 30 minutes, while you clean the TB and change the plugs to reset the ECU.

I'd also take the battery into an Autozone and have it checked. Even though it cranks fine, it might be end of life at 3 years old and causing weird things to happen.
__________________
2003 4Runner Limited 4wd V8 - Build thread on Tacoma World
FJ tcase swap, VVT intake swap, Solid Offroad motor mounts, Doug Thorley y-pipe, Bold Performance cat-back, ADS shocks F&R, Metal Tech LTHD springs rear, 1" body lift, 285/75/17 Toyo R/T Trails on Sequoia rims, Coastal front bumper, CAD rear bumper
xtremewlr is offline   Reply With QuoteReply With Quote
Old 12-11-2023, 09:20 PM #15
Zero0575's Avatar
Zero0575 Zero0575 is offline
Member
 
Join Date: Jun 2019
Location: Indianapolis, IN
Age: 35
Posts: 153
Real Name: Casey
Zero0575 will become famous soon enough Zero0575 will become famous soon enough
Zero0575 Zero0575 is offline
Member
Zero0575's Avatar
 
Join Date: Jun 2019
Location: Indianapolis, IN
Age: 35
Posts: 153
Real Name: Casey
Zero0575 will become famous soon enough Zero0575 will become famous soon enough
Quote:
Originally Posted by cice View Post
It did it again today. What bypass kit did you have installed? The slyfox one?
Hewitt.
__________________
2007 Limited V8 | 275/70/18 Falken Wildpeak AT3W | Spidertrax | 4xInnovations Weld On Sliders | Victory 4x4 Blitz Front Bumper | TNF Rear Bumper | Smittybuilt Winch | KOYORAD Aluminum Radiator |OME 886 Front/Toytec Superflex Rear and OME Shocks/Struts | JBA High Caster UCA | Rebuilt LCA with Superpro bushings + Moog BJ | HCF Delete | Doug Thorley Shorty Headers | Magnaflow HFC | Gibson Catback | Rear Diff Breather Extension | 20" Spot/Flood | 9" Spots | DD SS3 Yellow Fogs | Amber Grill Lights | Fog Lights Anytime Mod
Zero0575 is offline   Reply With QuoteReply With Quote
Reply

Tags
cel , engine , hesitation , stoplight , tonight

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
94 3.0 died fastgtfairlane Classic T4Rs 16 08-16-2017 10:56 AM
Need help! 4Runner died HustleHard 4th Gen T4Rs 13 02-03-2017 09:42 PM
3rd gen died today strat10 3rd gen T4Rs 18 07-29-2016 10:55 PM
3rd gen almost died t4r4life 3rd gen T4Rs 45 05-06-2011 07:41 AM
'05 Ltd, GPS just died. briandunning Problems & Warranty Issues 10 10-22-2006 06:40 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 10:00 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2024 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2024 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2024 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2020