User Tag List

Reply
 
Thread Tools Rate Thread Display Modes
Old 02-04-2019, 11:28 PM #1
370HSSSV 370HSSSV is offline
Junior Member
 
Join Date: Jul 2015
Location: Rancho Cucamonga CA
Posts: 20
370HSSSV is on a distinguished road
370HSSSV 370HSSSV is offline
Junior Member
 
Join Date: Jul 2015
Location: Rancho Cucamonga CA
Posts: 20
370HSSSV is on a distinguished road
Door lock keeps locking.

I used the search function, but nothing for 5th gen, and not a clear answer yet.

2015 4Runner
So today, my door lock keeps acting up, when I pressed unlock button either on key fob or the button on driver side door, the door will just lock itself up right after I press unlock.
And there is also a period of time, both engine and key are off, the door lock is just repeatedly doing lock/unlock process non stop...
It only happens when the car is parked so far.
And all the door locks while I turn the key from ON to Start, it supposed to be while I shift out of Park right?
I checked the fuse box, it's completely dry (because it's raining hard last couple days here)
The only after market I have that are electrical related is a switch pro 8100 and a BD light bar, I had them on for more than a year already.

I read previously it could be the battery in the car is old about to go, is that why?
Any idea on what and where to check and what's going on?
Thanks for your time, I really appreciate your responses. Trying to catch the moment between unlock/lock to open the door was not fun...
370HSSSV is offline   Reply With QuoteReply With Quote
Old 02-05-2019, 08:00 AM #2
Cndnmax Cndnmax is offline
Member
 
Join Date: Apr 2018
Location: Sacramento, California
Posts: 297
Cndnmax will become famous soon enough
Cndnmax Cndnmax is offline
Member
 
Join Date: Apr 2018
Location: Sacramento, California
Posts: 297
Cndnmax will become famous soon enough
Low battery voltage does tend to make for some crazy electrical gremlins. You can test the battery with a multimeter. I would try just disconnecting the battery for 15or so min then reconnecting it. Or Maybe there’s water in the door lock button.

Last edited by Cndnmax; 02-05-2019 at 08:22 AM.
Cndnmax is offline   Reply With QuoteReply With Quote
Old 02-05-2019, 01:42 PM #3
TrkyMfns's Avatar
TrkyMfns TrkyMfns is offline
Member
 
Join Date: Sep 2015
Location: Florida
Posts: 188
TrkyMfns is on a distinguished road
TrkyMfns TrkyMfns is offline
Member
TrkyMfns's Avatar
 
Join Date: Sep 2015
Location: Florida
Posts: 188
TrkyMfns is on a distinguished road
The two places I would start with would be checking that your battery terminals are securely connected and check the battery in your keyfob.
__________________
2011 SR5/P 4WD Blizzard Pearl - 265/70/17 BFG K02 C - Bilstein 5100 Lift @ 2.5 - SPC UCA's - Two Tone Katzkin Interior - 15% Ceramic Tint - Canvasback Liner - Husky Weatherbeater Liners - Phillips LED's - Completely upgraded ICE.
TrkyMfns is offline   Reply With QuoteReply With Quote
Old 02-05-2019, 01:58 PM #4
lukeskywalker's Avatar
lukeskywalker lukeskywalker is offline
Member
 
Join Date: Mar 2016
Location: CO
Posts: 243
lukeskywalker is on a distinguished road
MY GARAGE
lukeskywalker lukeskywalker is offline
Member
lukeskywalker's Avatar
 
Join Date: Mar 2016
Location: CO
Posts: 243
lukeskywalker is on a distinguished road
MY GARAGE
Have you ensured your wife's location and that she's not f$%$ing with you?
__________________
TRD PRO Trim - Bilstein 5100x4 @1.75 - Rear 1.5 Daystar Spacer - F(x) Pro Black Wheels - TRD Skid Plate - General Grabber AT2 @ 265/70R17 - Tail as Turn Rear Lights Mod - HID Low Beam Replacement - BAJA Rack - Flat Utility Mesh w/Sunroof - Sunroof - Fold Flat Cargo Platform - Raingler Cargo Ceiling Net
lukeskywalker is offline   Reply With QuoteReply With Quote
Old 02-05-2019, 02:08 PM #5
97BlackAckCL's Avatar
97BlackAckCL 97BlackAckCL is offline
Senior Member
 
Join Date: Mar 2010
Location: Pittsburgh
Posts: 4,770
Real Name: Chris
97BlackAckCL is a splendid one to behold 97BlackAckCL is a splendid one to behold 97BlackAckCL is a splendid one to behold 97BlackAckCL is a splendid one to behold 97BlackAckCL is a splendid one to behold 97BlackAckCL is a splendid one to behold 97BlackAckCL is a splendid one to behold
MY GARAGE
97BlackAckCL 97BlackAckCL is offline
Senior Member
97BlackAckCL's Avatar
 
Join Date: Mar 2010
Location: Pittsburgh
Posts: 4,770
Real Name: Chris
97BlackAckCL is a splendid one to behold 97BlackAckCL is a splendid one to behold 97BlackAckCL is a splendid one to behold 97BlackAckCL is a splendid one to behold 97BlackAckCL is a splendid one to behold 97BlackAckCL is a splendid one to behold 97BlackAckCL is a splendid one to behold
MY GARAGE
This will happen when the truck thinks that a door is open, check the console to see if it indicates a door is open when it's actually closed. Also check that the rear hatch is latched all the way
__________________
2017 Nautical Blue SR5 Premium - Black Emblem Overlays, AFE TB Spacer, AFE Momentum GT Intake, URD MAF Calibrator, Borla Touring Cat-Back, Morimoto MLED 2.0 Headlight Retrofit, Morimoto Black LED Fogs, FyreFlys LED Interior, Meso Puddle Lights, Tinted CarTrim Miror Turn Signals, Smoked Amber LED Raptor Lights, Odyssey 34 Battery, 32" LED Bar with Rago Hidden Brackets, Rago Molle Panels, Side Shooter LED Ditch Lights, sPod w/ PowerTray, Raceline Matte Bronze Wheels w/ Cooper Discoverer RTX, N-Fab Side Steps, BajaRack Full Length Roof Rack, 6xMB Quart Door Speakers, JBL 3.5's in dash, JL 8w3v3 in JBL Enclosure, Husky Weather Beaters, CanvasBack Liners, ScanGauge, Blackvue DR900S Dash Cams
97BlackAckCL is offline   Reply With QuoteReply With Quote
Old 02-05-2019, 10:53 PM #6
370HSSSV 370HSSSV is offline
Junior Member
 
Join Date: Jul 2015
Location: Rancho Cucamonga CA
Posts: 20
370HSSSV is on a distinguished road
370HSSSV 370HSSSV is offline
Junior Member
 
Join Date: Jul 2015
Location: Rancho Cucamonga CA
Posts: 20
370HSSSV is on a distinguished road
Quick update

@TrkyMfns I checked the battery terminal, they are secure and tight, the battery in the key fob is fine as well.

@lukeskywalker hahahaha, I am pretty sure that's not the case.

@97BlackAckCL I checked this as well, it's all good.


Now I think it's the battery like @Cndnmax said. In the morning.door locks didn't act up, everything works just fine as normal. while I was driving home, the switch pro stopped working completely. I made a quick stop on the way home, I made a quick stop, it started to act up again, all door locked while I turn the key from ON to START, I got home, parked the car, turned off the engine, and it started to lock itself up while I press unlock.....

Besides switch pro stopped working, the USB port to change my phone is really slow too, I have it plugged in, the battery on the phone is still going down.
I will get a voltmeter to test the battery in the car tomorrow.

Last edited by 370HSSSV; 02-05-2019 at 11:53 PM.
370HSSSV is offline   Reply With QuoteReply With Quote
Old 02-06-2019, 02:39 AM #7
rigtec's Avatar
rigtec rigtec is offline
Senior Member
 
Join Date: May 2012
Location: Bergenfield NJ.
Posts: 2,466
Real Name: Greg
rigtec has a spectacular aura about rigtec has a spectacular aura about
rigtec rigtec is offline
Senior Member
rigtec's Avatar
 
Join Date: May 2012
Location: Bergenfield NJ.
Posts: 2,466
Real Name: Greg
rigtec has a spectacular aura about rigtec has a spectacular aura about
Quote:
Originally Posted by 370HSSSV View Post
I used the search function, but nothing for 5th gen, and not a clear answer yet.

2015 4Runner
So today, my door lock keeps acting up, when I pressed unlock button either on key fob or the button on driver side door, the door will just lock itself up right after I press unlock.
And there is also a period of time, both engine and key are off, the door lock is just repeatedly doing lock/unlock process non stop...
It only happens when the car is parked so far.
And all the door locks while I turn the key from ON to Start, it supposed to be while I shift out of Park right?
I checked the fuse box, it's completely dry (because it's raining hard last couple days here)
The only after market I have that are electrical related is a switch pro 8100 and a BD light bar, I had them on for more than a year already.

I read previously it could be the battery in the car is old about to go, is that why?
Any idea on what and where to check and what's going on?
Thanks for your time, I really appreciate your responses. Trying to catch the moment between unlock/lock to open the door was not fun...
Hi @370HSSSV ,

Before you go crazy trying to trouble-shoot this gremlin, Disconnect the NEG Battery cable! This is done when the vehicle needs a 'Main body ECU Compu network' MASTER RESET! The ECU (Electronic Control Unit) is a computer, much like a windows laptop (and does have a 'Registry/file system').

But they do store quite a bit of Temporary files, History logs, and Learned data...etc, that does need to be deleted from time to time or the truck will experience malfunctions in different areas, e.g., lighting, security system, instrument cluster (unrelated) icons lighting up together for no logical reason (Check Engine, GEN, Seat-Belts, 4-Low, Steering...etc)!

So, disconnect the battery for a minimum of four hrs; I do mine (if I need to) when I'm done using the truck for the evening, and reconnect in the morning. NOTE: When you try to restart the truck, it will run for 3 seconds and shut-down... don't be alarmed, this is protocol! The next time you restart, everything should be back to normal, including the trouble with the locks!

Be sure to let us know how you make out... don't worry, you'll be fine "AFTER the master reset!" 'Best to you',

rig
__________________
2012 Limited (in bliz) Black leather interior.

Commercial hvac diagnostics/electrical specialist (Steamfitters Journeyman Local 475)

Last edited by rigtec; 02-06-2019 at 01:53 PM.
rigtec is offline   Reply With QuoteReply With Quote
Old 02-06-2019, 11:51 PM #8
370HSSSV 370HSSSV is offline
Junior Member
 
Join Date: Jul 2015
Location: Rancho Cucamonga CA
Posts: 20
370HSSSV is on a distinguished road
370HSSSV 370HSSSV is offline
Junior Member
 
Join Date: Jul 2015
Location: Rancho Cucamonga CA
Posts: 20
370HSSSV is on a distinguished road
Hey @rigtec , thank you for your response!

I did the master reset today. I disconnected the negative terminal on the car battery around 10:30 AM and reconnected them 7:30 PM.

But while I started the truck after connect the battery back on, it didn't shut off after three seconds like you said, is that normal as well?

Thanks again for your time!

Last edited by 370HSSSV; 02-06-2019 at 11:54 PM.
370HSSSV is offline   Reply With QuoteReply With Quote
Old 02-07-2019, 02:00 AM #9
rigtec's Avatar
rigtec rigtec is offline
Senior Member
 
Join Date: May 2012
Location: Bergenfield NJ.
Posts: 2,466
Real Name: Greg
rigtec has a spectacular aura about rigtec has a spectacular aura about
rigtec rigtec is offline
Senior Member
rigtec's Avatar
 
Join Date: May 2012
Location: Bergenfield NJ.
Posts: 2,466
Real Name: Greg
rigtec has a spectacular aura about rigtec has a spectacular aura about
Quote:
Originally Posted by 370HSSSV View Post
Hey @rigtec , thank you for your response!

I did the master reset today. I disconnected the negative terminal on the car battery around 10:30 AM and reconnected them 7:30 PM.

But while I started the truck after connect the battery back on, it didn't shut off after three seconds like you said, is that normal as well?

Thanks again for your time!
Hi 370HSSSV,

NO! That's actually an indication that the master RESET may not have been performed! There's a "Registry" in the main body ECU that has the responsibility of the file organisation and it may still be incomplete. If possible, try it again (I've never seen a 4Runner not stall after a 'MASTER RESET')!

It's in the manual where it mentions battery replacement or disconnection for extended periods of time... not sure what page (mine's a 2012 Limited), but they wanted the owners not to worry when that happens. The other thing that you should notice is the compass should show a Blinking dot next to the direction symbol. You should have ALSO lost all of your radio preset stations; sorry, I should have mentioned that when I advised you the disconnect the battery!

Check and see if there is a blinking dot on the leftside of the direction symbol e.g., N.E.. And you should NOT have any radio preset radio stations where you left them, if you do, you'll have to do it again; not a big deal, just do EXACTLY as you did it today and it will have no choice but to work! I'm still not sure just why it didn't stall when restarted(?). But you'll know more when you check the radio and the compass, Please let us know!

rig, cheers!
__________________
2012 Limited (in bliz) Black leather interior.

Commercial hvac diagnostics/electrical specialist (Steamfitters Journeyman Local 475)

Last edited by rigtec; 02-07-2019 at 02:04 AM.
rigtec is offline   Reply With QuoteReply With Quote
Old 02-08-2019, 12:51 AM #10
370HSSSV 370HSSSV is offline
Junior Member
 
Join Date: Jul 2015
Location: Rancho Cucamonga CA
Posts: 20
370HSSSV is on a distinguished road
370HSSSV 370HSSSV is offline
Junior Member
 
Join Date: Jul 2015
Location: Rancho Cucamonga CA
Posts: 20
370HSSSV is on a distinguished road
hey @rigtec

I did the reset again today 10:30AM to 7:30PM. Disconnected the negative terminal on the car battery. it's really weird that it's not resetting....
I was checking for the dot on compass, radio station, and stall after a few seconds engine started.
None of it happened. I didn't drive it either today or yesterday.
Where did I do wrong?

Now I press lock on the driver side door, it automatically unlocks itself right away, the opposite of what it did before.
Thanks for your time!
370HSSSV is offline   Reply With QuoteReply With Quote
Old 02-08-2019, 04:44 AM #11
rigtec's Avatar
rigtec rigtec is offline
Senior Member
 
Join Date: May 2012
Location: Bergenfield NJ.
Posts: 2,466
Real Name: Greg
rigtec has a spectacular aura about rigtec has a spectacular aura about
rigtec rigtec is offline
Senior Member
rigtec's Avatar
 
Join Date: May 2012
Location: Bergenfield NJ.
Posts: 2,466
Real Name: Greg
rigtec has a spectacular aura about rigtec has a spectacular aura about
Quote:
Originally Posted by 370HSSSV View Post
hey @rigtec

I did the reset again today 10:30AM to 7:30PM. Disconnected the negative terminal on the car battery. it's really weird that it's not resetting....
I was checking for the dot on compass, radio station, and stall after a few seconds engine started.
None of it happened. I didn't drive it either today or yesterday.
Where did I do wrong?

Now I press lock on the driver side door, it automatically unlocks itself right away, the opposite of what it did before.
Thanks for your time!
Okay @370HSSSV ,

Are you saying that the door locks are working as they should now, or are the locks are still screwed up? IF they're still screwed up, you can just remove the 'short-pin' from the main fusebox; you can locate it on the fusebox cover under the hood; looks just like a fuse but WILL NOT fit a fuse slot!

What that's for is, it de-energizes the Main body ECU Compu Network as well as any other ecu's (27 total) that would drain the battery while the 4Runners are being transported from the factory (in Japan) to the dealerships that ordered them in the USA!

You can leave the battery terminals connected this time, but it will still need a minimum of four hours for them to fully RESET! BTW: Did the radio presets get deleted or the compass above the temp controls need to be re-calibrated (determined by the blinking dot 'left-side' of the direction indicator)?

If NOT... are you using a dual battery set-up? I meant to ask you about that last night... which would explain the missing stall-out factor upon restart after a 'MASTER ECU RESET'! Please let us know,

rig, cheers!
__________________
2012 Limited (in bliz) Black leather interior.

Commercial hvac diagnostics/electrical specialist (Steamfitters Journeyman Local 475)
rigtec is offline   Reply With QuoteReply With Quote
Old 02-08-2019, 01:12 PM #12
370HSSSV 370HSSSV is offline
Junior Member
 
Join Date: Jul 2015
Location: Rancho Cucamonga CA
Posts: 20
370HSSSV is on a distinguished road
370HSSSV 370HSSSV is offline
Junior Member
 
Join Date: Jul 2015
Location: Rancho Cucamonga CA
Posts: 20
370HSSSV is on a distinguished road
Hello @rigtec

Sorry I wasn't clear before. before the two resets, While I press unlock, it locks itself right away, yesterday, while I press the lock button, it unlocks it self right away, so I guess it's still screwed up.

After disconnecting the battery yesterday, all my radio station were still there, there are no blinking dot on compass, so I guess it's not resetting the ECU.

I will try to remove the fuse today. Are you saying I need to remove the fuse for more than 4 hours before put it back in?

No I don't have a second battery, but I do have switch pro connected to battery.

Thank yo ufor all your help! I really appreciated it!
370HSSSV is offline   Reply With QuoteReply With Quote
Old 02-08-2019, 02:02 PM #13
ElectroBoy's Avatar
ElectroBoy ElectroBoy is online now
Member
 
Join Date: Nov 2017
Location: San Jose CA
Posts: 712
Real Name: Mark
ElectroBoy is a glorious beacon of light ElectroBoy is a glorious beacon of light ElectroBoy is a glorious beacon of light ElectroBoy is a glorious beacon of light ElectroBoy is a glorious beacon of light
ElectroBoy ElectroBoy is online now
Member
ElectroBoy's Avatar
 
Join Date: Nov 2017
Location: San Jose CA
Posts: 712
Real Name: Mark
ElectroBoy is a glorious beacon of light ElectroBoy is a glorious beacon of light ElectroBoy is a glorious beacon of light ElectroBoy is a glorious beacon of light ElectroBoy is a glorious beacon of light
It’s almost like there’s some electronic device in the truck that has a keep-alive battery that’s preventing a hard power-on reset of the ECU. The Switch Pro doesn’t have that feature, does it? You may consider disconnecting it as part of your troubleshooting.

By the way, did you check the battery with a voltmeter?
__________________
1st Gen 1987 T4R, sold at 180K miles
3rd Gen 2000 SR5, sold at 239K miles
5th Gen 2018 ORP, just interior mods
ElectroBoy is online now   Reply With QuoteReply With Quote
Old 02-08-2019, 06:46 PM #14
rigtec's Avatar
rigtec rigtec is offline
Senior Member
 
Join Date: May 2012
Location: Bergenfield NJ.
Posts: 2,466
Real Name: Greg
rigtec has a spectacular aura about rigtec has a spectacular aura about
rigtec rigtec is offline
Senior Member
rigtec's Avatar
 
Join Date: May 2012
Location: Bergenfield NJ.
Posts: 2,466
Real Name: Greg
rigtec has a spectacular aura about rigtec has a spectacular aura about
Quote:
Originally Posted by 370HSSSV View Post
Hello @rigtec

Sorry I wasn't clear before. before the two resets, While I press unlock, it locks itself right away, yesterday, while I press the lock button, it unlocks it self right away, so I guess it's still screwed up.
Lol! Okay @370HSSSV

There IS some kind of a power source that's maintaining a power supply to the ECU's! I don't know what or where, but I've been doing this kind of thing long enough to know what we're looking at! I would (under any other circumstance) tell you to pull the HOT and GND cables off of the battery and join them together (to discharge the power), but I can't because I don't know if the power source is large enough to do any electrical damage!

For now, (after disconnecting the NEG battery term), just leave ON your High Beams, Heating Blower (HI speed), and the radio... that should drain the (Ghost) power supply enough to do the Main body ECU 'Master RESET!

This is unusual, but remember, I'm not there to determine exactly what the trouble is! So, with these accessories left on, pull the 'Short pin' and the ECU-B 10A fuse OUT! I've provided a diagram to help you locate the ECU 10A fuse and "Short-pin"; see below, "you can enlarge the diagram by clicking the banner on the top of it":



I've marked the above diagram with a high-lighter pen in PINK; ECU-B 10A fuse, the door-locks (on the ECU'S to-do list, and the "Short-pin" location)!

This is the ECU that controls the door locks (see the arrow high lighted in pink)! So even if there is another power source, it won't matter because we're isolating the ECU by pulling the fuse and short pin...follow(?)! Let us know how you make out UNTIL we can put this issue FAR behind us lol!

rig, cheers!
__________________
2012 Limited (in bliz) Black leather interior.

Commercial hvac diagnostics/electrical specialist (Steamfitters Journeyman Local 475)

Last edited by rigtec; 02-17-2019 at 11:37 PM.
rigtec is offline   Reply With QuoteReply With Quote
Old 02-08-2019, 06:49 PM #15
rigtec's Avatar
rigtec rigtec is offline
Senior Member
 
Join Date: May 2012
Location: Bergenfield NJ.
Posts: 2,466
Real Name: Greg
rigtec has a spectacular aura about rigtec has a spectacular aura about
rigtec rigtec is offline
Senior Member
rigtec's Avatar
 
Join Date: May 2012
Location: Bergenfield NJ.
Posts: 2,466
Real Name: Greg
rigtec has a spectacular aura about rigtec has a spectacular aura about
rigtec Liked @ElectroBoy post!
__________________
2012 Limited (in bliz) Black leather interior.

Commercial hvac diagnostics/electrical specialist (Steamfitters Journeyman Local 475)
rigtec is offline   Reply With QuoteReply With Quote
Reply

Tags
car , door , key , lock , unlock

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 Door Lock Problem (chattering, no lock, etc) bluduk15 4th Gen T4Rs 8 12-15-2018 02:40 PM
Door Lock Issues: Actuator or just Lock Motor replacement Mlynn 4th Gen T4Rs 12 08-20-2016 06:19 PM
FS: Power Door Lock Actuator with Lock Latch - rear passenger side T4RTX For Sale: T4R Items 4 06-26-2014 02:58 PM
2007 4runner driver side back seat door lock won't lock Richqwert7 4th Gen T4Rs 0 11-30-2013 06:28 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 03:25 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2019


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.