User Tag List

Reply
 
Thread Tools Rate Thread Display Modes
Old 07-16-2019, 08:48 PM #1
Ripper238's Avatar
Ripper238 Ripper238 is offline
Member
 
Join Date: Jun 2019
Location: CT/NY
Posts: 170
Ripper238 will become famous soon enough
Ripper238 Ripper238 is offline
Member
Ripper238's Avatar
 
Join Date: Jun 2019
Location: CT/NY
Posts: 170
Ripper238 will become famous soon enough
Check engine trac off green blinking truck

Not sure what this is or why this happened. I'm also not getting the miles per gallon green Eco light now for some reason.

What could this be am I going to kill it if I drive it home?

Sent from my SM-N960U using Tapatalk
Ripper238 is offline   Reply With QuoteReply With Quote
Old 07-16-2019, 09:08 PM #2
Jarheadoo7's Avatar
Jarheadoo7 Jarheadoo7 is offline
Member
 
Join Date: Apr 2018
Location: Ohio
Posts: 230
Jarheadoo7 will become famous soon enough
Jarheadoo7 Jarheadoo7 is offline
Member
Jarheadoo7's Avatar
 
Join Date: Apr 2018
Location: Ohio
Posts: 230
Jarheadoo7 will become famous soon enough
I'm pretty sure any time the CEL comes on it shuts down the VSC/ Trac off by default...
Jarheadoo7 is offline   Reply With QuoteReply With Quote
Old 07-16-2019, 09:11 PM #3
Ripper238's Avatar
Ripper238 Ripper238 is offline
Member
 
Join Date: Jun 2019
Location: CT/NY
Posts: 170
Ripper238 will become famous soon enough
Ripper238 Ripper238 is offline
Member
Ripper238's Avatar
 
Join Date: Jun 2019
Location: CT/NY
Posts: 170
Ripper238 will become famous soon enough
When I put it in reverse the brackets around the (R) blank and it seems to be slow to the ingage in drive. This is a 2019 with 500 miles on it.

Sent from my SM-N960U using Tapatalk

Last edited by Ripper238; 07-16-2019 at 09:16 PM.
Ripper238 is offline   Reply With QuoteReply With Quote
Old 07-16-2019, 10:12 PM #4
Ripper238's Avatar
Ripper238 Ripper238 is offline
Member
 
Join Date: Jun 2019
Location: CT/NY
Posts: 170
Ripper238 will become famous soon enough
Ripper238 Ripper238 is offline
Member
Ripper238's Avatar
 
Join Date: Jun 2019
Location: CT/NY
Posts: 170
Ripper238 will become famous soon enough
Takes a few seconds to go into drive and clunks into gear.

Not sure if it's safe to drive or if I should get a tow?

Sent from my SM-N960U using Tapatalk
Ripper238 is offline   Reply With QuoteReply With Quote
Old 07-16-2019, 10:13 PM #5
mo_mo mo_mo is offline
Member
 
Join Date: Jul 2014
Location: Earth
Posts: 372
mo_mo will become famous soon enough
mo_mo mo_mo is offline
Member
 
Join Date: Jul 2014
Location: Earth
Posts: 372
mo_mo will become famous soon enough
Quote:
Originally Posted by Ripper238 View Post
Not sure what this is or why this happened. I'm also not getting the miles per gallon green Eco light now for some reason.

What could this be am I going to kill it if I drive it home?

Sent from my SM-N960U using Tapatalk
#1, go get an obd2 code reader.

#2, if the cel isnít flashing, then itís generally a ďgo get it looked at but is driveableĒ. Maybe not optimal as VSC/Cruise/etc may be unavailable, but not imminently catastrophic. If the cel is flashing, then pull codes/tow it to minimize damage. You should be under warranty, so give the dealership a jingle.
__________________
2014 T4R TE Nav KDSS Super White. Demello Hybrid Bolt On Sliders. LT265/70/17 C Duratracs. TRD CAI. RAV4 Sideview Mirrors: 87961-42D20 & 87931-42D50. Blackvue DR650S-2CH. Cobra 75 WX ST with 4í Firestik + Magnet Roof Top Mount. MXT275 Midland GMRS radio. 3M Crystalline: Front CR70, A-B CR50, B-Aft CR40. Rago Molle Panels. Leather steering wheel cover. RCI Full Skids (Aluminum). Drawer less drawer system and sleeping platform. RRW Leather Covers
mo_mo is offline   Reply With QuoteReply With Quote
Old 07-16-2019, 10:49 PM #6
Ripper238's Avatar
Ripper238 Ripper238 is offline
Member
 
Join Date: Jun 2019
Location: CT/NY
Posts: 170
Ripper238 will become famous soon enough
Ripper238 Ripper238 is offline
Member
Ripper238's Avatar
 
Join Date: Jun 2019
Location: CT/NY
Posts: 170
Ripper238 will become famous soon enough
The green truck is flashing. Multi-terrain select.

I got a remote start and alarm put in so that must have been what caused it. I have AAA so I guess I'll have them tow it.

Thanks

Sent from my SM-N960U using Tapatalk

Last edited by Ripper238; 07-16-2019 at 10:52 PM.
Ripper238 is offline   Reply With QuoteReply With Quote
Old 07-16-2019, 11:20 PM #7
DarkPassenger's Avatar
DarkPassenger DarkPassenger is offline
Member
 
Join Date: May 2015
Posts: 31
DarkPassenger is on a distinguished road
DarkPassenger DarkPassenger is offline
Member
DarkPassenger's Avatar
 
Join Date: May 2015
Posts: 31
DarkPassenger is on a distinguished road
Itís worth asking: Get gas today? Check the cap. A loose cap will trigger the check engine light, which disables traction control, multi terrain select, etc.

If a loose cap caused the problem, it may take some time for the ECU to register and return normal functionality. Youíll may still need to clear the codes with an OBDII dongle, which will clear the dash lights and restore all functionality.


Sent from my iPhone using Tapatalk
DarkPassenger is offline   Reply With QuoteReply With Quote
Old 07-16-2019, 11:33 PM #8
mo_mo mo_mo is offline
Member
 
Join Date: Jul 2014
Location: Earth
Posts: 372
mo_mo will become famous soon enough
mo_mo mo_mo is offline
Member
 
Join Date: Jul 2014
Location: Earth
Posts: 372
mo_mo will become famous soon enough
Quote:
Originally Posted by Ripper238 View Post
The green truck is flashing. Multi-terrain select.

I got a remote start and alarm put in so that must have been what caused it. I have AAA so I guess I'll have them tow it.

Thanks

Sent from my SM-N960U using Tapatalk

Green truck flashing shouldnít be a big deal. The CEL is the real one to watch. Maybe something official in the vehicle manual, but Iím away at the moment so canít tell ya.
__________________
2014 T4R TE Nav KDSS Super White. Demello Hybrid Bolt On Sliders. LT265/70/17 C Duratracs. TRD CAI. RAV4 Sideview Mirrors: 87961-42D20 & 87931-42D50. Blackvue DR650S-2CH. Cobra 75 WX ST with 4í Firestik + Magnet Roof Top Mount. MXT275 Midland GMRS radio. 3M Crystalline: Front CR70, A-B CR50, B-Aft CR40. Rago Molle Panels. Leather steering wheel cover. RCI Full Skids (Aluminum). Drawer less drawer system and sleeping platform. RRW Leather Covers
mo_mo is offline   Reply With QuoteReply With Quote
Old 07-16-2019, 11:54 PM #9
Ripper238's Avatar
Ripper238 Ripper238 is offline
Member
 
Join Date: Jun 2019
Location: CT/NY
Posts: 170
Ripper238 will become famous soon enough
Ripper238 Ripper238 is offline
Member
Ripper238's Avatar
 
Join Date: Jun 2019
Location: CT/NY
Posts: 170
Ripper238 will become famous soon enough
I got gas three days ago with no issues and I double checked the cab a few times.

In the manual the CEL didn't really help since most of it seems to be emissions and other things. My biggest worry is the delay in engaging the transmission and the lurching forward when it goes into gear.

I'll get it checked out one way or another tomorrow.

Sounds like I should invest in an OBDII.

Sent from my SM-N960U using Tapatalk
Ripper238 is offline   Reply With QuoteReply With Quote
Old 07-17-2019, 12:20 AM #10
Ripper238's Avatar
Ripper238 Ripper238 is offline
Member
 
Join Date: Jun 2019
Location: CT/NY
Posts: 170
Ripper238 will become famous soon enough
Ripper238 Ripper238 is offline
Member
Ripper238's Avatar
 
Join Date: Jun 2019
Location: CT/NY
Posts: 170
Ripper238 will become famous soon enough
Do you guys think if I disconnected the negative battery terminal for a bit then reconnected it would solve all this? Or should I just get it towed and tested?

Sent from my SM-N960U using Tapatalk
Ripper238 is offline   Reply With QuoteReply With Quote
Old 07-17-2019, 08:26 AM #11
waypoint's Avatar
waypoint waypoint is offline
Member
 
Join Date: Aug 2017
Posts: 353
waypoint will become famous soon enough waypoint will become famous soon enough
waypoint waypoint is offline
Member
waypoint's Avatar
 
Join Date: Aug 2017
Posts: 353
waypoint will become famous soon enough waypoint will become famous soon enough
Quote:
Originally Posted by Ripper238 View Post
Do you guys think if I disconnected the negative battery terminal for a bit then reconnected it would solve all this? Or should I just get it towed and tested?

Sent from my SM-N960U using Tapatalk
If this error immediately followed the installation of the remote start kit, it's your suspect.
waypoint is offline   Reply With QuoteReply With Quote
Old 07-17-2019, 08:36 AM #12
Ripper238's Avatar
Ripper238 Ripper238 is offline
Member
 
Join Date: Jun 2019
Location: CT/NY
Posts: 170
Ripper238 will become famous soon enough
Ripper238 Ripper238 is offline
Member
Ripper238's Avatar
 
Join Date: Jun 2019
Location: CT/NY
Posts: 170
Ripper238 will become famous soon enough
Quote:
Originally Posted by waypoint View Post
If this error immediately followed the installation of the remote start kit, it's your suspect.
almost. I drove about 30 miles parked it and then when I started it up again it gave me the error of course. It couldn't have happened while I was there....

Yeah definitely. Apparently they can check stuff so I'm having it towed there just to be safe. Clunking into drive is concerning.

Just so weird would have such a horrific reaction to whatever they did. and I bought this truck because it was simple, apparently the electronics are fairly sophisticated. Lol

Sent from my SM-N960U using Tapatalk
Ripper238 is offline   Reply With QuoteReply With Quote
Old 07-17-2019, 08:51 AM #13
bobdacat bobdacat is offline
Junior Member
 
Join Date: Nov 2013
Location: new jersey
Posts: 12
bobdacat is on a distinguished road
bobdacat bobdacat is offline
Junior Member
 
Join Date: Nov 2013
Location: new jersey
Posts: 12
bobdacat is on a distinguished road
possibly the neutral safety switch. a little electric box thats on the outside of transmission. Had the similar issue. Hard to shift and the eco light goes off, and pretty sure it wasnt shifting into 5th gear. It wasn't on all the time, got it to dealership when CEL little offroad light were on, the took it off examined it and put more of the dieletric grease and sealed it up. no further issues.
bobdacat is offline   Reply With QuoteReply With Quote
Old 07-17-2019, 09:58 AM #14
Ripper238's Avatar
Ripper238 Ripper238 is offline
Member
 
Join Date: Jun 2019
Location: CT/NY
Posts: 170
Ripper238 will become famous soon enough
Ripper238 Ripper238 is offline
Member
Ripper238's Avatar
 
Join Date: Jun 2019
Location: CT/NY
Posts: 170
Ripper238 will become famous soon enough
Tested with OBDII and it gave a bunch of transmission errors which is strange?

Transmission range sensor circuit?

Sent from my SM-N960U using Tapatalk

Last edited by Ripper238; 07-17-2019 at 10:07 AM.
Ripper238 is offline   Reply With QuoteReply With Quote
Old 07-17-2019, 10:52 AM #15
Ripper238's Avatar
Ripper238 Ripper238 is offline
Member
 
Join Date: Jun 2019
Location: CT/NY
Posts: 170
Ripper238 will become famous soon enough
Ripper238 Ripper238 is offline
Member
Ripper238's Avatar
 
Join Date: Jun 2019
Location: CT/NY
Posts: 170
Ripper238 will become famous soon enough
Thinking it's the neutral safety switch?

Sent from my SM-N960U using Tapatalk
Ripper238 is offline   Reply With QuoteReply With Quote
Reply

Tags
check , drive , green , kill , reason

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Check engine light, VSC TRAC & TRAC OFF lights crainmain Maintenance/Detailing 118 05-14-2019 10:52 AM
Check engine light on + Trac off light on + 4LO blinking= ?????? RiDE 5th gen T4Rs 21 10-11-2017 11:51 PM
Check engine light vsc trac & trac off lights come on piptraderfx New Members 5 03-14-2014 07:47 AM
check engine & VCS Off light blinking lonkelm 4th Gen T4Rs 12 09-10-2013 07:54 PM
Check engine + VSC/TRAC blinking after install baz Engines / Suspension / Wheels / Tires / Audio / Accessories 3 08-03-2008 08:14 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 07:24 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2019


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.