User Tag List

Reply
 
Thread Tools Rate Thread Display Modes
Old 06-24-2020, 03:33 AM #1
mluckey's Avatar
mluckey mluckey is offline
Junior Member
 
Join Date: Jun 2020
Location: Camarillo, CA
Posts: 23
Real Name: Mitch
mluckey is on a distinguished road
mluckey mluckey is offline
Junior Member
mluckey's Avatar
 
Join Date: Jun 2020
Location: Camarillo, CA
Posts: 23
Real Name: Mitch
mluckey is on a distinguished road
Cruise Control Not Working

Hello all, I have a 2012 SR5 4x4 and ever since I got the truck (~6 months ago) the cruise control has not worked. When I hit the stock to turn on CC the dash light doesn't even illuminate, my first thought was maybe the bulb burned out but even after trying to turn it on and initiate CC as if the light did turn on it still does not work. I checked for fuse diagrams and nothing that i've been able to find says anything about any fuses that have to do with CC. I'm wondering if maybe the stock itself is bad or if it is something else. Everything else on the truck seems to work perfectly fine so it doesnt seem to be linked to another problem.

Would appreciate any insight.
Thanks.
mluckey is offline   Reply With QuoteReply With Quote
Old 06-24-2020, 09:22 AM #2
Bossman's Avatar
Bossman Bossman is offline
Senior Member
 
Join Date: Jun 2008
Location: North Bay, ON, Canada
Posts: 1,471
Bossman is a jewel in the rough Bossman is a jewel in the rough Bossman is a jewel in the rough Bossman is a jewel in the rough
Bossman Bossman is offline
Senior Member
Bossman's Avatar
 
Join Date: Jun 2008
Location: North Bay, ON, Canada
Posts: 1,471
Bossman is a jewel in the rough Bossman is a jewel in the rough Bossman is a jewel in the rough Bossman is a jewel in the rough
May want to confirm that the cruise control module is actually plugged in (maybe PO was doing some work and needed to unplug it for some reason and forgot to plug it back in).

Would suggest pulling the error codes.

Other possible causes for the cruise control not working are a faulty brake light switch, or issues with the clock spring / spiral cable.

Cruise control not working

Spiral cable and cruise control question

Cruise Control Only Works When Wheel Turned
__________________
2011 Limited 4WD with NAV: "CDN Package" (running boards, mud guards, all-weather mats, cargo liner, block heater).
Summer: Michelin Premier LTX 245/60R20 on OEM Limited 20" rims / Winter: Toyo Observe GSi-5 265/70R17 on 2018 TRD Off-Road 17" rims.

Previous: 2003 4Runner Limited 4WD V8; 1997 Lexus LS400; 1997 Camry CE; 1988 Celica Turbo 4WD; 1982 Celica GT
Bossman is offline   Reply With QuoteReply With Quote
Old 06-24-2020, 11:56 AM #3
thennen's Avatar
thennen thennen is offline
Senior Member
 
Join Date: Aug 2018
Location: Ohio
Posts: 1,142
thennen is a name known to all thennen is a name known to all thennen is a name known to all thennen is a name known to all thennen is a name known to all thennen is a name known to all
thennen thennen is offline
Senior Member
thennen's Avatar
 
Join Date: Aug 2018
Location: Ohio
Posts: 1,142
thennen is a name known to all thennen is a name known to all thennen is a name known to all thennen is a name known to all thennen is a name known to all thennen is a name known to all
Fuse 6, interior panel (speed control amplifier) maybe? Ignore red lines.
Attached Images
Cruise Control Not Working-interior-fuse-panel-062420-gif 
thennen is offline   Reply With QuoteReply With Quote
Old 06-24-2020, 01:41 PM #4
Shadytype Shadytype is offline
Member
 
Join Date: Nov 2017
Posts: 81
Shadytype is on a distinguished road
Shadytype Shadytype is offline
Member
 
Join Date: Nov 2017
Posts: 81
Shadytype is on a distinguished road
Make sure you dont have traction control off. Cruise wont work with it off. Also if you have a broken abs sensor or other peice that setects wheel slip it, the cruise will nit work
Shadytype is offline   Reply With QuoteReply With Quote
Reply

Tags
control , light , stock , turn , work

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2020 TRD PRO - Cruise Control not working deevilla7 5th gen T4Rs 10 04-22-2020 05:28 PM
ECO and Cruise Control not working. Any thoughts? Cam_23 5th gen T4Rs 8 03-16-2015 03:33 PM
Cruise control not working cbielat 5th gen T4Rs 18 01-19-2015 09:33 PM
Cruise Control not working DSpease15 Classic T4Rs 6 09-04-2011 01:07 AM
Cruise control quit working wy4runner 3rd gen T4Rs 4 06-17-2008 03:20 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 01:07 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2020