User Tag List

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-24-2020, 11:40 AM #1
nhelo1 nhelo1 is offline
Junior Member
 
Join Date: Nov 2020
Posts: 13
nhelo1 is on a distinguished road
nhelo1 nhelo1 is offline
Junior Member
 
Join Date: Nov 2020
Posts: 13
nhelo1 is on a distinguished road
Electric Problem

Hello,
I just bought a 2018 4runner TRD off road premium. After the shipper dropped it off I noticed a few problems:

1) low beam headlights don't work
2) brake light is on
3) ABS light is on
3) power steering light is on
4) TPMS light is on
5) from the drive seat I can only control driver window can not control other windows. The other window controls work from their respective door panels
6) Multi terrain select is not available
7) Odomotor, speedometer, and tachometer don't work.
8) ambient temperature sensor does not work
9) Gear of transmission display does not work on the dashboard
10) slip light indicator is on.
11) remote key entry does not work
12) a lot of the fuses will not light up when I try to test them (like Half of the fuse box).
13) car has a rough start and idle. seems like it wants to die on cold starts.


I appreciate your help. I am guessing its the ECU or the wiring. Whats throwing me off is my diagnostic computer can not even connect to give me codes (it turns on when connected to the obd2 but can't read the car). When I opened up the panel I noticed the alarm was disconnected so I am guessing the car was stolen. Any help in diagnosing a wire problem or eco problem would be of help.

Thanks
nhelo1 is offline   Reply With QuoteReply With Quote
Old 11-24-2020, 11:44 AM #2
Jivewalker's Avatar
Jivewalker Jivewalker is offline
Member
 
Join Date: Jul 2012
Location: Charleston, SC
Age: 49
Posts: 598
Jivewalker is just really nice Jivewalker is just really nice Jivewalker is just really nice Jivewalker is just really nice
Jivewalker Jivewalker is offline
Member
Jivewalker's Avatar
 
Join Date: Jul 2012
Location: Charleston, SC
Age: 49
Posts: 598
Jivewalker is just really nice Jivewalker is just really nice Jivewalker is just really nice Jivewalker is just really nice
You accepted it with all those problems? I'd make it the sellers/shippers problem. Why would you even mess with it?
__________________
2012 TE KDSS | Black| 265/70R17 C KO2's | 212,000 miles |Link To Inside Fishing Rod Holder Mod

I am fragile.
Not like a flower.
But like a bomb.
Jivewalker is offline   Reply With QuoteReply With Quote
Old 11-24-2020, 11:48 AM #3
LandCruiser's Avatar
LandCruiser LandCruiser is offline
Senior Member
 
Join Date: Feb 2013
Location: East Bay
Posts: 4,501
Real Name: Sparky
LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of
LandCruiser LandCruiser is offline
Senior Member
LandCruiser's Avatar
 
Join Date: Feb 2013
Location: East Bay
Posts: 4,501
Real Name: Sparky
LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of
Sounds like it had a bad battery and then shipper jump started it improperly and fried the electronics.
__________________
Old and (c)rusty.
LandCruiser is offline   Reply With QuoteReply With Quote
Old 11-24-2020, 11:57 AM #4
s13koop's Avatar
s13koop s13koop is offline
Member
 
Join Date: Sep 2017
Location: Houston, TX
Posts: 48
s13koop will become famous soon enough
s13koop s13koop is offline
Member
s13koop's Avatar
 
Join Date: Sep 2017
Location: Houston, TX
Posts: 48
s13koop will become famous soon enough
What's the backstory on it?
Flooded? Insurance repo/rebuilt?
__________________
00-JZX100
10-Trail Ed.
s13koop is offline   Reply With QuoteReply With Quote
Old 11-24-2020, 11:58 AM #5
nhelo1 nhelo1 is offline
Junior Member
 
Join Date: Nov 2020
Posts: 13
nhelo1 is on a distinguished road
nhelo1 nhelo1 is offline
Junior Member
 
Join Date: Nov 2020
Posts: 13
nhelo1 is on a distinguished road
It was a stolen vehicle. I bought it from the auction. I should have known better.


Quote:
Originally Posted by s13koop View Post
What's the backstory on it?
Flooded? Insurance repo/rebuilt?
nhelo1 is offline   Reply With QuoteReply With Quote
Old 11-24-2020, 12:01 PM #6
s13koop's Avatar
s13koop s13koop is offline
Member
 
Join Date: Sep 2017
Location: Houston, TX
Posts: 48
s13koop will become famous soon enough
s13koop s13koop is offline
Member
s13koop's Avatar
 
Join Date: Sep 2017
Location: Houston, TX
Posts: 48
s13koop will become famous soon enough
Well not necessarily all bad. Afterall it is a Toyota
Lets start simple. How's the battery/charging?
If you can't clear the codes can you leave the battery disconnected for 10-20min and try again?
__________________
00-JZX100
10-Trail Ed.
s13koop is offline   Reply With QuoteReply With Quote
Old 11-24-2020, 12:10 PM #7
nhelo1 nhelo1 is offline
Junior Member
 
Join Date: Nov 2020
Posts: 13
nhelo1 is on a distinguished road
nhelo1 nhelo1 is offline
Junior Member
 
Join Date: Nov 2020
Posts: 13
nhelo1 is on a distinguished road
I had to install a new battery, even though the one they installed was only a few months old. I have disconnected the battery overnight and tried to reread the codes but no success. I will try again.

Quote:
Originally Posted by s13koop View Post
Well not necessarily all bad. Afterall it is a Toyota
Lets start simple. How's the battery/charging?
If you can't clear the codes can you leave the battery disconnected for 10-20min and try again?
nhelo1 is offline   Reply With QuoteReply With Quote
Old 11-24-2020, 12:27 PM #8
1jzgte 1jzgte is offline
Member
 
Join Date: Oct 2016
Location: Nevada
Posts: 878
1jzgte will become famous soon enough 1jzgte will become famous soon enough
1jzgte 1jzgte is offline
Member
 
Join Date: Oct 2016
Location: Nevada
Posts: 878
1jzgte will become famous soon enough 1jzgte will become famous soon enough
ouch. good luck
1jzgte is offline   Reply With QuoteReply With Quote
Old 11-24-2020, 12:29 PM #9
s13koop's Avatar
s13koop s13koop is offline
Member
 
Join Date: Sep 2017
Location: Houston, TX
Posts: 48
s13koop will become famous soon enough
s13koop s13koop is offline
Member
s13koop's Avatar
 
Join Date: Sep 2017
Location: Houston, TX
Posts: 48
s13koop will become famous soon enough
May need to look into Zero Point Calibration
__________________
00-JZX100
10-Trail Ed.

Last edited by s13koop; 11-24-2020 at 12:32 PM.
s13koop is offline   Reply With QuoteReply With Quote
Old 11-24-2020, 12:39 PM #10
llDemonll llDemonll is offline
Member
 
Join Date: Mar 2017
Location: Washington
Posts: 553
llDemonll is just really nice llDemonll is just really nice llDemonll is just really nice llDemonll is just really nice llDemonll is just really nice
llDemonll llDemonll is offline
Member
 
Join Date: Mar 2017
Location: Washington
Posts: 553
llDemonll is just really nice llDemonll is just really nice llDemonll is just really nice llDemonll is just really nice llDemonll is just really nice
You bought a stolen vehicle, high likely-hood all issues are electrical. Get under the dash and start looking at wiring, or buy a new ECU and see if that fixes anything.

Either way, you bought a car at auction sight-unseen. Should have at least asked for a video of the car running and a view of the dash.
llDemonll is offline   Reply With QuoteReply With Quote
Old 11-24-2020, 01:10 PM #11
thennen's Avatar
thennen thennen is online now
Senior Member
 
Join Date: Aug 2018
Location: Ohio
Posts: 1,262
thennen is a splendid one to behold thennen is a splendid one to behold thennen is a splendid one to behold thennen is a splendid one to behold thennen is a splendid one to behold thennen is a splendid one to behold thennen is a splendid one to behold
thennen thennen is online now
Senior Member
thennen's Avatar
 
Join Date: Aug 2018
Location: Ohio
Posts: 1,262
thennen is a splendid one to behold thennen is a splendid one to behold thennen is a splendid one to behold thennen is a splendid one to behold thennen is a splendid one to behold thennen is a splendid one to behold thennen is a splendid one to behold
Quote:
Originally Posted by nhelo1 View Post
Hello,
I just bought a 2018 4runner TRD off road premium. After the shipper dropped it off I noticed a few problems:

1) low beam headlights don't work
2) brake light is on
3) ABS light is on
3) power steering light is on
4) TPMS light is on
5) from the drive seat I can only control driver window can not control other windows. The other window controls work from their respective door panels
6) Multi terrain select is not available
7) Odomotor, speedometer, and tachometer don't work.
8) ambient temperature sensor does not work
9) Gear of transmission display does not work on the dashboard
10) slip light indicator is on.
11) remote key entry does not work
12) a lot of the fuses will not light up when I try to test them (like Half of the fuse box).
13) car has a rough start and idle. seems like it wants to die on cold starts.


I appreciate your help. I am guessing its the ECU or the wiring. Whats throwing me off is my diagnostic computer can not even connect to give me codes (it turns on when connected to the obd2 but can't read the car). When I opened up the panel I noticed the alarm was disconnected so I am guessing the car was stolen. Any help in diagnosing a wire problem or eco problem would be of help.

Thanks
Ouch is right. First, as Jivewalker said, make it the seller's problem if at all possible. If you bought it as-is, then you may be done there.

If you're stuck with it, I'm wondering if you could pull the fuses for all the things that aren't essential to running (lights, AC, ABS, etc.) and see if anything changes as far as the dash lights and rough engine. You could then re-introduce a fuse at a time (after making sure it's good) and look for changes. Maybe someone maliciously slashed or ripped a wire bundle, or did some other damage, creating opens and/or shorts. Also, not sure what you mean by fuses not lighting up. You're pulling them and checking with an ohmmeter?

One thing maybe - the window lock switch could be engaged or bad.

LandCruiser could be right about the ECU. Best wishes.
thennen is online now   Reply With QuoteReply With Quote
Old 11-24-2020, 01:38 PM #12
Jivewalker's Avatar
Jivewalker Jivewalker is offline
Member
 
Join Date: Jul 2012
Location: Charleston, SC
Age: 49
Posts: 598
Jivewalker is just really nice Jivewalker is just really nice Jivewalker is just really nice Jivewalker is just really nice
Jivewalker Jivewalker is offline
Member
Jivewalker's Avatar
 
Join Date: Jul 2012
Location: Charleston, SC
Age: 49
Posts: 598
Jivewalker is just really nice Jivewalker is just really nice Jivewalker is just really nice Jivewalker is just really nice
Even if you bought AS-IS, not the end of the world especially if engine, body, and other components are good. If you're only problem is electrical you can find the issues and fix them with some time. Might just be one thing.

I would start with the headlights low beam not working. Trace it back with a meter.

A broken ground somewhere will cause a lot of those issues. Something as simple as a harness unplugged under the hood will give you some of those lights. Start checking continuity of all circuits. You can get a wiring diagram on here. One of the ECU's may very well be fried, but I'd have to know why before I even went that route.
__________________
2012 TE KDSS | Black| 265/70R17 C KO2's | 212,000 miles |Link To Inside Fishing Rod Holder Mod

I am fragile.
Not like a flower.
But like a bomb.
Jivewalker is offline   Reply With QuoteReply With Quote
Old 11-24-2020, 04:17 PM #13
TRUSTYAXE's Avatar
TRUSTYAXE TRUSTYAXE is offline
Member
 
Join Date: Dec 2014
Location: North Port, Florida
Posts: 555
TRUSTYAXE will become famous soon enough TRUSTYAXE will become famous soon enough
TRUSTYAXE TRUSTYAXE is offline
Member
TRUSTYAXE's Avatar
 
Join Date: Dec 2014
Location: North Port, Florida
Posts: 555
TRUSTYAXE will become famous soon enough TRUSTYAXE will become famous soon enough
Quote:
Originally Posted by nhelo1 View Post
Whats throwing me off is my diagnostic computer can not even connect to give me codes (it turns on when connected to the obd2 but can't read the car).
Thanks
This is key, I encountered a similar issue recently. My neighbors Camry horn was going off one day and I looked out to see him and his wife (older couple) jumping it. Well the next day I saw him under the hood and went over to see if I could help. Turns out the Camry was screaming for HELP, they had jumped it with reversed polarity, actually melted about one third of the negative terminal on the battery. Apparently they had AAA come by during the day and the driver told them the computer was fried. We got a new battery in and then the fun started, during this I could not get my Scan tool to connect. After replacing the 120 amp alternator fuse and several others, from radio power to throttle power, only then was able to connect and clear codes.

I would start by removing the battery and replacing all the blown fuses.

It's a big cookie so you know the saying...one bite at a time.
__________________
2015 TRDPRO SUPER WHITE ~ ROOF RACK DELETE ~ REAR SEAT DELETE ~ LED ANYTIME FOGS ~ DRL DISABLE ~ DOMETIC CFX-28 ~ NITTO RG 285's ~ TOYTEC 2/1.5 SAW ~ BORLA CAT BACK ~ SPRINT BOOSTER V2 ~ aFe MOMENTUM GT INTAKE ~ OTHER JUNK N STUFF
TRUSTYAXE is offline   Reply With QuoteReply With Quote
Old 11-24-2020, 04:49 PM #14
EddieV4runnin's Avatar
EddieV4runnin EddieV4runnin is offline
Member
 
Join Date: Oct 2016
Location: Oxnard
Posts: 758
EddieV4runnin is a jewel in the rough EddieV4runnin is a jewel in the rough EddieV4runnin is a jewel in the rough
EddieV4runnin EddieV4runnin is offline
Member
EddieV4runnin's Avatar
 
Join Date: Oct 2016
Location: Oxnard
Posts: 758
EddieV4runnin is a jewel in the rough EddieV4runnin is a jewel in the rough EddieV4runnin is a jewel in the rough
Donít mess with it, send it to the dealer you should be under warranty.
__________________
Mods are loading.......
EddieV4runnin is offline   Reply With QuoteReply With Quote
Old 11-24-2020, 04:55 PM #15
LandCruiser's Avatar
LandCruiser LandCruiser is offline
Senior Member
 
Join Date: Feb 2013
Location: East Bay
Posts: 4,501
Real Name: Sparky
LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of
LandCruiser LandCruiser is offline
Senior Member
LandCruiser's Avatar
 
Join Date: Feb 2013
Location: East Bay
Posts: 4,501
Real Name: Sparky
LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of LandCruiser has much to be proud of
Quote:
Originally Posted by EddieV4runnin View Post
Donít mess with it, send it to the dealer you should be under warranty.
Would warranty cover electrical damage to a truck incurred by it either being stolen or shenanigans that happened after it was recovered?
__________________
Old and (c)rusty.
LandCruiser is offline   Reply With QuoteReply With Quote
Reply

Tags
car , guessing , light , problem , work

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I bet you've never seen this electric problem.... Adam F 3rd gen T4Rs 13 07-01-2017 01:41 AM
89 Electric back window problem 89runner31 Classic T4Rs 13 11-17-2015 07:16 AM
1990 4runner electric fan problem commostud Classic T4Rs 0 11-29-2010 11:02 PM
Starter problem (electric) Steernit 3rd gen T4Rs 13 10-02-2009 12:56 AM
Fuse and Electric and Lock Problem Gtrain Classic T4Rs 0 10-24-2005 11:05 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 11:29 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2020