User Tag List

Reply
 
Thread Tools Rate Thread Display Modes
Old 02-26-2021, 07:14 PM #1
cascadiarunner cascadiarunner is offline
Member
 
Join Date: Nov 2018
Location: Northern CA/Southern OR
Age: 36
Posts: 51
Real Name: Erik
cascadiarunner is on a distinguished road
cascadiarunner cascadiarunner is offline
Member
 
Join Date: Nov 2018
Location: Northern CA/Southern OR
Age: 36
Posts: 51
Real Name: Erik
cascadiarunner is on a distinguished road
Weird Problem - New ECM & MPG Loss

Long story short a rodent chewed an injector cable and fried my ECM. I got it replaced and I've lost about 2.5 MPG average since. It's been about a month and I've probably driven 1,000 miles or so. Also got the spark plugs replaced at the same time.

I know correlation =/= causation but the timing seems to indicate something related. Anyone ever heard of anything like this or have any ideas?

Thanks!
cascadiarunner is offline   Reply With QuoteReply With Quote
Old 02-26-2021, 11:10 PM #2
Skidmarcx's Avatar
Skidmarcx Skidmarcx is offline
Member
 
Join Date: Jan 2013
Location: Phoenix, AZ
Posts: 730
Skidmarcx will become famous soon enough
Skidmarcx Skidmarcx is offline
Member
Skidmarcx's Avatar
 
Join Date: Jan 2013
Location: Phoenix, AZ
Posts: 730
Skidmarcx will become famous soon enough
Doesnít sound normal... do you have access to a scan tool that can display fuel trims?
__________________
97 Limited 4x2 ---> 4x4 (SOLD)
SS 1.3 | ToyTec | RadFlo | Aussie | SOR | AOR | CBI | DC Power | Rigid | Alpine | Audison | JL Audio | Second Skin


2020 TRD Off Road Premium
King | BFG | Rago | AudioControl | AudioFrog | JL Audio | Dynamat
Skidmarcx is offline   Reply With QuoteReply With Quote
Old 02-27-2021, 12:30 AM #3
fkheath fkheath is offline
Member
 
Join Date: Sep 2020
Location: Utah
Posts: 506
fkheath has a spectacular aura about fkheath has a spectacular aura about fkheath has a spectacular aura about
fkheath fkheath is offline
Member
 
Join Date: Sep 2020
Location: Utah
Posts: 506
fkheath has a spectacular aura about fkheath has a spectacular aura about fkheath has a spectacular aura about
Quote:
Originally Posted by cascadiarunner View Post
Long story short a rodent chewed an injector cable and fried my ECM. I got it replaced and I've lost about 2.5 MPG average since. It's been about a month and I've probably driven 1,000 miles or so. Also got the spark plugs replaced at the same time.

I know correlation =/= causation but the timing seems to indicate something related. Anyone ever heard of anything like this or have any ideas?

Thanks!
Try resetting the average MPG. Sometimes there is some old data in the memory that makes the reading look low to what it really is.
fkheath is offline   Reply With QuoteReply With Quote
Old 02-27-2021, 03:08 AM #4
flyrv9's Avatar
flyrv9 flyrv9 is offline
Senior Member
 
Join Date: Dec 2012
Location: Clearwater Kansas
Posts: 1,104
flyrv9 has a spectacular aura about flyrv9 has a spectacular aura about
flyrv9 flyrv9 is offline
Senior Member
flyrv9's Avatar
 
Join Date: Dec 2012
Location: Clearwater Kansas
Posts: 1,104
flyrv9 has a spectacular aura about flyrv9 has a spectacular aura about
You could do a basic fuel calibration. Make sure all tires are the same pressure. Fill tank and drive a set number of miles (let's say 100). Fill tank again and compute MPG. You could run the test a couple of times under the same conditions; with the same loading in the truck. Compare that to what you were getting with the old ECU.

Another thing to check is that both ECU's are the same part # and have the same software load.
flyrv9 is offline   Reply With QuoteReply With Quote
Reply

Tags
=/= , ecm , mpg , replaced , time

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 sr5 weird brake pressure loss at a light. rpete Problems & Warranty Issues 4 12-11-2017 12:05 PM
Tachometer Problem/Loss of Power Chotchkies 3rd gen T4Rs 4 09-13-2017 03:20 PM
Brake problem! Loss of preasure... Idahosr5 3rd gen T4Rs 9 06-03-2011 03:40 PM
Weird loss of traction after ABS goes off wsdavies 3rd gen T4Rs 2 12-09-2009 04:38 PM
Wierd power loss problem.... brokeawd Classic T4Rs 6 09-23-2006 12:10 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 03:30 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2020