User Tag List

Reply
 
Thread Tools Rate Thread Display Modes
Old 03-13-2012, 11:56 AM #1
RangerME47's Avatar
RangerME47 RangerME47 is offline
Junior Member
 
Join Date: Mar 2012
Location: Flagstaff, Arizona
Posts: 1
RangerME47 is on a distinguished road
RangerME47 RangerME47 is offline
Junior Member
RangerME47's Avatar
 
Join Date: Mar 2012
Location: Flagstaff, Arizona
Posts: 1
RangerME47 is on a distinguished road
Power Steering Pump Leak

On my 1994 runner, i have a power steering pump leak. Some work was done to the truck about a year ago and a little while ago a leak popped up somewhere within the power steering pump. I cant see where without tearing half the motor apart. It almost looks like it may be coming from a spot on the left hand side of the pump as your looking at it from the front end, but i was told it was the vacuum for the pump, but there is a bolt that goes into it that was taken off when the truck was worked on, could there be a crush ring in there that is seated wrong and is causing the problem, or is it something else? Any help would be nice. Thanks guys

Truck specs:
1994 4runner
3.0L V6 Automatic
4wd
RangerME47 is offline   Reply With QuoteReply With Quote
Old 02-24-2014, 05:53 PM #2
mistersnowman97's Avatar
mistersnowman97 mistersnowman97 is offline
Member
 
Join Date: Jan 2013
Location: San Francisco, California
Posts: 281
Real Name: Jerry Reed
mistersnowman97 is on a distinguished road
mistersnowman97 mistersnowman97 is offline
Member
mistersnowman97's Avatar
 
Join Date: Jan 2013
Location: San Francisco, California
Posts: 281
Real Name: Jerry Reed
mistersnowman97 is on a distinguished road
Hopefully I can resurrect this thread. I have the same problem, but it's leaking rapidly and it's making a mess. The mechanic said if it's the pump, then it's under warranty and it won't cost me anything. But i'm assuming it'll cost me something in labor. Just wondering if I should check to see if it's just a leaky hose or something before dropping $$ on someone else to do it for me..
__________________
1994 4Runner-Stock 3VZE
mistersnowman97 is offline   Reply With QuoteReply With Quote
Old 02-24-2014, 06:08 PM #3
giro's Avatar
giro giro is offline
Member
 
Join Date: Feb 2007
Location: Lake Tahoe, NV
Posts: 288
giro is on a distinguished road
giro giro is offline
Member
giro's Avatar
 
Join Date: Feb 2007
Location: Lake Tahoe, NV
Posts: 288
giro is on a distinguished road
Check the hoses first. There's at least 2 different types of clamps at the metal to hose connections, depending on the truck (mine was different than the one I mined (for the metal line that got kinked by fan shrapnel) at pick-n-pull).

I had a very slow leak in the pump 5 years ago, just a drip or 2 a day. I fixed that with stop-leak, though it took a bottle and a half over a year to fully fix it. It's been leak free for 4 years now.
__________________
92 4runner SR5 Garnet Pearl (3K3), 5spd 4x4 V6 185k
22 Sienna AWD 9k
06 Sienna AWD 185k
98 4runner SR5 4x4 V6 auto 136k locking rear diff -- SOLD (and heard it's been totaled)
giro is offline   Reply With QuoteReply With Quote
Old 02-24-2014, 06:11 PM #4
Jdrum1 Jdrum1 is offline
Member
 
Join Date: Jul 2013
Location: West Texas
Posts: 59
Jdrum1 is on a distinguished road
Jdrum1 Jdrum1 is offline
Member
 
Join Date: Jul 2013
Location: West Texas
Posts: 59
Jdrum1 is on a distinguished road
I'm not sure of your specific problem, but check to ensure you have Dexron ATF and not power steering fluid in your system.

Mine had steering fluid, and was cuasing multiple leaks (and the pump started to whine when cold). I flushed and filled the system with Dexron, and all is good (two months later, and the pump is fine and no more leaks).
Jdrum1 is offline   Reply With QuoteReply With Quote
Old 02-24-2014, 06:20 PM #5
77'911 77'911 is offline
Member
 
Join Date: Apr 2006
Location: north america
Posts: 637
77'911 is on a distinguished road
77'911 77'911 is offline
Member
 
Join Date: Apr 2006
Location: north america
Posts: 637
77'911 is on a distinguished road
As others have indicated, check the hoses. If they are leaking it is usually due to failing crush washers, improper fluid, and or failed motor mounts(engine moves too much pulling on the hoses breaking the seal). I use Mobil 1 synthetic ATF in our 1990 which has worked exceedingly well over the years. If the pump is leaking, Toyota does sell a reseal kit, and a new pump for about $400. Best of luck with it.
regards
77'911 is offline   Reply With QuoteReply With Quote
Old 02-24-2014, 06:25 PM #6
mistersnowman97's Avatar
mistersnowman97 mistersnowman97 is offline
Member
 
Join Date: Jan 2013
Location: San Francisco, California
Posts: 281
Real Name: Jerry Reed
mistersnowman97 is on a distinguished road
mistersnowman97 mistersnowman97 is offline
Member
mistersnowman97's Avatar
 
Join Date: Jan 2013
Location: San Francisco, California
Posts: 281
Real Name: Jerry Reed
mistersnowman97 is on a distinguished road
thanks all.
Yes it is ATF in there.
I'll check those hoses. I imagine it's not too hard of a fix considering the pump is only 3 months old.
Will post pics as soon as possible.
__________________
1994 4Runner-Stock 3VZE
mistersnowman97 is offline   Reply With QuoteReply With Quote
Old 02-24-2014, 07:48 PM #7
mistersnowman97's Avatar
mistersnowman97 mistersnowman97 is offline
Member
 
Join Date: Jan 2013
Location: San Francisco, California
Posts: 281
Real Name: Jerry Reed
mistersnowman97 is on a distinguished road
mistersnowman97 mistersnowman97 is offline
Member
mistersnowman97's Avatar
 
Join Date: Jan 2013
Location: San Francisco, California
Posts: 281
Real Name: Jerry Reed
mistersnowman97 is on a distinguished road
*UPDATE*
Went down and talked to my mechanic and he took a look and said it was the main seal. it was spraying all over the inside of the engine bay. (erg. just degreased the thing) But the pump was under warranty and so i'm getting a new one for $0
__________________
1994 4Runner-Stock 3VZE
mistersnowman97 is offline   Reply With QuoteReply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
power steering pump RIrunner 3rd gen T4Rs 7 11-19-2009 10:18 AM
Power Steering Pump lax815 Classic T4Rs 2 04-23-2008 08:48 AM
FS: Power steering pump for 3.0L 3VZE n8buddy Classifieds - buy & sell (no commercial ads please) 0 09-15-2006 03:58 PM
replacing power steering pump?? wastedracing Classic T4Rs 1 08-24-2006 09:01 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 12:47 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2024 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2024 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2024 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2020