User Tag List

Reply
 
Thread Tools Rate Thread Display Modes
Old 07-15-2020, 06:49 AM #16
pinemind pinemind is offline
Member
 
Join Date: Oct 2018
Location: Philadelphia, PA
Posts: 78
pinemind will become famous soon enough
pinemind pinemind is offline
Member
 
Join Date: Oct 2018
Location: Philadelphia, PA
Posts: 78
pinemind will become famous soon enough
I did a test I should have done long before on the CSI. Thinking there may be a leak, I took the electrical connector off the CSI, pulled it out of the plenum, connected the fuel jumper, ignition on. I waited about 3 minutes and didn't see any leaking. So at this point, as many have suggested, the CSI itself is fine. It doesn't leak, it sprays on start when needed, and Ohm's out correctly. I don't see anything wrong with the cold start system, mechanical or electrical at this point.
pinemind is offline   Reply With QuoteReply With Quote
Old 12-21-2020, 07:24 PM #17
86yota4wd 86yota4wd is offline
Junior Member
 
Join Date: Dec 2020
Location: Anacortes Wa
Posts: 1
86yota4wd is on a distinguished road
86yota4wd 86yota4wd is offline
Junior Member
 
Join Date: Dec 2020
Location: Anacortes Wa
Posts: 1
86yota4wd is on a distinguished road
I am having the exact issue with my 86 22re. Cold starts are hit and miss, sometimes it fires right up, sometimes it takes 1 minute of running the starter to get it to fire off. Cold starts are always kind of rough( a little miss but clears up after a few seconds) Warm/hot the truck starts and runs just fine. At this point I think the fuel pressure is bleeding down, the fuel pressure regulator is bad or for some reason the CSI isnt getting enough voltage. I have also read that the crimps in the harness for the fuel injectors may be the issue. I havent checked mine yet.

Last edited by 86yota4wd; 12-21-2020 at 07:25 PM. Reason: grammer error
86yota4wd is offline   Reply With QuoteReply With Quote
Reply

Tags
cold , engine , fuel , oem , start

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
WTB- 1st gen 4runner 22RE, cold start injector kc15842 For Sale: T4R Items 2 05-31-2018 03:52 PM
I need 22re cold start injector switch/senser yeahsureugotitgo Problems & Warranty Issues 1 06-02-2014 03:24 PM
Low idle on cold start - '88 22re bishopsRobes Classic T4Rs 1 12-06-2010 11:19 PM
22re cold start capo Classic T4Rs 2 11-04-2007 04:48 PM
22re cold start injector capo Classic T4Rs 1 10-19-2007 01:24 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 05:24 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2020