User Tag List

Reply
 
Thread Tools Rate Thread Display Modes
Old 07-29-2022, 01:33 AM #1
Maverickpixel Maverickpixel is offline
Junior Member
 
Join Date: Oct 2018
Location: LA
Posts: 19
Maverickpixel is on a distinguished road
Maverickpixel Maverickpixel is offline
Junior Member
 
Join Date: Oct 2018
Location: LA
Posts: 19
Maverickpixel is on a distinguished road
87 power loss?

hey all,

i am rehabbing a 87 4runner and im running into a weird issue. Lately it feels like the truck has about half its normal power. I live on the top of a hill and i can barely get up it these days.

some history... i purchased the truck from someone who didnt keep the best care of it. when i got it i did a full tune up and got it ready to be carb legal in CA. And it ran well for months.

The previous owner did some electrical mods that im slowly finding. Like a kill switch and what looks to be a bull horn.

randomly the truck will lose power to the turn signals/dash (hopefully not breaklights but i havent been able to test that ) i cant seem to pin point why this is happening, like trying to find some kind of pattern that would cause things to randomly shut off. I mention this issue because im wondering if i have a grounding problem, that could be affecting the power out put.

my first thought would be a vacuum leak, which i hope isnt the case because im not sure how to diagnose that.

maybe something to do with the ignition electricals? cap / rotor/ wires everything has been replaced this year but something could have gone bad... not sure how to test that either

my mechanic is pretty backed up so im hoping i can solve this one on my own. i miss driving the truck around. i havent been because im nervous its going to leave me stranded.

thanks for reading

-mv
Maverickpixel is offline   Reply With QuoteReply With Quote
Old 07-30-2022, 01:26 PM #2
fourwd1's Avatar
fourwd1 fourwd1 is offline
Moderator
 
Join Date: Jun 2004
Location: the Socialist State of Maryland
Posts: 11,154
Real Name: Soylent Green sales
fourwd1 is a jewel in the rough fourwd1 is a jewel in the rough fourwd1 is a jewel in the rough
fourwd1 fourwd1 is offline
Moderator
fourwd1's Avatar
 
Join Date: Jun 2004
Location: the Socialist State of Maryland
Posts: 11,154
Real Name: Soylent Green sales
fourwd1 is a jewel in the rough fourwd1 is a jewel in the rough fourwd1 is a jewel in the rough
Your post is a bit confusing, are you loosing engine power or electrical power ?
__________________
- the Internet - the mother-ship of people who don't know much and aren't afraid to go public
'84 4Runner - ARBed 5.29s F&R, 4.7 & 2.28 t-cases, 2" drive train lift, BudBuilt x-member/skid, 30 spl Longs
'83 Toy P/U - Buick 231 V6, Holley 4 bbl, Weiand intake, Downey headers, TH350 w/700R4 low gearset,
'89 4Runner SR5 - stock
fourwd1 is offline   Reply With QuoteReply With Quote
Old 07-30-2022, 07:44 PM #3
Reinout's Avatar
Reinout Reinout is offline
Member
 
Join Date: Oct 2016
Location: Lakebay, WA
Posts: 450
Real Name: Reinout
Reinout will become famous soon enough Reinout will become famous soon enough
Reinout Reinout is offline
Member
Reinout's Avatar
 
Join Date: Oct 2016
Location: Lakebay, WA
Posts: 450
Real Name: Reinout
Reinout will become famous soon enough Reinout will become famous soon enough
Let me recap the issues:
-Undocumented electrical mods (not repairs)
-Losing electrical power to: turn signals and dash
-Engine loses power

It's possible that it's a vacuum leak but it seems to coincidental.

To rule out vacuum leak get yourself a can of brake cleaner and while the motor is running go around and spray a variety of spots that it might be leaking. If you get a surge or the motor dies, you've found your spot. If you don't get any surge/dying, try spraying the cleaner elsewhere in the engine bay.

I have a feeling that your motor being down on power at times is indeed going to be a grounding issue.
__________________
1988 4Runner SR5- ~250k Miles and counting - 5 Speed
1997 4Runner SR5- ~376k Miles and counting - 5 Speed E-Locker
2007 4Runner Limited V6- 165k Miles - Automatic - Brake Controller
2011 VW JSW TDI- 130k Miles - 6 Speed - Air Lift 1000
2006 Scamp trailer 16'
Reinout is offline   Reply With QuoteReply With Quote
Old 07-30-2022, 08:11 PM #4
Maverickpixel Maverickpixel is offline
Junior Member
 
Join Date: Oct 2018
Location: LA
Posts: 19
Maverickpixel is on a distinguished road
Maverickpixel Maverickpixel is offline
Junior Member
 
Join Date: Oct 2018
Location: LA
Posts: 19
Maverickpixel is on a distinguished road
Quote:
Originally Posted by Reinout View Post
Let me recap the issues:
-Undocumented electrical mods (not repairs)
-Losing electrical power to: turn signals and dash
-Engine loses power

It's possible that it's a vacuum leak but it seems to coincidental.

To rule out vacuum leak get yourself a can of brake cleaner and while the motor is running go around and spray a variety of spots that it might be leaking. If you get a surge or the motor dies, you've found your spot. If you don't get any surge/dying, try spraying the cleaner elsewhere in the engine bay.

I have a feeling that your motor being down on power at times is indeed going to be a grounding issue.
Thanks for the technique, ill give that a shot. I ordered some replacement hoses and honestly i was going to replace them all just for posterity. i already noticed that im missing a full line coming from the crank case.

i also need to replace the timing chain guides, i read that it could jump a tooth and that could cause it.

its definitely running rich, atleast to my nose meter
Maverickpixel is offline   Reply With QuoteReply With Quote
Old 07-31-2022, 05:14 PM #5
Maverickpixel Maverickpixel is offline
Junior Member
 
Join Date: Oct 2018
Location: LA
Posts: 19
Maverickpixel is on a distinguished road
Maverickpixel Maverickpixel is offline
Junior Member
 
Join Date: Oct 2018
Location: LA
Posts: 19
Maverickpixel is on a distinguished road
might not be the best place to ask, but is there a more visited 1st gen 4runner forum that is out there? i find it hard to find any info here via the search
__________________
1977 Celica GT
1987 4runner
1991 Mr2 Turbo
2002 Mr2 Spyder
2009 Saab 9-3 Sportcombi Aero
Maverickpixel is offline   Reply With QuoteReply With Quote
Old 08-02-2022, 11:31 PM #6
RAD4Runner's Avatar
RAD4Runner RAD4Runner is offline
Senior Member
 
Join Date: Mar 2012
Location: Southern California
Posts: 1,836
RAD4Runner has a spectacular aura about RAD4Runner has a spectacular aura about
RAD4Runner RAD4Runner is offline
Senior Member
RAD4Runner's Avatar
 
Join Date: Mar 2012
Location: Southern California
Posts: 1,836
RAD4Runner has a spectacular aura about RAD4Runner has a spectacular aura about
Quote:
Originally Posted by Maverickpixel View Post
might not be the best place to ask, but is there a more visited 1st gen 4runner forum that is out there? i find it hard to find any info here via the search
Yotatech. First gen owners are more active there.
Use "google' search option. The other options are lame and will give you irrelevant results.
__________________
86 4Runner, 22R-Eliable, 5-Speed Manual, dlx. WHAT'S YOURS?
If you want us to help from afar please let us see, hear, feel what you're dealing with.
A picture paints a thousand words.
Toyota components are bullet-proof. Issues often arise from poor wiring, assembly and/or maintenance. Suspect those first.
Next only to our senses, the multi-meter is the most important electrical diagnostic tool. Spend $6 at Harbor Freight or $$$ blindly replacing parts.
RAD4Runner is offline   Reply With QuoteReply With Quote
Reply

Tags
issue , power , randomly , test , truck

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Loss of power, no CEL rjb75 4th Gen T4Rs 5 07-02-2020 03:49 PM
Please Help: Extreme Loss of Power (@ 30% full power) mattkc16 5th gen T4Rs 33 05-17-2017 09:43 PM
Help!! Loss of power 95 T4R SjamesT4R Classic T4Rs 18 01-10-2017 03:46 PM
power loss on take off hannable111 General Discussions 0 02-15-2011 01:21 PM
how much power loss am i looking at? 99NWA4R Engines / Suspension / Wheels / Tires / Audio / Accessories 19 10-26-2010 08:12 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 12:40 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2022 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2022 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2022 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2020