User Tag List

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-20-2019, 04:28 AM #1
AlexG AlexG is offline
Junior Member
 
Join Date: Feb 2014
Location: Plano, TX
Posts: 3
AlexG is on a distinguished road
AlexG AlexG is offline
Junior Member
 
Join Date: Feb 2014
Location: Plano, TX
Posts: 3
AlexG is on a distinguished road
Replaced car battery, now A/C has weird smell???

I had Walmart replace my car battery about 3 weeks ago, and ever since, there is a strong smell coming from the A/C - even when I turn it off, but much more so when it's on - either blowing hot or cold, doesn't matter.

Hard to describe the smell, but I don't think it's mold or mildew. Perhaps an "electrical" or "burning" smell?

I've replaced the battery in this vehicle many times (including same model battery top rated by Consumer Reports - at this same Walmart 6 years ago) - never had a problem like this!

What on earth could be going on?

Vehicle: 1999 4Runner SR5 V6 2WD ~310,000 miles
Location: Dallas TX area

Any thoughts would be greatly appreciated!
AlexG is offline   Reply With QuoteReply With Quote
Old 11-20-2019, 08:16 AM #2
AuSeeker AuSeeker is offline
Senior Member
 
Join Date: Nov 2016
Location: Bluffton S.C.
Posts: 3,364
Real Name: Skip
AuSeeker is a splendid one to behold AuSeeker is a splendid one to behold AuSeeker is a splendid one to behold AuSeeker is a splendid one to behold AuSeeker is a splendid one to behold AuSeeker is a splendid one to behold AuSeeker is a splendid one to behold AuSeeker is a splendid one to behold
AuSeeker AuSeeker is offline
Senior Member
 
Join Date: Nov 2016
Location: Bluffton S.C.
Posts: 3,364
Real Name: Skip
AuSeeker is a splendid one to behold AuSeeker is a splendid one to behold AuSeeker is a splendid one to behold AuSeeker is a splendid one to behold AuSeeker is a splendid one to behold AuSeeker is a splendid one to behold AuSeeker is a splendid one to behold AuSeeker is a splendid one to behold
Quote:
Originally Posted by AlexG View Post
I had Walmart replace my car battery about 3 weeks ago, and ever since, there is a strong smell coming from the A/C - even when I turn it off, but much more so when it's on - either blowing hot or cold, doesn't matter.

Hard to describe the smell, but I don't think it's mold or mildew. Perhaps an "electrical" or "burning" smell?

I've replaced the battery in this vehicle many times (including same model battery – top rated by Consumer Reports - at this same Walmart 6 years ago) - never had a problem like this!

What on earth could be going on?

Vehicle: 1999 4Runner SR5 V6 2WD ~310,000 miles
Location: Dallas TX area

Any thoughts would be greatly appreciated!
Not sure what would cause this unless they connected the battery incorrectly at first and shorted something out, check all the fuses to see if any are blown and if so that circuit could be where the burn wiring smell is coming from and the wiring needs to be checked out, if you have the recirculating button set for outside air the smell could be coming from under the hood, try setting it for inside air and see if the smell get less or goes away, if not then look for burned wires under the dash.
__________________
2004 Limited V8

Last edited by AuSeeker; 11-22-2019 at 02:45 AM.
AuSeeker is offline   Reply With QuoteReply With Quote
Old 11-22-2019, 12:36 AM #3
Lester Lugnut's Avatar
Lester Lugnut Lester Lugnut is offline
Senior Member
 
Join Date: Feb 2014
Location: U. S. A.
Posts: 1,015
Lester Lugnut has a spectacular aura about Lester Lugnut has a spectacular aura about
Lester Lugnut Lester Lugnut is offline
Senior Member
Lester Lugnut's Avatar
 
Join Date: Feb 2014
Location: U. S. A.
Posts: 1,015
Lester Lugnut has a spectacular aura about Lester Lugnut has a spectacular aura about
Is the battery leaking electrolyte?
__________________
2015 2WD Toyota Tacoma Prerunner V6 SR5 1GR-FE 236HP VVT-i
2014 2WD Toyota 4Runner SR5 1GR-FE 254 HP Dual VVT-i
2006 Toyota Avalon 3.5l automatic 2GR-RE Dual VVT-i
1991 Mercedes-Benz 300-SEL M103
1975 Kawasaki 900 Z1-B
Lester Lugnut is offline   Reply With QuoteReply With Quote
Reply

Tags
battery , car , replaced , smell , vehicle

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird smell after I use the defroster bay_area4runner 3rd gen T4Rs 9 01-12-2017 01:46 AM
Weird chemical smell outside 04 V8 4Runner dave4242 4th Gen T4Rs 0 12-08-2016 08:27 AM
Weird smell chahaj Problems & Warranty Issues 1 05-28-2014 01:05 PM
Weird Smell Clemsonfan15 3rd gen T4Rs 8 10-08-2008 02:54 AM
intake installed... but weird smell galacticrunner1 4th Gen T4Rs 7 05-12-2005 09:49 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 01:20 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2020