Toyota 4Runner Forum - Largest 4Runner Forum

Toyota 4Runner Forum - Largest 4Runner Forum (https://www.toyota-4runner.org/)
-   5th gen T4Rs (https://www.toyota-4runner.org/5th-gen-t4rs/)
-   -   Xenon Depot Warranty (https://www.toyota-4runner.org/5th-gen-t4rs/278861-xenon-depot-warranty.html)

marlinsfan 10-21-2019 01:35 PM

Xenon Depot Warranty
 
Hey gang,

So I installed the H11 HID kit with the Philips 4300k bulb 35 months ago. One of the lights is no longer working, noticed today but don't really know how long it's been out. I paid $150 for the kit almost 3 years ago.

In looking at their website, replacement bulbs cost $135, although there is a 10% coupon out there today. The same kit today is $245 minus the 10%.

The kit came with a "3 Year legitimate replacement warranty". Has anyone here had any issues with the kit? And if so, have you gotten them to send you a warranty replacement kit? I'm under this warranty for another month as I see it.

This time of year it's getting dark early, so I'm running the risk of getting a ticket every day I leave work...

nguggs 10-21-2019 02:35 PM

I purchased my kit about a year ago and had ballasts issues all winter. (Ive never had bulb problems, though.) XD support was very helpful and patient as we spend ~5 months troubleshooting. They mailed multiple ballast out to me before we finally were able to get it resolved.

Id for sure reach out if a bulb has any issues and you're still within the warranty period. Id even do it if it were slightly after... My guess is they will have you do a bunch testing first, like swapping bulb sides, manually flipping lights off and on, etc to help "prove"(?) that the bulb is bad before sending a replacement if warranted.

Toda R 10-22-2019 10:45 AM

I've been a loyal Xenon Deopt customer for years. All my cars run their kits with no problems..... until recently. I bought a kit about a year ago now, and have had to replace 3 ballast. While their warranty program is excellent, they always replaced it without any questions. I have questions about the quality of the product since they sold the company about a year ago. I'm running my 3rd ballast right now and hopefully i finally got a good one. If it goes out again i probably will be switching companies.

marlinsfan 10-22-2019 11:39 AM

Ok so I talked to XD yesterday and @nguggs s was right, they asked me to trouble shoot to see what part failed. I swapped the bulbs and both fires up. But.... the original side doesn’t always fire up now. I called XD back and told them as much, when they asked me to swap the ballasts I politely declined as it’s a huge amount of work. Fair enough they said and will be shipping me a new ballast. Hopefully that fixes it, as maybe the problem is with the relay.

A+ to XD for honoring a 3 year warranty when I have about 30 days left on it.

marlinsfan 10-29-2019 09:17 AM

I must say that I'm bringing the grade down to a C at this point. It's been a full week since they created my free replacement order, and it still hasn't shipped. It's impossible to get them on the phone as they either have too many calls or not enough people answering them, and their email replies are painfully slow.

In the meantime, I've been driving with only one headlight, and in this part of the country, the sun is rising late and it's getting dark very early, so every day driving to work and driving back home I'm risking getting pulled over.:wtf:

jhguth 10-29-2019 09:40 AM

why not just stop at an auto parts store and throw in a cheap halogen bulb until you get your replacement?

marlinsfan 10-29-2019 10:06 AM

Itís not that simple. I have the old original bulbs. The installation of the HID kit requires you to drill the plastic cap that seals the headlamp so that the wider grommet can fit in.

WISluggo 10-29-2019 10:31 AM

Quote:

Originally Posted by marlinsfan (Post 3379662)
I must say that I'm bringing the grade down to a C at this point. It's been a full week since they created my free replacement order, and it still hasn't shipped. It's impossible to get them on the phone as they either have too many calls or not enough people answering them, and their email replies are painfully slow.

In the meantime, I've been driving with only one headlight, and in this part of the country, the sun is rising late and it's getting dark very early, so every day driving to work and driving back home I'm risking getting pulled over.:wtf:

There was a similar story with XD in the other thread discussing the new Xb headlights. I hope your issue gets resolved.

jhguth 10-29-2019 10:40 AM

Quote:

Originally Posted by marlinsfan (Post 3379681)
Itís not that simple. I have the old original bulbs. The installation of the HID kit requires you to drill the plastic cap that seals the headlamp so that the wider grommet can fit in.

use a piece of tape, the bulb itself has a seal that's just a dust cap, or hell it's a $12 part if you just want another one

really easy to fix so you have 2 headlights

BigCountryT4R 10-29-2019 07:56 PM

Quote:

Originally Posted by marlinsfan (Post 3379681)
Itís not that simple. I have the old original bulbs. The installation of the HID kit requires you to drill the plastic cap that seals the headlamp so that the wider grommet can fit in.

So? Get some tape over the hole And put your other bulbs back in for a short time. Better than paying for a fix it ticket.

Sent from my SM-N975U using Tapatalk

Daftjungle03 10-29-2019 09:33 PM

I just installed a kit a few months back. I had another in a Highlander without any issues. I was thinking about stashing the stock bulbs in my emergency kit just for this kind of a scenario. I don't think that XD has too many issues but obviously you can't just pull into the store and replace a bulb / ignitor etc..

I agree, just remove the HID bulbs, reinstall the stock ones and place a piece of duct tape over the hole until it's sorted.

XenonDepot 10-30-2019 10:41 AM

Hi guys!

I am extremely sorry for the communications. We're getting more support with phones and emails. This is my first time seeing this, but that's not an excuse.

@marlinsfan , Please PM me your order number or email, and I'll get it taken care of today!

marlinsfan 10-30-2019 11:22 AM

Sending PM now. I did get a call back yesterday evening. The person that called me was surprised that the order had been stuck in the system, and promised to ship it out today. I just logged on and it still shows 'processing'. I just called to see, but again was on hold for a while and the system kicked me out promising to call me back.

The guy on the phone was yesterday was very rude. I asked him to send me the part overnight, because it was supposed to have gone out last week and I'm driving around with a busted headlight. He told me he wasn't authorized to do that. I asked to speak to a supervisor, he told me I'd get the same answer. I told him I still wanted to talk to a supervisor, he told me I'd have to hold for 30 minutes. I told him just send me the damn part then.

I tell you, customer service is not a priority for you guys. There are many people selling what you sell, you should do your best to keep the clients you have.

Daftjungle03 11-18-2019 01:53 PM

Any update to this? Right after seeing this post I had a bulb issue and after confirming my address for a replacement I haven't heard back. It's been a week...

This is how I look at the moment. Funny they say the drivers side is bad? At least I don't have a bulb completely out at the moment. This is their HID kit with Phillips 4300k bulbs.

https://live.staticflickr.com/65535/...2663761e_c.jpgIMG_20191106_091216 (1) by Michael Starmer, on Flickr

marlinsfan 11-18-2019 02:08 PM

I got the new ballast and Iím all good now. They told me that the first warranty replacement order was stuck in the system. Then they pushed it out, and as mentioned before, refused to over-night it to me. Took about two weeks total for me to get my part.

They IMíd me here offering some other bulb in compensation. I told them I would not say now if they were going to send me something for free, but I never got whatever it was they were going to send. Oh well.

Keep calling them and be patient on hold.it room several tries but I was able to talk to them after many tries.


All times are GMT -4. The time now is 04:44 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.