User Tag List

Reply
 
Thread Tools Rating: Thread Rating: 2 votes, 4.50 average. Display Modes
Old 11-25-2011, 09:15 AM #46
madmax 06 madmax 06 is offline
Junior Member
 
Join Date: Nov 2011
Posts: 10
madmax 06 is on a distinguished road
madmax 06 madmax 06 is offline
Junior Member
 
Join Date: Nov 2011
Posts: 10
madmax 06 is on a distinguished road
Oh, and one last thing! My wife just called me while she was on her way to work, and now all of a sudden her rear windshield wiper, defroster and wiper fluid don't work. What the???? Could this be one heck of a qwinky dink, or did something get affected by disconnecting the battery. Everything else works.

I guess I will check the fuse when she gets home tonight.
madmax 06 is offline   Reply With QuoteReply With Quote
Old 11-25-2011, 08:15 PM #47
dbfoerster dbfoerster is offline
Junior Member
 
Join Date: Apr 2011
Location: Brighton, Colorado
Posts: 8
Real Name: David
dbfoerster is on a distinguished road
dbfoerster dbfoerster is offline
Junior Member
 
Join Date: Apr 2011
Location: Brighton, Colorado
Posts: 8
Real Name: David
dbfoerster is on a distinguished road
I have a similar issue.

Started my 2006 4 Runner Sport 4.7 last night and a lot of the idiot lights came on and have not gone off. Check Engine light, VSC Off light, Traction Control light and VSC Traction light. I went to the local auto parts store to get the diagnostics code and they came up with P0712. Did a little research and found that it could be the transmission fluid temp sensor or related to it. Has anyone had any experiance with this issue. Before I had the code checked I did check the gas cap and it was tight.
dbfoerster is offline   Reply With QuoteReply With Quote
Old 11-27-2011, 11:15 AM #48
madmax 06 madmax 06 is offline
Junior Member
 
Join Date: Nov 2011
Posts: 10
madmax 06 is on a distinguished road
madmax 06 madmax 06 is offline
Junior Member
 
Join Date: Nov 2011
Posts: 10
madmax 06 is on a distinguished road
Ok, did a little more research on here, and found out how to re-set the rear window and sun roof after disconnecting the battery. On my way to Auto Zone to get a new gas cap and see if I can get the TRAC/VSC lights to finally shut off. Snow is on it's way.
madmax 06 is offline   Reply With QuoteReply With Quote
Old 11-29-2011, 09:53 AM #49
dbfoerster dbfoerster is offline
Junior Member
 
Join Date: Apr 2011
Location: Brighton, Colorado
Posts: 8
Real Name: David
dbfoerster is on a distinguished road
dbfoerster dbfoerster is offline
Junior Member
 
Join Date: Apr 2011
Location: Brighton, Colorado
Posts: 8
Real Name: David
dbfoerster is on a distinguished road
Quote:
Originally Posted by dbfoerster View Post
I have a similar issue.

Started my 2006 4 Runner Sport 4.7 last night and a lot of the idiot lights came on and have not gone off. Check Engine light, VSC Off light, Traction Control light and VSC Traction light. I went to the local auto parts store to get the diagnostics code and they came up with P0712. Did a little research and found that it could be the transmission fluid temp sensor or related to it. Has anyone had any experiance with this issue. Before I had the code checked I did check the gas cap and it was tight.
Well before I could do anything, I filled up with gas and all the lights went out. I did notice that the gas cap was NOT tight does not ever get tight. Just for the heck of it I am going to buy a new gas cap-WIERD STUFF.
dbfoerster is offline   Reply With QuoteReply With Quote
Old 01-03-2012, 09:15 PM #50
DuManchu's Avatar
DuManchu DuManchu is offline
Junior Member
 
Join Date: Dec 2010
Location: Olathe, KS
Posts: 5
DuManchu is on a distinguished road
DuManchu DuManchu is offline
Junior Member
DuManchu's Avatar
 
Join Date: Dec 2010
Location: Olathe, KS
Posts: 5
DuManchu is on a distinguished road
Had this exact thing happen to me today. What's worse is my code reader apparently decided to stop working today as well.

Turns out mine was just the gas cap. The one that was on it would click, but it wasn't actually tightening. Ran to NAPA, grabbed a new cap, ditched the old one, unplugged the battery to clear the code, and blam! No more CEL/TRAC lights!

I'm just glad it was the gas cap, easy to fix and diagnose without a code reader.

Guess I have a good excuse to get a ScanGauge II now
__________________
TLCA #15671
2005 4Runner SR5 V6 4X4 - Titanium Metallic
Removed HCF
265/75/16 Hankook Dynapro ATM's
Leveling Suspension 2/1.5 Lift
DuManchu is offline   Reply With QuoteReply With Quote
Old 01-05-2012, 07:59 PM #51
scrooster's Avatar
scrooster scrooster is offline
Member
 
Join Date: May 2011
Location: Somewhere in the Machine
Age: 60
Posts: 31
scrooster is on a distinguished road
scrooster scrooster is offline
Member
scrooster's Avatar
 
Join Date: May 2011
Location: Somewhere in the Machine
Age: 60
Posts: 31
scrooster is on a distinguished road
It amazing that this many people are experiencing this problem ... we've had the exact same thing happen to our 4runner and it too was, on different occassions:

1 - Gas Cap
2 - #6 cylinder
3 - and we keep having the same TRAC/VSC lights issues as well.
4 - O2 sensor

It's been a good little SUV that we've bought new with 3 miles on the odo ... but it sure has been quirky.
scrooster is offline   Reply With QuoteReply With Quote
Old 01-06-2012, 11:55 PM #52
smallfry's Avatar
smallfry smallfry is offline
Senior Member
 
Join Date: Nov 2006
Location: Colorado Springs, Co
Age: 38
Posts: 1,903
smallfry will become famous soon enough
smallfry smallfry is offline
Senior Member
smallfry's Avatar
 
Join Date: Nov 2006
Location: Colorado Springs, Co
Age: 38
Posts: 1,903
smallfry will become famous soon enough
It just happened to my 3rd gen and I just replaced the rear O2 sensor and so far so good.
__________________
2010 Toyota 4runner TE - http://www.toyota-4runner.org/5th-ge...ion-build.html
smallfry is offline   Reply With QuoteReply With Quote
Old 01-09-2012, 02:20 PM #53
SilverGs SilverGs is offline
Member
 
Join Date: Dec 2011
Location: Oakville, Ontario
Posts: 337
SilverGs is on a distinguished road
SilverGs SilverGs is offline
Member
 
Join Date: Dec 2011
Location: Oakville, Ontario
Posts: 337
SilverGs is on a distinguished road
I'm glad I stumbled on this thread.

I have a 05 Sport Edition V6 with 186K Km (or 115K miles). Just bought the truck about a month ago.

This morning I got the CEL and VSC/TRAC lights on. I'll check the gas cap when I get home tonight and disconnect the battery to see if it clears the code.

Does the disconnect of the have to be simply to disconnect and reconnect it back immediately or do I need to leave it disconnected for a specific amount of time?
SilverGs is offline   Reply With QuoteReply With Quote
Old 01-25-2012, 09:23 AM #54
eddie in nc eddie in nc is offline
Junior Member
 
Join Date: Nov 2011
Location: Charlotte, NC
Posts: 3
eddie in nc is on a distinguished road
eddie in nc eddie in nc is offline
Junior Member
 
Join Date: Nov 2011
Location: Charlotte, NC
Posts: 3
eddie in nc is on a distinguished road
New Gas Cap

2006 4WD Sport Edition. Just wanted to post that I had the CEL and Trac Lights go on about a month ago and I tried a few of the quick fixes but the lights came back on. Then I really looked at the gas cap and the seal appeared somewhat deteriorated. I went to the dealership and got a new gas cap, ~ $28, installed it and a few days later the lights went off and have been off for a week now, knock on wood.
eddie in nc is offline   Reply With QuoteReply With Quote
Old 08-20-2012, 09:47 PM #55
bren861 bren861 is offline
Junior Member
 
Join Date: Aug 2012
Location: New York
Posts: 8
bren861 is on a distinguished road
bren861 bren861 is offline
Junior Member
 
Join Date: Aug 2012
Location: New York
Posts: 8
bren861 is on a distinguished road
I have a 2003 4 Runner 6c. My check engine and VSC Track VSC off lights are on. The truck seems to be running ok, except for a little hesitation at red lights. Im trying to avoid the dealership. They want 103.00 just to put in on the computer. There's a lot of talk in the forum that it may be the 02 sensors. Is that something my neighborhood mechanic can fix, or do I have to take it to the dealer?
bren861 is offline   Reply With QuoteReply With Quote
Old 09-15-2012, 11:00 AM #56
Seano777 Seano777 is offline
Junior Member
 
Join Date: Sep 2012
Posts: 1
Seano777 is on a distinguished road
Seano777 Seano777 is offline
Junior Member
 
Join Date: Sep 2012
Posts: 1
Seano777 is on a distinguished road
Smile Update on check engine light with VSC lights

Yes. The gas cap being loose or off will cause the check engine light to come on as well as the VSC lights. Why.... Probably a broad code systems for techs. Just tighten the gas cap and remove positive connector to battery. Once power has been disabled, reconnect and check engine light & VSC lights turn off.
2008 4Runner The sensor/CAT and everything else were fine.
Seano777 is offline   Reply With QuoteReply With Quote
Old 10-12-2012, 04:54 PM #57
haro4x4's Avatar
haro4x4 haro4x4 is offline
Junior Member
 
Join Date: Sep 2011
Location: bx n y
Posts: 23
haro4x4 is on a distinguished road
haro4x4 haro4x4 is offline
Junior Member
haro4x4's Avatar
 
Join Date: Sep 2011
Location: bx n y
Posts: 23
haro4x4 is on a distinguished road
I disconnect the battery to replace my hid bulb and reconnect the battery and started the truck and the engine light and VSC Track VSC come on. than the VSC Track VSC lights turn off now I have the engine light on
haro4x4 is offline   Reply With QuoteReply With Quote
Old 10-26-2012, 05:33 AM #58
Kayeffsee04 Kayeffsee04 is offline
Junior Member
 
Join Date: Oct 2012
Posts: 2
Kayeffsee04 is on a distinguished road
Kayeffsee04 Kayeffsee04 is offline
Junior Member
 
Join Date: Oct 2012
Posts: 2
Kayeffsee04 is on a distinguished road
Vsc/Trac lights

Same thing happened to my 2004 Toyota 4runner SR5. Grr! Thanks for all the helpful information! I totally panicked when the light came on...
Kayeffsee04 is offline   Reply With QuoteReply With Quote
Old 11-23-2012, 03:47 PM #59
ayazdadla ayazdadla is offline
Junior Member
 
Join Date: Nov 2012
Posts: 10
ayazdadla is on a distinguished road
ayazdadla ayazdadla is offline
Junior Member
 
Join Date: Nov 2012
Posts: 10
ayazdadla is on a distinguished road
Toyota V8 engine defect.

Please chime in ...

I have been a loyal... | Facebook
ayazdadla is offline   Reply With QuoteReply With Quote
Old 05-26-2013, 12:47 PM #60
trentchristopher's Avatar
trentchristopher trentchristopher is offline
Junior Member
 
Join Date: Mar 2012
Location: sjc or phx
Posts: 1
Real Name: trent
trentchristopher is on a distinguished road
trentchristopher trentchristopher is offline
Junior Member
trentchristopher's Avatar
 
Join Date: Mar 2012
Location: sjc or phx
Posts: 1
Real Name: trent
trentchristopher is on a distinguished road
Thumbs up CEL and VSC Lights -> Gas Cap & Battery Disconnect

Hi Guys and Gals,

Long-time reader, first-time poster. I have a 2005 SR5 4WD (105k miles) that I left sit for two weeks while on a business trip. My wife fired it up once about a week in. When I came home and fired up the beast, it struggled to keep idling and shook. So, I applied the accelerator in neutral and blew out quite a bit of smoke. Then, it began idling ok. (My wife said it idled "like a diesel" when she drove it, too.) We went about our errands and a couple hours later, and three stops, the Check Engine Light and three VSC lights came on. I popped the hood and notice my AFE CAI was missing 2 screws, and there was a ton of dried leaves on the perimeter of the engine bay, but everything else "looked" fairly normal.

When we got home, I checked this forum and decided to try 1) getting a new gas cap and 2) replacing the CAI housing screws. $33 later (local Bay Area dealership) and $1.50 (local OSH) later and the idiot lights were still ablaze. So, I disconnected the battery and left it unplugged for a bit while I did other things. Came back, hooked up the battery, and fired it up. Voila; no more idiot lights.

I'm a hobby mechanical, weekend warrior at best, so can't tell you exactly what went wrong. But, I think the gas tank collected condensation while it sat for a couple of weeks due to the gas cap not being all too great, causing it to blow smoke on startup. Probably something with the poor vacuum sealing of the original cap coupled with the condensation triggered one of the O2 sensors to freak out. O2 sensor freaked out and the "system" threw the CEL and cut all "unnecessary" electric amenities (ie VSC). New gas cap probably fixed the vacuum leak and driving it around a little bit probably got rid of the condensation that freaked out the O2 sensor. Battery disconnect allowed the "system" to re-evaluate itself and realize that everything was A-OK again. I don't think replacing the lost screws did anything but give me the warm and fuzzies.

Thanks to all who posted prior. Your experience saved me from an undoubtedly costly trip to the mechanic.



-tcm
__________________
2005 4runner SR5 V6 4WD | Bilstein 5100s Front & Rear | Good Year Duratrac 265/70/R17 | MagnaFlow Cat Back AEF CAI | | Clarion CX609 | Thule Racks Galore | Go Play in the Mountains |
trentchristopher is offline   Reply With QuoteReply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Check engine light, VSC TRAC & TRAC OFF lights crainmain Maintenance/Detailing 118 05-14-2019 10:52 AM
2002 4Runner- VSC, Trac, Check Engine lights came on today ScottDetroit 3rd gen T4Rs 17 09-18-2017 11:12 AM
Check Engine + SRS + VSC TRAC + Slip Indicator lights are all on HELP!!! 4Runner07NEWBIE General Discussions 9 01-06-2011 10:30 PM
check engine light + the VSC Trac + VSC OFF lights are on- Again 1 year later Jerold 3rd gen T4Rs 22 05-26-2010 02:11 AM
2002 4Runner- VSC Trac Check engine lights came on today ScottDetroit Maintenance/Detailing 1 10-10-2008 03:32 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 06:51 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2019


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.