User Tag List

Reply
 
Thread Tools Rating: Thread Rating: 10 votes, 4.40 average. Display Modes
Old 01-11-2010, 01:20 PM #31
TEXREX's Avatar
TEXREX TEXREX is offline
Junior Member
 
Join Date: Dec 2009
Location: Springs that drip, TX
Posts: 17
TEXREX is on a distinguished road
TEXREX TEXREX is offline
Junior Member
TEXREX's Avatar
 
Join Date: Dec 2009
Location: Springs that drip, TX
Posts: 17
TEXREX is on a distinguished road
Vsc trac & vsc off

I just thought I'd resurrect this thread.

I just had the Mass.state emissions done on my '03 and the lights came on. I pointed this out to the tech and they had never seen it happen before. I went back to the station with the TSP in hand and they reset the sensor for me. The tech said he would bring it to the attention of the State Inpection Dept. to update their system.

Thanks for all the help guys. Saved me a trip to the dealer.
__________________

It's all greek to me.
TEXREX is offline   Reply With QuoteReply With Quote
Old 01-11-2010, 01:50 PM #32
bxc13 bxc13 is offline
Member
 
Join Date: Feb 2005
Posts: 119
bxc13 is an unknown quantity at this point
bxc13 bxc13 is offline
Member
 
Join Date: Feb 2005
Posts: 119
bxc13 is an unknown quantity at this point
Hi all,

Just wanted to give an update on my situation as well. I had the issue where the VSC Trac/VSC Off (no check engine) would ONLY come on if the weather was cold. I purchased a scangauge 2 to see if I can get any codes (surprisingly, there were none), however it appears my issue has been fixed (sort of) by having the unit plugged in at all times. I did remove it and the lights came on again, reinstalled and it is gone. I have no technical info on why this works, but it does for my case.

It is a pleasant surprise to have the issue resolved (or at least masked) and having the additional info from the OBD2 port. The amber light can be adjusted to match the factory gauges pretty well also.

Hoppe this helps.

Regards,
Bill
bxc13 is offline   Reply With QuoteReply With Quote
Old 01-11-2010, 02:06 PM #33
BrokenGeiger BrokenGeiger is offline
Junior Member
 
Join Date: Aug 2006
Posts: 6
BrokenGeiger is an unknown quantity at this point
BrokenGeiger BrokenGeiger is offline
Junior Member
 
Join Date: Aug 2006
Posts: 6
BrokenGeiger is an unknown quantity at this point
There was another thread I ran across while researching this. Look further on this forum with keywords OBD2, pin, reset, VSC
__________________
it's hers but paid for...
my cars the jeep
BrokenGeiger is offline   Reply With QuoteReply With Quote
Old 01-12-2010, 02:40 AM #34
Uneek's Avatar
Uneek Uneek is offline
Super Moderator
 
Join Date: Oct 2005
Location: California
Posts: 7,332
Uneek is on a distinguished road
Uneek Uneek is offline
Super Moderator
Uneek's Avatar
 
Join Date: Oct 2005
Location: California
Posts: 7,332
Uneek is on a distinguished road
Try this thread, http://www.toyota-4runner.org/proble...ff-lights.html
__________________
'06 Limited V6

Amy's Mom: "Who's that you're talking to?"
Amy: "It's Uneek, spelled in a 'unique' way."
Uneek is offline   Reply With QuoteReply With Quote
Old 01-16-2010, 02:50 AM #35
CAN-03runner's Avatar
CAN-03runner CAN-03runner is offline
Member
 
Join Date: Dec 2009
Location: Montreal Canada
Age: 43
Posts: 739
CAN-03runner is on a distinguished road
MY GARAGE
CAN-03runner CAN-03runner is offline
Member
CAN-03runner's Avatar
 
Join Date: Dec 2009
Location: Montreal Canada
Age: 43
Posts: 739
CAN-03runner is on a distinguished road
MY GARAGE
VSC OFF fixed Update

I had this problem several days ago. VSC TRAC and VSC lights lit up on the dash. No Check Engine Light and no ABS Light. I tested the ABS on some ice and it did kick in. So ABS and VSC are infact seperate.

I researched this problem on this forum. 2 situations that can possibly result in this condition both were done to my 2003 4runner.

1) the toyota ODBII scanner was attached to it
2) a new key was programmed for the truck. But not sure how they program a new key, maybe it is also with the ODBII??

Anyhow many persons have listed the above as causing this issue to manifest itself. Brought it back to toyota, and they preformed the Zero Point Calibration on it. This has fixed my problem. It's been several days and it hasn't come back. I tried resetting this with 2 other ODBII belonging to a mechanic I know but was not able to perform the recalibration. So be advised if you plan on buying a ODBII scanner for only this particular problem, the non toyota scanners might not have the capability....the BR001-4 provideds information on how to reset manually with the scanner.
__________________
2003 4Runner Sport 4.7 V8 Silver/Grey - Fr/Rr ARB Locker - OME 885/895 - LR UCA - BFG KM2 255/80/17- RCI Skids - Demello Sliders - Bud Hidden Winch- Runva Winch - Synthetic oils- Trail Stripes - Two Baby Seats...

1984/86 4runner In Progress....... V6 swap - High Steer - 33" MTZ - 4.88 Gears - welded rear - ARB front - axle gaussets - Diff covers - Longfields - 4.7 crawler - Titan Winch http://www.toyota-4runner.org/classi...ner-build.html
CAN-03runner is offline   Reply With QuoteReply With Quote
Old 01-17-2010, 02:54 PM #36
MicaBlue03's Avatar
MicaBlue03 MicaBlue03 is offline
Member
 
Join Date: Dec 2004
Location: Seattle
Posts: 230
MicaBlue03 is on a distinguished road
MicaBlue03 MicaBlue03 is offline
Member
MicaBlue03's Avatar
 
Join Date: Dec 2004
Location: Seattle
Posts: 230
MicaBlue03 is on a distinguished road
Why programming a key clears yaw/decel memory

Many (including me) frequenty talk about "programming a new key" for the 4runner and other vehicles with immobilizer or alarm-equipment that makes use of a chip in the ignition key.

The chip in the key is actually a small device that responds to a radio frequency stimulus signal from the vehicle (a transmitter in or very near to the ignition switch) and replies with a digital code unique to that key.

So when you're programming a new key, what you're actually doing is programming the vehicle's own main computer or security module computer (and not the key itself) to accept a specific key. The key itself is unaffected. This process is sometimes called "enrolling the key" and the same thing could happen with a lock/unlock key fob, etc. It's pretty similar to setting up a garage door opener with "rolling code" technology to accept additional remotes.

One thing to keep in mind is that to do the enrolling of a new key you need one of Toyota's "hand-held tester" units and a valid master key for the vehicle in question. They're the black-bodied keys and not the gray valet key. If you lose both master keys you can still use the valet key to open and operate the vehicle, but to get a new key made you (actually the dealer) will have to buy a new security module (several hundred dollars I think) and enroll new key(s) to that module. That's the way they do the ignition immobilizer security, and keep thieves from programming their own keys as a way to steal your car. The lesson here is that if you lose one master key you might consider getting a replacement soon, because if you lose the other master you're in for a bigger bill.

Of course this info is current for the 4th gen 4runners that I'm familiar with. Things can always change.

It's kind of a pain, but I hear from local police that these chip-equipped keys and associated immobilizers are successful at reducing the theft rate of these vehicles. Now if Toyota would only make a more effective lock for the spare tire...

Last edited by MicaBlue03; 01-17-2010 at 02:57 PM.
MicaBlue03 is offline   Reply With QuoteReply With Quote
Old 01-21-2010, 01:43 PM #37
jdq4runner jdq4runner is offline
Junior Member
 
Join Date: Dec 2008
Location: LA
Age: 38
Posts: 13
jdq4runner is an unknown quantity at this point
jdq4runner jdq4runner is offline
Junior Member
 
Join Date: Dec 2008
Location: LA
Age: 38
Posts: 13
jdq4runner is an unknown quantity at this point
thanks MicaBlue03 for starting this post!!! good write up!!!
haven't tried it yet but had CHECK LIGHT, VSC TRAC and VSC OFF lights being turned on by other emission failures (including catalyst and oxygen sensor problems). i erased out code with a obdII scanner CEL turned off but VSC TRAC and VSC OFF still appeared. add guarantee to pass smog in the gas tank drove for a few weeks did my smog i passed with no problem w VSC TRAC and VSC OFF light appeared on. thanks!!!

Last edited by jdq4runner; 01-25-2010 at 04:06 PM.
jdq4runner is offline   Reply With QuoteReply With Quote
Old 01-25-2010, 02:07 PM #38
t4rjon02 t4rjon02 is offline
Junior Member
 
Join Date: Dec 2009
Location: Folsom, Ca
Posts: 16
t4rjon02 is on a distinguished road
t4rjon02 t4rjon02 is offline
Junior Member
 
Join Date: Dec 2009
Location: Folsom, Ca
Posts: 16
t4rjon02 is on a distinguished road
VSC off, TRAC off and check engine light on and rough idle

I'm having some issues with mine. I have an 02 sr5 and I went to start my runner this morning and it had a rough time turning over. The battery is fine. Once it turns over, it idles very roughly and when i give it gas, it stalls. Hope this isn't a huge issue. Any help?
__________________
02 T4R SR5 V6, 31" BFG AT, center lock diff-more to come now that I am almost done with my Duc
09 Ducati M696, CF fender/hugger, CF header guard, CF pod cover, Rizoma Bar End mirrors&bar ends, CF termi exhaust, DP fender eliminator kit, Pazzo levers, Motovation frame sliders
t4rjon02 is offline   Reply With QuoteReply With Quote
Old 01-25-2010, 02:37 PM #39
V8Limited4wd's Avatar
V8Limited4wd V8Limited4wd is offline
Member
 
Join Date: Mar 2004
Location: NoVA
Posts: 728
V8Limited4wd is on a distinguished road
V8Limited4wd V8Limited4wd is offline
Member
V8Limited4wd's Avatar
 
Join Date: Mar 2004
Location: NoVA
Posts: 728
V8Limited4wd is on a distinguished road
Quote:
Originally Posted by t4rjon02 View Post
I'm having some issues with mine. I have an 02 sr5 and I went to start my runner this morning and it had a rough time turning over. The battery is fine. Once it turns over, it idles very roughly and when i give it gas, it stalls. Hope this isn't a huge issue. Any help?
try posting on the actual problems and warranty forum. this thread is specific to the 4thgen.
__________________
2004 V8 LIMITED 4WD
[INT/EXT] 06+ Projectors & HIDs/LEDs/CDN Hood deflector/SS Bull Bar & Hitch Step
[ENGINE] aFe Pro DRY S Air Filter/DT Headers/TRD Dual Exhaust
[WHEELS/SUSPENSION] OEM 20" Rims(265/50R20)/Dobinsons Suspension 1.5" lift
V8Limited4wd is offline   Reply With QuoteReply With Quote
Old 02-02-2010, 03:15 PM #40
Canada 4 Runner's Avatar
Canada 4 Runner Canada 4 Runner is offline
Junior Member
 
Join Date: Feb 2010
Location: Toronto, Canada
Posts: 4
Canada 4 Runner is on a distinguished road
Canada 4 Runner Canada 4 Runner is offline
Junior Member
Canada 4 Runner's Avatar
 
Join Date: Feb 2010
Location: Toronto, Canada
Posts: 4
Canada 4 Runner is on a distinguished road
2003 T4R VSC TRAC + VSC Off + Engine Lights "ON"

I have a 2003 Toyota 4 Runner Limited. a couple of days ago, VSC TRAC + VSC Off & Engine Lights all came ON at the same time.

I live in Canada and it is pretty cold, but I have used this same car the whole past winter without issues.

I have replaced my tires about a month ago, but it was fine right after that..

I have read many of the threads, and they are useful, but is there anyone who could help me with what should be done to this specific case (3 lights!!).
Canada 4 Runner is offline   Reply With QuoteReply With Quote
Old 02-03-2010, 11:06 AM #41
Canada 4 Runner's Avatar
Canada 4 Runner Canada 4 Runner is offline
Junior Member
 
Join Date: Feb 2010
Location: Toronto, Canada
Posts: 4
Canada 4 Runner is on a distinguished road
Canada 4 Runner Canada 4 Runner is offline
Junior Member
Canada 4 Runner's Avatar
 
Join Date: Feb 2010
Location: Toronto, Canada
Posts: 4
Canada 4 Runner is on a distinguished road
Quote:
Originally Posted by Canada 4 Runner View Post
I have a 2003 Toyota 4 Runner Limited. a couple of days ago, VSC TRAC + VSC Off & Engine Lights all came ON at the same time.

I live in Canada and it is pretty cold, but I have used this same car the whole past winter without issues.

I have replaced my tires about a month ago, but it was fine right after that..

I have read many of the threads, and they are useful, but is there anyone who could help me with what should be done to this specific case (3 lights!!).
I had VSC Off + VSC TRAC + CEL (Check Engine Light) ON.

I disconnected the +ve terminal of the battery over night and this morning reconnected it and all lights are gone.

I drove the vehicle for more than 1 Hour and no lights came ON. I checked the Traction and it is working as well as the ABS.

I will drive it for another day or two and see what happens. I may take it to my mechanic to have him look at it as well.

This site is so helpful.. Thanks all for sharing your experience.
Canada 4 Runner is offline   Reply With QuoteReply With Quote
Old 02-05-2010, 04:02 AM #42
glebov88 glebov88 is offline
Junior Member
 
Join Date: Jul 2009
Location: san francisco
Posts: 7
glebov88 is on a distinguished road
glebov88 glebov88 is offline
Junior Member
 
Join Date: Jul 2009
Location: san francisco
Posts: 7
glebov88 is on a distinguished road
So I did this test like 4 months ago with my brother in law and nothing worked the lights stayed on BUT I just checked the instructions and had noticed that he didn't read the last part so what do I do I grab a stereo and a paper clip follow the instruction and wam bam thank you mam I am all fre of the VCS LIGht YEAHH. I am very very happy thanks Guys. Just finished installing an HID kit will post pic soon. had a slight problem but figured out it was a polarity problem switched the switch upside down and wam their shell be light man 6000k looks good
glebov88 is offline   Reply With QuoteReply With Quote
Old 02-10-2010, 07:59 PM #43
rotten1 rotten1 is offline
Junior Member
 
Join Date: Feb 2010
Posts: 2
rotten1 is on a distinguished road
rotten1 rotten1 is offline
Junior Member
 
Join Date: Feb 2010
Posts: 2
rotten1 is on a distinguished road
toyota 4 runner vsc light

Hey I just wanted to thank micablue for his detailed information on the zero point calibration. I brought my wifes truck in for inspection and here in New Hampshire the hook up to the diag connector. Now although I know the vsc light may come on at anytime it just didnt seem right. I performed the recalibration according to procedure and low and behold off the light goes. You learn something new everyday with vehicles
rotten1 is offline   Reply With QuoteReply With Quote
Old 02-15-2010, 08:20 PM #44
V-bOnE's Avatar
V-bOnE V-bOnE is offline
Member
 
Join Date: Nov 2005
Location: Midwest
Posts: 81
V-bOnE is on a distinguished road
V-bOnE V-bOnE is offline
Member
V-bOnE's Avatar
 
Join Date: Nov 2005
Location: Midwest
Posts: 81
V-bOnE is on a distinguished road
Angry VSC TRAC, VSC OFF, and ABS on ONLY when headlights on?!?!?!

I'm hoping someone can help...I get all three lights, but ONLY when the headlights are turned on. In fact, it only takes turing the parking lamps on to trigger the lights. I did do the ZPC last night, and in fact the lights cleared...but then this morning as soon as I turned the headlights on, there were the lights to greet me. Anyone got any ideas? Please help!!!
__________________
2004 SR5 V6 4x4 - BLACK
--------------------------------
K&N Filter, Borla Exhaust, Jaos Aura Grille, PowderCoat Black Tundra/Sequoia 17's, DRL, XD5 hi/lo and fogs, LED Parking Lights, Westin Safari Bar w/PIAA 525s, JDM Heads and Tails w/LED Tail/Brakes, LED Rear Bumper Fogs, Manik Nerf Bars, Debadge, Alpine HU w/iPod Control and Bluetooth, JL Stealthbox w/ JL 250/1 Amp, Euro Wheelskin, Driver Assist Handle, LED Interiors, Japan Trash Bag, JDM Pen and Coin Holders, X-SP Leather Seats, Seat Heaters
V-bOnE is offline   Reply With QuoteReply With Quote
Old 02-22-2010, 02:27 PM #45
RORYRRFA5 RORYRRFA5 is offline
Junior Member
 
Join Date: Feb 2010
Posts: 1
RORYRRFA5 is on a distinguished road
RORYRRFA5 RORYRRFA5 is offline
Junior Member
 
Join Date: Feb 2010
Posts: 1
RORYRRFA5 is on a distinguished road
WOW!!! I recently found this forum due to the Dealership wanting to charge me $100 for my VSA/TRAC lights being on. I too went through emissions, and they told me that it was like that before I came in. Well I tried the Procedure, and to my avail it worked!!! I just want to that everyone who has done some reserch and figured this out. THANK YOU!!!
RORYRRFA5 is offline   Reply With QuoteReply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Yaw Rate and Acceleration Sensor Zero Point Calibration iDRiVaT4R 5th gen T4Rs 81 08-03-2019 10:41 AM
Zero point didnt work how to turn off "VSC TRAC" & "VSC OFF" & "ABS" lights sciff5 4th Gen T4Rs 6 09-27-2010 12:10 AM
Got the dreaded "check engine" + "VSC off" lights bonedoctor 4th Gen T4Rs 2 11-04-2006 10:33 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 05:39 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2019


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.