User Tag List

Reply
 
Thread Tools Rate Thread Display Modes
Old 02-07-2008, 07:58 PM #1
swimmer2361 swimmer2361 is offline
Member
 
Join Date: Sep 2006
Location: Tucson, AZ
Posts: 160
swimmer2361 is an unknown quantity at this point
swimmer2361 swimmer2361 is offline
Member
 
Join Date: Sep 2006
Location: Tucson, AZ
Posts: 160
swimmer2361 is an unknown quantity at this point
VSC off, TRAC off and check engine light on!

Well its been a while since Ive been on this site but now I have a problem with my runner. I have 2004 sr5 4x4 v6 runner that I took to the dealer to change the oil, after it was there for a full day I came to pick it up and the staff told me that I needed to flush the break and power steering system. So I said I would bring it to them 2 days from then. So I took it to the dealership and they flushed the systems and I took it home. The next morning I was on my way to work when the Check engine light came on and the VSC off and Trac off lights came on. So after work I came back home and had a bit of fun with the VSC and Traction control off (I didn't check the abs), then I called up the dealership. They told me to bring it in for them to check it. I took it to the dealership and they looked at it, and with in 30 minuets I was able to take it home with the lights off (Im betting they just disconnected the battery). The next day(yesterday) when I was on my way to work and the lights came on again. So this morning I took it in , then when I returned after work they told me that the catalytic converter needed to be replaced, and they replaced it free of charge. Im not exactly sure why they gave me a new catalytic converter, because that has nothing to do with the breaking system (VSC, TRAC), so I am betting that the lights will come on again tomorrow morning. Any ideas??
__________________
2004 Toyota 4Runner P265/65/17 Revos

"He took a stock 4runner to charouleau gap!"

http://i106.photobucket.com/albums/m.../DSC009032.jpg
swimmer2361 is offline   Reply With QuoteReply With Quote
Old 02-11-2008, 12:28 PM #2
retco retco is offline
Member
 
Join Date: Dec 2007
Location: birmingham, al
Age: 41
Posts: 194
retco is on a distinguished road
retco retco is offline
Member
 
Join Date: Dec 2007
Location: birmingham, al
Age: 41
Posts: 194
retco is on a distinguished road
whats up bro, I've got a 03 T4R sport my VSC trac, VSC off lights are on also check engine light was on but Auto Zone turned it off and told me cat was bad. 2 days later check engine light hasn't come back on, but i thought if there was really a prob light would come back on, VSC lights still on , so took it to a dealer to have them check it and they are not getting any codes. "Weird". Dealer said bring it in so they could dig alittle deeper for probs. Don't really trust dealers. HOW DID U GET YOUR CAT FOR FREE, WARRENTY, RECALL OR SOMETHING. THANKS
retco is offline   Reply With QuoteReply With Quote
Old 02-11-2008, 04:48 PM #3
swimmer2361 swimmer2361 is offline
Member
 
Join Date: Sep 2006
Location: Tucson, AZ
Posts: 160
swimmer2361 is an unknown quantity at this point
swimmer2361 swimmer2361 is offline
Member
 
Join Date: Sep 2006
Location: Tucson, AZ
Posts: 160
swimmer2361 is an unknown quantity at this point
hello retco,
Well I guess it was the catalytic converter, the lights haven't been back on. The dealer just offered me a new catalytic converter and they told me that it was under warranty. The dealer will probably give you a new one to.

This is all good but it brings the question, why did the VSC off and TRAC off lights come on?? I had played with the car a bit before I took it in, and the VSC/TRAC system did not intervene, this could be a safety risk. I don't think the catalytic converter has ANYTHING to do with the VSC/TRAC system (correct me if I am wrong).
__________________
2004 Toyota 4Runner P265/65/17 Revos

"He took a stock 4runner to charouleau gap!"

http://i106.photobucket.com/albums/m.../DSC009032.jpg
swimmer2361 is offline   Reply With QuoteReply With Quote
Old 02-12-2008, 06:23 AM #4
Good Times's Avatar
Good Times Good Times is offline
Senior Member
 
Join Date: Jan 2003
Location: Sunny Socal
Posts: 1,657
Good Times is on a distinguished road
Good Times Good Times is offline
Senior Member
Good Times's Avatar
 
Join Date: Jan 2003
Location: Sunny Socal
Posts: 1,657
Good Times is on a distinguished road
Emissions have a longer warranty due to federal guidelines so you should be able to warranty those items if they require replacing as per TSB or anything else under the warranty program.

As for the christmas tree lights engaging, sometimes a simple cel can cause the others to light up. the easiest way to diagnose what the root of the cause is by visiting your local Autozone or any other auto part store and rent (for free) a CEL code reader and check for yourself. Sometimes you'll do it for you but for the most part it's easy to do.

Once you get the codes you'll have a better idea what issues your vehicle is experiencing so this will be a good starting point.

Also, these code readers can also clear the codes (the only way to clear the xmas tree lights). Disconnecting your battery does not reset your codes (older vehicles with OBDI can but not OBDII vehicles).

Good luck
Good Times is offline   Reply With QuoteReply With Quote
Old 02-12-2008, 10:10 AM #5
sharp4runr's Avatar
sharp4runr sharp4runr is offline
Elite Member
 
Join Date: Jan 2004
Location: Hoodbridge, Virginia
Age: 39
Posts: 5,078
sharp4runr is on a distinguished road
sharp4runr sharp4runr is offline
Elite Member
sharp4runr's Avatar
 
Join Date: Jan 2004
Location: Hoodbridge, Virginia
Age: 39
Posts: 5,078
sharp4runr is on a distinguished road
If they touched your brake systems they could have broken a one of the ABS sensors and that would cause your VSC system to be faulty.

Or do a search for zero point calibration. There is a thread with instructions on how to clear it up.
sharp4runr is offline   Reply With QuoteReply With Quote
Old 02-14-2008, 04:33 AM #6
retco retco is offline
Member
 
Join Date: Dec 2007
Location: birmingham, al
Age: 41
Posts: 194
retco is on a distinguished road
retco retco is offline
Member
 
Join Date: Dec 2007
Location: birmingham, al
Age: 41
Posts: 194
retco is on a distinguished road
Hey swimmer, The day before all my lights came on, i filled up my 4runner and added a bottle of LUCAS fule treatment"tune up in a bottle", i really think that had something to do with my problem, the mechanic said anytime CHECK ENGINE comes on, so does VSC CHECK and VSC OFF, want to try the zero point calibration but dont really under stand how, or what to use, if i use a Diagnostic tester were can i get one that can do this. Can anyone tell me exactly what to use to do this without a tester.Thanks
retco is offline   Reply With QuoteReply With Quote
Old 02-15-2008, 02:34 PM #7
retco retco is offline
Member
 
Join Date: Dec 2007
Location: birmingham, al
Age: 41
Posts: 194
retco is on a distinguished road
retco retco is offline
Member
 
Join Date: Dec 2007
Location: birmingham, al
Age: 41
Posts: 194
retco is on a distinguished road
VSC LIGHTS OFF, followed TSB and used a ornament hanger, It took about 2 minutes, very simple. That saved me a ton of money.
retco is offline   Reply With QuoteReply With Quote
Old 03-19-2008, 11:34 AM #8
kb7mci kb7mci is offline
Junior Member
 
Join Date: Mar 2008
Location: NW Suburb of Minneapolis
Posts: 2
kb7mci is an unknown quantity at this point
kb7mci kb7mci is offline
Junior Member
 
Join Date: Mar 2008
Location: NW Suburb of Minneapolis
Posts: 2
kb7mci is an unknown quantity at this point
Thumbs down emissions problem? drop any additional load on the engine???

I had the same problem with my 6 month old 2007 4wd 4-runner. I had a bad charcoal canister, and the dealer told me the VSC lights always come on with the check engine light, but implied that the VSC still works... I assured them that as of the snow storm the other day, the VSC was not working.

They could not explain why the VSC is disabled when the check engine light comes on. Sounds dumb to me ...

But I found another reference:

A detected engine problem could mean many things, so Toyota decided to kill anything that could be an additional load on the engine including the VSC system since it causes braking (the ABS does still work though).

I still call the VSC system a safety system and think it was a dumb move, but it at least makes a little sense.
__________________
Mike
kb7mci is offline   Reply With QuoteReply With Quote
Old 05-02-2008, 10:54 AM #9
orokooyaro orokooyaro is offline
Junior Member
 
Join Date: May 2008
Location: New castle delaware
Posts: 1
orokooyaro is an unknown quantity at this point
orokooyaro orokooyaro is offline
Junior Member
 
Join Date: May 2008
Location: New castle delaware
Posts: 1
orokooyaro is an unknown quantity at this point
vcs off

Hi all!
I would like to thank you for invaluable info i got in this forum.After the vsc off, vsc trac and check engine lights popped up in my 2002 4runner, i turned to the internet for trouble-shooting.Found out that my gas cap was loose.I did tighten it and thereafter unhooked battery for 15mins as suggested.The lights went out and the baby has been good since.Thanks for saving me the $$$$!
orokooyaro is offline   Reply With QuoteReply With Quote
Old 05-11-2008, 05:15 AM #10
Naija4Runner's Avatar
Naija4Runner Naija4Runner is offline
Junior Member
 
Join Date: Mar 2008
Location: Lagos
Age: 40
Posts: 13
Naija4Runner is an unknown quantity at this point
Naija4Runner Naija4Runner is offline
Junior Member
Naija4Runner's Avatar
 
Join Date: Mar 2008
Location: Lagos
Age: 40
Posts: 13
Naija4Runner is an unknown quantity at this point
I got the same VSC TRAC/ VSC OFF problem too. The funny thing is that this started after i took my truck to the mechanic to have my fuel tank and injector flushed. I have taken it back twice to have it checked again and they keep saying that it doesnt give any codes and there is nothing wrong with the truck.
I dont belive them and i think they messed up something while dropping the tank and cleaning the injector.
What do you guys think? I need to get back armed with evidence
__________________
2004 Limited V8 4X4
Naija4Runner is offline   Reply With QuoteReply With Quote
Old 05-06-2009, 02:05 PM #11
2wheeldriver 2wheeldriver is offline
Junior Member
 
Join Date: May 2009
Posts: 1
2wheeldriver is an unknown quantity at this point
2wheeldriver 2wheeldriver is offline
Junior Member
 
Join Date: May 2009
Posts: 1
2wheeldriver is an unknown quantity at this point
I have a 2002 runner and last night we had our trac off;vsc off; and check engine light come one. We came to this forum in hopes to find some help--which we did! Turns out, my wife left the gas cap loose! thanks for the help!

I havent visited this forum in a while, but turns out that wasnt the only problem----although i beleive it to be the culprit----also had to replace one of the oxygen sensors--reset the codes--finally, lights stayed off!

Last edited by 2wheeldriver; 10-30-2009 at 01:11 PM. Reason: more problems
2wheeldriver is offline   Reply With QuoteReply With Quote
Old 09-18-2009, 09:07 AM #12
Sgt. Boz Sgt. Boz is offline
Junior Member
 
Join Date: Sep 2009
Posts: 7
Sgt. Boz is on a distinguished road
Sgt. Boz Sgt. Boz is offline
Junior Member
 
Join Date: Sep 2009
Posts: 7
Sgt. Boz is on a distinguished road
I have a good one here.
I have an 04 SR5 V6 w/ 134,000 miles on it. I started it up one day and it shook pretty good for about 30 seconds and then went away. the CEL and VSC/TRAC off lights came on and stayed on. I drove it to work, everything was fine. Started it after 8 hrs. same thing shake for 30 sec. then runs fine. Pulled codes and had a #6 cylinder miss-fire. Changed Plugs. She ran fine for 2 days and then the same thing started. pulled code again , same thing. Swapped #6 coil pack with #4. ran for 2 days problem returned. pulled code #4 miss-fire!!!! yaa problem solved!! not quite. Put #4 pack back on #4 and changed #6 coil pack with new. Ran fine last night. Started it up this morning engine shake again for 30 seconds and CEL blinked for a couple of seconds and then went out, engine drove fine. What the heck??? Same exact problem. I will pull code again once it stays on. What would cause the eninge to shake (like a cylinder isn't firing) for 30 seconds (give or take a couple) and then run fine. No noticable loss of power. gas cap tight, just passed emmisions. I am lost on this one. ANY help would be greatly appreciated. Oh, one more thing. when the CEL was cleared why didn't the VSC/TRAC off light go out? Those are the only light that won't go out. Then come on as soon as the vehicle moves. It stays out for as long as the engine is running and you haven't moved when you first start it up. PLEASE HELP!!!
Sgt. Boz is offline   Reply With QuoteReply With Quote
Old 10-14-2010, 04:23 PM #13
grosse14 grosse14 is offline
Junior Member
 
Join Date: Oct 2010
Posts: 2
grosse14 is on a distinguished road
grosse14 grosse14 is offline
Junior Member
 
Join Date: Oct 2010
Posts: 2
grosse14 is on a distinguished road
Quote:
Originally Posted by Sgt. Boz View Post
I have a good one here.
I have an 04 SR5 V6 w/ 134,000 miles on it. I started it up one day and it shook pretty good for about 30 seconds and then went away. the CEL and VSC/TRAC off lights came on and stayed on. I drove it to work, everything was fine. Started it after 8 hrs. same thing shake for 30 sec. then runs fine. Pulled codes and had a #6 cylinder miss-fire. Changed Plugs. She ran fine for 2 days and then the same thing started. pulled code again , same thing. Swapped #6 coil pack with #4. ran for 2 days problem returned. pulled code #4 miss-fire!!!! yaa problem solved!! not quite. Put #4 pack back on #4 and changed #6 coil pack with new. Ran fine last night. Started it up this morning engine shake again for 30 seconds and CEL blinked for a couple of seconds and then went out, engine drove fine. What the heck??? Same exact problem. I will pull code again once it stays on. What would cause the eninge to shake (like a cylinder isn't firing) for 30 seconds (give or take a couple) and then run fine. No noticable loss of power. gas cap tight, just passed emmisions. I am lost on this one. ANY help would be greatly appreciated. Oh, one more thing. when the CEL was cleared why didn't the VSC/TRAC off light go out? Those are the only light that won't go out. Then come on as soon as the vehicle moves. It stays out for as long as the engine is running and you haven't moved when you first start it up. PLEASE HELP!!!
Did you resolve your issue. I have similar observations on my 4-runner. I have 2004 with 140,000 with the CEL coming on for the last 6-9 months or so. I also have some intermittent rough idle when I start it about 5-10 seconds. The dealer has suggested gasket and inspection of valves Please keep the posts coming, as Iím very interested in what fixes your problems.
grosse14 is offline   Reply With QuoteReply With Quote
Old 12-05-2010, 12:44 AM #14
kelx03 kelx03 is offline
Junior Member
 
Join Date: May 2008
Location: fl
Posts: 3
kelx03 is an unknown quantity at this point
kelx03 kelx03 is offline
Junior Member
 
Join Date: May 2008
Location: fl
Posts: 3
kelx03 is an unknown quantity at this point
I have a 2003 4runner and tonight the Check Engine light came on and VSC Trac lights lit up...I am not sure what happened...I had this issue a few months back and had regular mechanic run a diagnostic but ran out of time as I didn't want to leave it. They checked the rest of the truck and cleared it to drive/reset the lights. 2 days later, I was still nervous and checked the oil and was VERY low...so not sure what the issue was then.

Now, I am not sure what it is as my oil was changed two weeks ago and oil. Before I take in, I checked gas cap but read somewhere else you had to unhook the battery afterwards?

Any assistance greatly appreciated to getting cleared or giving the mechanic an idea where to look....
kelx03 is offline   Reply With QuoteReply With Quote
Old 03-20-2011, 01:43 AM #15
raj raj is offline
Junior Member
 
Join Date: Mar 2011
Posts: 1
raj is on a distinguished road
raj raj is offline
Junior Member
 
Join Date: Mar 2011
Posts: 1
raj is on a distinguished road
VSC Trac lights on

Hi all- I have 2004 T 4Runner v6 with 90K miles on it. Every time I have to park it on an inclined driveway or space and put on the emergency brake, the vsc trac lights as well as the check engine sign comes on. The last time it happened it was a few days before I had to have the 90K mile service. And all the warning lights went away. They changed the battery as well, so I am guessing that is what ended up curing the faulty signs as well. Does anyone have any ideas or similar experiences? How easy or difficult would it be to disconnect and reconnect the battery?
Thanks
raj is offline   Reply With QuoteReply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 05:13 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2019


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.