User Tag List

Reply
 
Thread Tools Rate Thread Display Modes
Old 12-17-2009, 09:04 PM #1
pmellen pmellen is offline
Junior Member
 
Join Date: Dec 2009
Location: Burlington, VT
Posts: 1
pmellen is on a distinguished road
pmellen pmellen is offline
Junior Member
 
Join Date: Dec 2009
Location: Burlington, VT
Posts: 1
pmellen is on a distinguished road
ABS, BRAKE, VSC TRAC, VSC OFF, Speedometer not working

Hi all -
Facts:

- 2004 Toyota 4runner sport v6, 78K miles.
- Regularly serviced by Toyota (every 5K), extended warranty to 100K
- Three days ago I had my car serviced by my local Toyota dealer. At that time they replaced the front brake calipers (under warranty) as well as the front pads/rotors.
- I have driven the car 6 times since then, for the following mileages (30,350,4,4,4,4).

I was just driving and the following lights just went on simultaneously, after about 200 meters: ABS, BRAKE(!), VSC TRAC, VSC OFF

I then stopped, pulled over and read my manual, which said to get somewhere safe and call my dealer. After turning my car off and then on again, I decided to drive the 3miles to my hotel. Throughout that trip my Speedometer read 0mph. The lights stayed on throughout that trip and are lit if a restart my car. (Also, the thermometer reads 1 degree but I know that it is 8-10 degrees out.)

Any idea what is causing this? Could this be catastrophic or is it likely something wrong with recent brake replacement?

I am planning to have this towed to a local Toyota dealer tomorrow, but I am 350 miles from home. Is there anything else I should/could do?

Any diagnosis or guidance would be greatly appreciated. Thanks.
pmellen is offline   Reply With QuoteReply With Quote
Old 12-17-2009, 09:50 PM #2
CJ3Flyr's Avatar
CJ3Flyr CJ3Flyr is offline
Super Moderator
 
Join Date: Jan 2008
Location: Metro ATL & Cape Coral, FL
Age: 58
Posts: 6,276
CJ3Flyr will become famous soon enough
CJ3Flyr CJ3Flyr is offline
Super Moderator
CJ3Flyr's Avatar
 
Join Date: Jan 2008
Location: Metro ATL & Cape Coral, FL
Age: 58
Posts: 6,276
CJ3Flyr will become famous soon enough
Quote:
Originally Posted by pmellen View Post
Hi all -
Facts:

- 2004 Toyota 4runner sport v6, 78K miles.
- Regularly serviced by Toyota (every 5K), extended warranty to 100K
- Three days ago I had my car serviced by my local Toyota dealer. At that time they replaced the front brake calipers (under warranty) as well as the front pads/rotors.
- I have driven the car 6 times since then, for the following mileages (30,350,4,4,4,4).

I was just driving and the following lights just went on simultaneously, after about 200 meters: ABS, BRAKE(!), VSC TRAC, VSC OFF

I then stopped, pulled over and read my manual, which said to get somewhere safe and call my dealer. After turning my car off and then on again, I decided to drive the 3miles to my hotel. Throughout that trip my Speedometer read 0mph. The lights stayed on throughout that trip and are lit if a restart my car. (Also, the thermometer reads 1 degree but I know that it is 8-10 degrees out.)

Any idea what is causing this? Could this be catastrophic or is it likely something wrong with recent brake replacement?

I am planning to have this towed to a local Toyota dealer tomorrow, but I am 350 miles from home. Is there anything else I should/could do?

Any diagnosis or guidance would be greatly appreciated. Thanks.
Occasionally people see that in the very cold (minus the '0' speedo indication"). For the most part the "have it towed in" thing is legally driven and is probably not necessary IMHO (don't sue me! ). You don't have ABS brakes or Vehicle Stability Control. It's old-school in this condition, like an early 80's car (which we all survived somehow).

Have it checked out, the extended warranty should cover it.

Last edited by CJ3Flyr; 12-17-2009 at 09:54 PM.
CJ3Flyr is offline   Reply With QuoteReply With Quote
Old 12-19-2009, 11:10 AM #3
V8Limited4wd's Avatar
V8Limited4wd V8Limited4wd is offline
Member
 
Join Date: Mar 2004
Location: NoVA
Posts: 756
V8Limited4wd is on a distinguished road
V8Limited4wd V8Limited4wd is offline
Member
V8Limited4wd's Avatar
 
Join Date: Mar 2004
Location: NoVA
Posts: 756
V8Limited4wd is on a distinguished road
how did you get the calipers replaced under warranty? did you pay for the rotors and pads? i have the extended warranty and im expecting to have the frozen caliper issue when the time comes to replace the pads and rotors, but not at the dealer.
__________________
2004 V8 LIMITED 4WD
[INT/EXT] 06+ Projectors & HIDs/LEDs/CDN Hood deflector/SS Bull Bar & Hitch Step
[ENGINE] aFe Pro DRY S Air Filter/DT Headers/TRD Dual Exhaust
[WHEELS/SUSPENSION] OEM 20" Rims(265/50R20)/Dobinsons Suspension 2" lift
V8Limited4wd is offline   Reply With QuoteReply With Quote
Old 07-24-2013, 06:03 PM #4
bigmacj bigmacj is offline
Junior Member
 
Join Date: Jul 2013
Location: Houston
Posts: 2
bigmacj is on a distinguished road
bigmacj bigmacj is offline
Junior Member
 
Join Date: Jul 2013
Location: Houston
Posts: 2
bigmacj is on a distinguished road
Same problem - any resolution?

I have this exact same problem now.

I had my calipers replaced on the front, about two weeks later the abs/brake lights came on with the VSC TRAC and VCS OFF, and then the speedometer stopped working shortly thereafter.

Firestone did the brake job, and claims that this is all unrelated. It seems highly coincidental that this would be the case, but i guess stranger things have happened. The OP never followed up, so i'm curious what my options are here...

Firestone tried to replace the speed sensor and determined that wasn't the problem, and now they are sending me to the dealer. Could it be related to the caliper work that they did?
bigmacj is offline   Reply With QuoteReply With Quote
Old 07-24-2013, 06:11 PM #5
TheeMikeB's Avatar
TheeMikeB TheeMikeB is offline
Senior Member
 
Join Date: Dec 2009
Location: Walnut Creek CA
Posts: 1,167
TheeMikeB is on a distinguished road
TheeMikeB TheeMikeB is offline
Senior Member
TheeMikeB's Avatar
 
Join Date: Dec 2009
Location: Walnut Creek CA
Posts: 1,167
TheeMikeB is on a distinguished road
FYI this is a 4 year old thread and the OP appears to only have 1 post. You may want to search a bit for some answers.
__________________
85 Xtracab, 3Link Front, Marlin Dual Ultimate, Double Locked on 37s
TheeMikeB is offline   Reply With QuoteReply With Quote
Old 07-24-2013, 06:24 PM #6
bigmacj bigmacj is offline
Junior Member
 
Join Date: Jul 2013
Location: Houston
Posts: 2
bigmacj is on a distinguished road
bigmacj bigmacj is offline
Junior Member
 
Join Date: Jul 2013
Location: Houston
Posts: 2
bigmacj is on a distinguished road
Quote:
Originally Posted by TheeMikeB View Post
FYI this is a 4 year old thread and the OP appears to only have 1 post. You may want to search a bit for some answers.
I recognize that, but I did search and this is the only one that also mentioned a recent caliper replacement.

While the series of indicators seems to be common based on my reading, I'm trying to determine if there is any way I can lay blame on Firestone for causing a problem while replacing the calipers.

I have service scheduled tomorrow with Toyota, but if the OP, or anyone, could say "oh ya, they obviously did X and should do Y to fix it," that would be helpful. If it's dumb luck and i'm out $2,500 to replace the module, then so be it. I just thought the chances of it happening to at least one other person meant that maybe it wasn't random, but related.

Thanks.
bigmacj is offline   Reply With QuoteReply With Quote
Old 07-24-2013, 07:47 PM #7
TheeMikeB's Avatar
TheeMikeB TheeMikeB is offline
Senior Member
 
Join Date: Dec 2009
Location: Walnut Creek CA
Posts: 1,167
TheeMikeB is on a distinguished road
TheeMikeB TheeMikeB is offline
Senior Member
TheeMikeB's Avatar
 
Join Date: Dec 2009
Location: Walnut Creek CA
Posts: 1,167
TheeMikeB is on a distinguished road
What is the year and model 4runner you have?


You might try sending the OP a PM too.
__________________
85 Xtracab, 3Link Front, Marlin Dual Ultimate, Double Locked on 37s
TheeMikeB is offline   Reply With QuoteReply With Quote
Old 09-02-2013, 10:55 PM #8
fourwd1's Avatar
fourwd1 fourwd1 is offline
Moderator
 
Join Date: Jun 2004
Location: the Socialist State of Maryland
Posts: 11,018
Real Name: Soylent Green sales
fourwd1 has a spectacular aura about fourwd1 has a spectacular aura about fourwd1 has a spectacular aura about
fourwd1 fourwd1 is offline
Moderator
fourwd1's Avatar
 
Join Date: Jun 2004
Location: the Socialist State of Maryland
Posts: 11,018
Real Name: Soylent Green sales
fourwd1 has a spectacular aura about fourwd1 has a spectacular aura about fourwd1 has a spectacular aura about
Quote:
Originally Posted by TheeMikeB View Post
What is the year and model 4runner you have?


You might try sending the OP a PM too.
Or better yet star a new thread that specifically delineates your problems and solutions.
__________________
- the Internet - the mother-ship of people who don't know much and aren't afraid to go public
'84 4Runner - ARBed 5.29s F&R, 4.7 & 2.28 t-cases, 2" drive train lift, BudBuilt x-member/skid, 30 spl Longs
'83 Toy P/U - Buick 231 V6, Holley 4 bbl, Weiand intake, Downey headers, TH350 w/700R4 low gearset,
'89 4Runner SR5 - stock
fourwd1 is offline   Reply With QuoteReply With Quote
Old 01-25-2015, 10:05 AM #9
theblackone08 theblackone08 is offline
Junior Member
 
Join Date: Jan 2015
Location: Oklahoma
Posts: 1
theblackone08 is on a distinguished road
theblackone08 theblackone08 is offline
Junior Member
 
Join Date: Jan 2015
Location: Oklahoma
Posts: 1
theblackone08 is on a distinguished road
2001 4 Runner 3.4L 2WD...My speedometer, my odometer doest not work, my ABS light, VSC TRAC, VSC OFF, CHECK ENGINE, BRAKE light are ON....I will like to get this fix ( I change the ABS, VSC computer under the dage, and the speed sensor on the transmission..without success)....
theblackone08 is offline   Reply With QuoteReply With Quote
Old 04-20-2018, 10:37 PM #10
Muggsy Muggsy is offline
Junior Member
 
Join Date: Apr 2018
Location: Kentucky
Posts: 3
Muggsy is on a distinguished road
Muggsy Muggsy is offline
Junior Member
 
Join Date: Apr 2018
Location: Kentucky
Posts: 3
Muggsy is on a distinguished road
2003 4runner, v8, 4wd

I had this same problem, took it to advance auto and the reader said bad abs sensors, ecm bad and something else. Anyway, got to poking around and discovered that the tail pipe had broken between muffler and end of tail pipe. Exhaust had melted wire harness for rear abs wheel sensors. Retaped wires and tidied up harness, fixed muffler and problem fixed. Fyi.
Shorted wheel sensors will reek havoc.
Muggsy is offline   Reply With QuoteReply With Quote
Old 04-20-2022, 06:20 PM #11
caisen4 caisen4 is offline
Junior Member
 
Join Date: Apr 2022
Location: Wilmington
Posts: 2
caisen4 is on a distinguished road
caisen4 caisen4 is offline
Junior Member
 
Join Date: Apr 2022
Location: Wilmington
Posts: 2
caisen4 is on a distinguished road
I fixed it

Hey all,

I have a 2001 4runner limited. Not sure if this method works on other years but thought I would share. I had lights on my dashboard including brake, vsc, vsc off, trac and check engine lights. The speedometer or odometer wasn’t working either. The code I was getting was P0500. A local Toyota repair shop told me I needed a ECM or Engine Computer Module which new are $1,700 to $2,500 or used around $250 - $300 with no guarantee that it would solve my issue because the used one could be bad as well. So I ended up installing a used ECM and that didn’t work.. keep in mind when you install a different ECM you have to get your keys to work with that new computer which costs another $250-$500 because the key has a chip in it which is an immobilizer key. This is only on some models, you key will have a small dot at the bottom, if so then it has a chip in it.

So since that didn’t work I ended up replacing the ABS TRAC VSC COMPUTER CONTROL MODULE and sure as shit it worked. The second I cranked up my car all the lights went off and speedometer was working.

So, located under the driver side dash where the break peddle is - I would unplug and plug back in your ABS TRC VSC COMPUTER CONTROL MODULE to make sure its connected properly. If that doesn't work order one off ebay and replace it. For my 2001 the part number was 89540-35270. I would start with that first because uninstalling and installing takes 10 minutes if that vs going through the process of replacing the ECM, getting keys fixed etc.

Good luck!
caisen4 is offline   Reply With QuoteReply With Quote
Old 04-20-2022, 06:23 PM #12
caisen4 caisen4 is offline
Junior Member
 
Join Date: Apr 2022
Location: Wilmington
Posts: 2
caisen4 is on a distinguished road
caisen4 caisen4 is offline
Junior Member
 
Join Date: Apr 2022
Location: Wilmington
Posts: 2
caisen4 is on a distinguished road
Quote:
Originally Posted by theblackone08 View Post
2001 4 Runner 3.4L 2WD...My speedometer, my odometer doest not work, my ABS light, VSC TRAC, VSC OFF, CHECK ENGINE, BRAKE light are ON....I will like to get this fix ( I change the ABS, VSC computer under the dage, and the speed sensor on the transmission..without success)....

See below what I posted
caisen4 is offline   Reply With QuoteReply With Quote
Reply

Tags
abs , brake , speedometer , vsc

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 02:37 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2022 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2022 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2022 DragonByte Technologies Ltd.
***This site is an unofficial Toyota site, and is not officially endorsed, supported, authorized by or affiliated with Toyota. All company, product, or service names references in this web site are used for identification purposes only and may be trademarks of their respective owners. The Toyota name, marks, designs and logos, as well as Toyota model names, are registered trademarks of Toyota Motor Corporation***Ad Management plugin by RedTyger
 
Copyright © 2020